1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

After completing cleaning steps, tcpip corrupted on every restart

Discussion in 'Malware Removal' started by Sinjin Zoren, Jun 28, 2010.

  1. Sinjin Zoren

    Sinjin Zoren Private E-2

    Running Windows XP /SP3


    I ran through the recommended steps to remove an infection. This fixed my original problem (most noticeably, DNS hijacking), but I am still having an issue:

    Whenever my system reboots, internet is lost. It appears the TCPIP stack is being corrupted (IPCONFIG/ALL returns the error: "Access is denied...Unable to open registry key for tcpip.") I understand this can happen due to the malware removal process; however, the usual fixes (e.g. winsockxpfix.exe) do not help. Further, once I do get internet up and running (see below), it will work fine until a reboot occurs, at which point tcpip is re-corrupted. Is this the work of a stubborn virus still present in my system?

    I have discovered, quite by accident, the following 2-step method to restore internet access. So far, nothing else has worked:

    1. Uninstall and reinstall my D-Link drivers. This results in a normal-looking IPCONFIG/ALL, and I can obtain a network address and connect. HOWEVER I can't connect to any web sites (can ping IP numbers but not names).
    2. Run combofix. Miraculously this restores full connectivity.

    I am attaching the original logs from when I ran through your infection-removal steps. Please note, however, that I have no Root Repeal log (that process crashed with a BSOD.) Also, since I have run combofix numerous times in order to restore internet (I know, I know, please don't yell at me! :-o) I only have the most recent log for that program.

    Thanks for any help you can give!

    Attached Files:

  2. chaslang

    chaslang MajorGeeks Admin - Master Malware Expert Staff Member

    Welcome to Major Geeks!

    The infection you had/have is known to infect router hardware. If you have a router hooked up then you need to follow the instructions for your hardware and reset it to factory default settings. Normally there is a recessed push button type switch that needs to be held down for some number of seconds to do this. After resetting to factory defaults on your router, you will need to reconfigure the router for your network if you have made any changes to the default network setup.

    Then fix you D-Link drivers as necessary and see where things stand.

    Also note, if you need more help, you will have to post updated logs since yours are a month old. You will have to install current versions of SUPERAntispyware (requires and uninstall 1st), Malwarebytes, and also MGtools.
  3. Sinjin Zoren

    Sinjin Zoren Private E-2

    I followed your suggestion and it seems to have done the trick. Thanks so much! :-D (I had no idea a virus could infect the router itself, but it makes a lot of sense given my symptoms.)

    I will go ahead and run fresh scans as you suggested, to make sure nothing lingers on my system. This may take a couple days.

    Thanks again!
  4. chaslang

    chaslang MajorGeeks Admin - Master Malware Expert Staff Member

    You're welcome. If you don't require anymore help, then you should complete the below final instructions.

    If you are not having any other malware problems, it is time to do our final steps:
    1. We recommend you keep SUPERAntiSpyware and Malwarebytes Anti-Malware for scanning/removal of malware. Unless you purchase them, they provide no protection. They do not use any significant amount of resources ( except a little disk space ) until you run a scan.
    2. If we had you use ComboFix, uninstall ComboFix (This uninstall will only work as written if you installed ComboFix on your Desktop like we requested.)
      • Click START then RUN and enter the below into the run box and then click OK. Note the quotes are required
      • "%userprofile%\Desktop\combofix" /uninstall
        • Notes: The space between the combofix" and the /uninstall, it must be there.
        • This will uninstall ComboFix and also reset hidden files and folders settings back to Windows defaults.
    3. Go back to step 6 oof the READ ME and renable your Disk Emulation software with Defogger if you had disabled it.
    4. Any other miscellaneous tools we may have had you install or download can be uninstalled and deleted.
    5. If we had you download any registry patches like fixme.reg or fixWLK.reg (or any others), you can delete these files now.
    6. If running Vista, it is time to make sure you have reenabled UAC by double clicking on the C:\MGtools\enableUAC.reg file and allowing it to be added to the registry.
    7. Go to add/remove programs and uninstall HijackThis.
    8. Goto the C:\MGtools folder and find the MGclean.bat file. Double click on this file to run this cleanup program that will remove files and folders
      related to MGtools and some other items from our cleaning procedures.
    9. If you are running Win 7, Vista, Windows XP or Windows ME, do the below:
      • Refer to the cleaning procedures pointed to by step 7 of the READ ME
        for your Window version and see the instructions to Disable System Restore which will flush your Restore Points.
      • Then reboot and Enable System Restore to create a new clean Restore Point.
    10. After doing the above, you should work thru the below link:

Share This Page

MajorGeeks.Com Menu

MajorGeeks.Com \ All In One Tweaks \ Android \ Anti-Malware \ Anti-Virus \ Appearance \ Backup \ Browsers \ CD\DVD\Blu-Ray \ Covert Ops \ Drive Utilities \ Drivers \ Graphics \ Internet Tools \ Multimedia \ Networking \ Office Tools \ NEW! PC Games \ System Tools \ Macintosh \ Demonews.Com \ Top Downloads

MajorGeeks.Com \ News (Tech) \ Off Base (Other Websites News) \ Way Off Base (Offbeat Stories and Pics)

Social: Facebook \ YouTube \ Twitter \ Tumblr \ Pintrest \ RSS Feeds