1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Arrow keys will not function to get into safe mode

Discussion in 'Software' started by rich5lee, Mar 7, 2012.

  1. rich5lee

    rich5lee Private E-2

    Arrow keys will not function to get into safe mode.

    I have been trying to get into "safe mode" to see about doing a system restore, but the arrow keys do not allow movement to select the safe mode, due to a possible virus or malware, please help, system info below;

    I have a Gateway DX 4200-09 Quad core AMD, running Windows Vista Home Premium 32 bit. The keyboard is USB, (I also tried plugging in a PS2 keyboard and arrow keys still did not allow movement).

    Thank you in advance.
    Last edited: Mar 7, 2012
  2. sach2

    sach2 Major Geek Extraordinaire

    A quick thought is that you must restart for a PS/2 keyboard to be recognized. If you just swapped keyboards without restarting then try rebooting.
  3. rich5lee

    rich5lee Private E-2

    Yes, I did restart (due to a virus or malware, it take a very long time) but the arrow keys on either keyboard do not allow movement, to get into safe mode, to do a system restore.

    After it tries to start, it will hang up, I am sure it is due to a virus and or malware. I just need to get the darn arrow keys to move, so I can get in "Safe mode" to do a system restore (lol), this has had me banging my head on the wall...
  4. Caliban

    Caliban I don't need no steenkin' title!

    Greetings, rich5lee...

    I copy that you are trying to boot into Safe Mode.

    Will Windows boot normally? If so, you might try running msconfig - under the Boot tab, select one of the 'Safe boot' options ('Minimal' is preferred), then see if you can access a restore point that way...
  5. Earthling

    Earthling Interplanetary Geek

    You may be able to do a system restore without booting to Safe Mode. In Vista (and 7) you can type 'system restore' into the Start search box and hit Enter - if your keyboard is working of course!
    Last edited: Mar 7, 2012
  6. rich5lee

    rich5lee Private E-2

    I am not sure what to try now, after reading the below information;

    Problems that can occur by forcing Safe Mode using the System Configuration Utility

    Maybe, if your computer has been infected with Malware ??? I think this could be my problem, not sure, I am trying to gather all the necessary information, so I do not screw up, lol

    I read this;

    On a computer that is operating properly this is normally not a problem. Unfortunately, though, a new trick that some of the more recent malware are using is to delete certain Windows Registry keys so that your computer can not properly boot into safe mode. It is in these situations that using the System Configuration utility to boot into safe mode can cause the computer to become inoperable for many users.
    This is because once you set the computer to boot into Safe Mode using /Safeboot, it will continuously attempt to start Safe Mode until the /safeboot argument is removed from the boot.ini. Since the malware is not allowing us to actually boot into safe mode, you have no way of getting to a point where you can run the System Configuration utility again to uncheck the*/Safeboot*option. Thus, you are stuck with a computer constantly attempting to get into safe mode and not being able to do so.
    If a situation like this has happened to you it is possible to fix this problem by renaming your boot.ini file. The first step would be to use a*boot disk*to start your computer. If your computer does not have a floppy disk, then you can typically boot off the Windows CD that came with your computer in order to access the Windows Recovery Console. More information about the Windows Recovery Console can be found*here. Once booted to a*command*prompt, you would simply rename your*C:\Boot.ini*file to another name like*C:\Boot.ini.bak. The command to rename the file at the command prompt is:
    ren C:\Boot.ini Boot.ini.bak
    Once the file is renamed, you can then remove the*boot*disk*and reboot your computer to get back to normal mode. When booting up after the rename, do not be surprised if you see an error stating that you do not have a valid Boot.ini file. When you get back to normal Windows mode, you can then rename*C:\Boot.ini.bak*to*C:\Boot.ini*and run Msconfig again to remove the /safeboot flag.
    It is not uncommon when people are helping you troubleshoot your computer that they tell you to enter Safe Mode. With this tutorial you should now know how to enter Safe Mode when it is required.

    So, I am concerned, maybe I should run some Malware / virus program first, before I try a MSCONFIG, and which application should I try to run, all suggestions to help on this, are greatly appreciated.

  7. Earthling

    Earthling Interplanetary Geek

    Did you try this?

  8. dave.m

    dave.m Private First Class

    I suspect that you are trying to do a system restore to a point BEFORE you think you were infected.
    Have you run full scans with your security software programs and also Malwarebytes and Superantispyware?

    You could also run Dr.Web CureIt!

    Then try to get into safe mode.

  9. rich5lee

    rich5lee Private E-2

    I will try this 'system restore' in the morning, my pain levels are sky-rocketing, got to go take a lot of my pain meds, I will let you know. Thanks to all and I still have a lot of reading to do also, thanks again... :)

Share This Page

MajorGeeks.Com Menu

MajorGeeks.Com \ All In One Tweaks \ Android \ Anti-Malware \ Anti-Virus \ Appearance \ Backup \ Browsers \ CD\DVD\Blu-Ray \ Covert Ops \ Drive Utilities \ Drivers \ Graphics \ Internet Tools \ Multimedia \ Networking \ Office Tools \ NEW! PC Games \ System Tools \ Macintosh \ Demonews.Com \ Top Downloads

MajorGeeks.Com \ News (Tech) \ Off Base (Other Websites News) \ Way Off Base (Offbeat Stories and Pics)

Social: Facebook \ YouTube \ Twitter \ Tumblr \ Pintrest \ RSS Feeds