1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Boot sector/MBR repair on slave drive?

Discussion in 'Software' started by dlb, Jul 11, 2008.

  1. dlb

    dlb MajorGeek

    I have an older laptop with a slightly corrupt HD. If I put it in an enclosure and connect thru USB on a functional tower, I can access the drive and all the data. However, on the laptop, it doesn't even see the drive. I have tried different drives on the laptop and they worked, so I know the MoBo is OK. If I run a low level diagnostic like Hitachis DFT it sees the drive and it passes the diag, but other tests do not see the drive, and the laptop does not see the drive, so I think it's a boot sector/MBR or file table issue. Is there a way to run fixboot or fixmbr when the drive is connected thru the enclosure/USB port? Does anyone have any other ideas as to how I can get this laptop to recognize the drive?


    (...I'm in a bit of a hurry with this.... )
  2. mcadam

    mcadam Major Amnesia

    Is the laptop running off battery or plugged in to power?

    It's surprising how this can make a difference when powering external devices
  3. dlb

    dlb MajorGeek

    It's plugged in to the power. I also tried it with the battery removed. I used a bootable utility CD to reset the boot partition as active and I ran a MBR/fixboot using the same utility CD. This got the drive to boot as far as the Windows XP logo screen with the scrolling bar underneath.... it sat there scrolling for about 30 seconds, flashed a BSOD and rebooted, and now it's back at square one where the PC doesn't even recognize the drive. I ran another diagnostic which reported "defective device; corrupt sectors cannot be repaired" so I guess that about sums it up.... HD DOA... :( I was able to save 90% of the users data by going thru a USB port on a functioning tower, so it isn't a total loss, and the drive still reads as an external also.... I'm assuming the damaged/defective sectors or clusters are in the part of the drive that tells the PC about active partitions and boot sectors.... then again, I'm no expert on HD architecture.... at least the data was saved....
  4. ernie16

    ernie16 Private E-2

    USB external hard drive is not indicated in "My computer" but is recognitized in the device manger area* there's "no local disk d:" There is much info in the hard drive* it does work* I was formating another hard drive "internal" with xp home* when I lost the d: drive* so HELP ME PLEASE* So I can put it back on* and keep all my info on my 80gig hard drive*it's a MAXTOR 4 RO8OLO USB DEVICE* "HOW TO MAKE IT RECOGIZE AGAIN" ? (LOCAL DISK D:)
  5. Lev

    Lev MajorGeek

    Ernie16 - please start a new thread with your own issue rather than hijacking another person's thread. It makes it very difficult for the Original Poster (OP) to follow subsequent advice given if it is mixed in with advice to you post too.

    Thanks :)

Share This Page

MajorGeeks.Com Menu

MajorGeeks.Com \ All In One Tweaks \ Android \ Anti-Malware \ Anti-Virus \ Appearance \ Backup \ Browsers \ CD\DVD\Blu-Ray \ Covert Ops \ Drive Utilities \ Drivers \ Graphics \ Internet Tools \ Multimedia \ Networking \ Office Tools \ NEW! PC Games \ System Tools \ Macintosh \ Demonews.Com \ Top Downloads

MajorGeeks.Com \ News (Tech) \ Off Base (Other Websites News) \ Way Off Base (Offbeat Stories and Pics)

Social: Facebook \ YouTube \ Twitter \ Tumblr \ Pintrest \ RSS Feeds