1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Can’t load rtl70.bpl

Discussion in 'Software' started by Trevina, Apr 2, 2006.

Thread Status:
Not open for further replies.
  1. Trevina

    Trevina Private E-2

    Hi folks,

    When I try to delete a favorite, rename etc or to view > source, I get this error message

    Can’t load rtl70.bpl

    How do I sort this out? I have tried various registry fix software. Nothing is working.

    The error also keeps coming when I right click to delete anything on dsktop.

    Please help.

  2. star17

    star17 MajorGeek

    That's a Borland Delphi 7 runtime library file; do you use programs from Delphi or have recently downloaded some type of image converter?
  3. Trevina

    Trevina Private E-2

    I do not know anything to do with Delphi but I may have recently downloaded some type of image converter.

    I am unable to restore the computer to a time before the problem began.
  4. star17

    star17 MajorGeek

    Perform a search on your computer for files ending in .bpl (include the period), and post the list it finds; perhaps we can track down what program is causing it by what folder is using it.

    It should look something like this:

    Directory of C:\Program Files\X-Setup Pro\bin

    DCXSPR~1 BPL 206,848 04-16-04 8:09p dcXSPRuntime.bpl
    DESIGN~1 BPL 625,152 08-09-02 5:00p designide70.bpl
    RTL70 BPL 778,240 08-09-02 5:00p rtl70.bpl
    VCL70 BPL 1,381,376 08-09-02 5:00p vcl70.bpl
    VCLACT~1 BPL 276,480 08-09-02 5:00p vclactnband70.bpl
    VCLX70 BPL 215,040 08-09-02 5:00p vclx70.bpl
    6 file(s) 3,483,136 bytes
  5. Trevina

    Trevina Private E-2

    It said...

    Search is complete. There are no results to display.

  6. star17

    star17 MajorGeek

    Let's try this: open Notepad, copy/paste the following into a new text file, and save it as findfile.bat to your desktop

    dir c:\*.bpl /s > files.txt
    notepad files.txt

    Locate the findfile.bat and double-click it. Ity should open notepad with some text in it. If so, copy/paste it here.

    If it returns empty text, run a registry cleaner and see if it deletes a bad entry for that file. Make sure you have your reg cleaner set to make an automatic backup.
  7. Trevina

    Trevina Private E-2

    Hope I did it right. This is what came up on notepad:

    Volume in drive C is VAIO
    Volume Serial Number is D489-679F

    Does not seem right?
  8. star17

    star17 MajorGeek

    That's all the text it posted? It should look like my post #4 above, with the program information under the drive info. Reopen the file again, it's searching your system and sometimes takes a few minutes.
  9. Trevina

    Trevina Private E-2

    That is all it posted. Give me a moment. I will do it again.
  10. Trevina

    Trevina Private E-2

    Should I give it longer? It is still giving me the same info. That is

    Volume in drive C is VAIO
    Volume Serial Number is D489-679F

    Nothing more!
  11. star17

    star17 MajorGeek

    Nope, that's more than long enough; I'm thinking you had a program installed that used that .bpl file, uninstalled it and it left some junk behind.

    Do you have a registry cleaner installed? If so, have you run it lately? An unused entry like that would likely be removed with a decent reg cleaner.

    If you don't have one installed, I use and recommend this one:


    Make sure you have any registry cleaner set to make a backup before using.

    ~edit~ Check this link; do you or ahve you had any of the programs listed installed at one time?

  12. Trevina

    Trevina Private E-2

    Thanks for your help. Yes, I have a registry cleaner and have tried various ones over the last week.

    I will try the one you recommend and post the results here.

    Thanks again. I appreciate your help.

  13. star17

    star17 MajorGeek

    No problem; don't sweat it, we'll track it down :)
  14. Trevina

    Trevina Private E-2

  15. star17

    star17 MajorGeek

    Okay, let us know what happens after your run a registry cleaner and we'll go from there.
  16. Trevina

    Trevina Private E-2

    I run the registry cleaner and the problem still persists!
  17. Matacumbie

    Matacumbie Rocky Top

    I agree with Star17, you must have installed some kind of Image Converter that has added something to the right-click menu, a bad context menu handler.

    Download this file http://nwvault.ign.com/fms/Download.php?id=19616, unzip it and follow the prompts. This is an installer that will put three files, rtl70.bpl, vcl70.bpl, and vclx70.bpl, in your System directory. These files are needed for programs built with Delphi 7.

    That should solve your issue and maybe the program that was causing it will be listed on the right-click option.

    Let us know.

  18. Trevina

    Trevina Private E-2

    Well, I followed your directions Matacumbie. After unzipping it, I followed the prompts though am not sure if the last step was executed.

    Now the error message is:

    Can’t load PKIECtr7.bpl

    I am not sure if am now better off, badly off or just there. The message appears when I attempt to view > source, remove or rename favourites and in some instances of right clicking.

    I appreciate your help.

  19. Matacumbie

    Matacumbie Rocky Top

    OK. Do you have a program called ReaConverter installed?

  20. Trevina

    Trevina Private E-2

    Yes I do! How do you know!!!:rolleyes:

    I do not need it actually, I should remove it.
Thread Status:
Not open for further replies.

Share This Page

MajorGeeks.Com Menu

MajorGeeks.Com \ All In One Tweaks \ Android \ Anti-Malware \ Anti-Virus \ Appearance \ Backup \ Browsers \ CD\DVD\Blu-Ray \ Covert Ops \ Drive Utilities \ Drivers \ Graphics \ Internet Tools \ Multimedia \ Networking \ Office Tools \ NEW! PC Games \ System Tools \ Macintosh \ Demonews.Com \ Top Downloads

MajorGeeks.Com \ News (Tech) \ Off Base (Other Websites News) \ Way Off Base (Offbeat Stories and Pics)

Social: Facebook \ YouTube \ Twitter \ Tumblr \ Pintrest \ RSS Feeds