1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Can I install windows 7 on a Dell Inspiron 5150?

Discussion in 'Software' started by B_Radical, Apr 30, 2010.

  1. B_Radical

    B_Radical Private E-2

    Hi all
    Basically the question is in the title.
    I have a Inspiron 5150 and she was working fine with xp pro on it but decided I would try 7. The install went along swimmingly but at first boot after the windows splash screen I got a BSOD. The error is driver_IRQL_not_less_or_equal. Start up repair It boots up fine in safe mode and checking the device manager I found that there were a few driver problems. So I went to the Dell site and got the few I needed and then found that according to Dell the 5150 does not support Windows 7, yet several searches over the last week has told me allot of people are running 7 on the same notebook.
    I installed all the drivers it would let me (some came up with an error saying "only for XP") and now the only two that are flagged are Network Controller and PCI Modem.
    I do not have the original drivers disk that came with it. The service tag number is GL6KB1S
    If anyone has any answers or things I may need to try I'd be more than happy to hear them.
  2. 3eee3

    3eee3 Private E-2

    On the blue screen, it should indicate the problem file. Post that and we'll know where to start.
  3. B_Radical

    B_Radical Private E-2

    The next BSOD I got was different to the first as it held and let me review the errors for more than a few seconds

    The errors are: Stop: 0X000000C5 (0X00000004, 0X00000002, 0X0000000, 0X8A96477F)

    Hope they are the codes you need?
  4. jconstan

    jconstan MajorGeek

    Did you run the Windows 7 Upgrade Advisor to make sure your system and applications were compatible with Windows 7? Did you do an upgrade or a "fresh" install of Windows 7?
  5. B_Radical

    B_Radical Private E-2

    I did a clean install of 7 and no, I did not run the upgrade adviser. Didn't even know it existed. I think I may just re install xp pro and run that to get my answer. Many thanks


Share This Page

MajorGeeks.Com Menu

MajorGeeks.Com \ All In One Tweaks \ Android \ Anti-Malware \ Anti-Virus \ Appearance \ Backup \ Browsers \ CD\DVD\Blu-Ray \ Covert Ops \ Drive Utilities \ Drivers \ Graphics \ Internet Tools \ Multimedia \ Networking \ Office Tools \ NEW! PC Games \ System Tools \ Macintosh \ Demonews.Com \ Top Downloads

MajorGeeks.Com \ News (Tech) \ Off Base (Other Websites News) \ Way Off Base (Offbeat Stories and Pics)

Social: Facebook \ YouTube \ Twitter \ Tumblr \ Pintrest \ RSS Feeds