1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Can't stop "Preparing to Install" message

Discussion in 'Software' started by 4world, Jan 10, 2007.

  1. 4world

    4world Private E-2


    I am new to this forum and would appreciate any pointers or help for the following-

    I have Win XP Pro (2002), SP2. If I open a folder browser window (Explore or Folder list), and click on "Search" (F3), it brings up the Windows Installer dialog box that says "Preparing to install ..." I can't search and the PC seems crippled at that point.

    Only way out at that point is to use Ctrl-Alt-Del and kill the Installer or the browser window (which are in "Not Responding" state).

    Thank you in advance
  2. Adrynalyne

    Adrynalyne Guest

    Preparing to install.....what?

    Is there a title on the window, hinting as to what its trying to install?
  3. 4world

    4world Private E-2

    The title on the dialog box is "Windows Installer" and the message inside it is "Preparing to install..." There is nothing else that is mentioned except there is a "Cancel" button that does not work.

    Once this dialog box pops up, all open windows get almost frozen or extremely slow to respond.

  4. Adrynalyne

    Adrynalyne Guest

    Right click on My computer, choose manage.

    Go to event viewer, check application, and system logs.

    Look for a source of Windows installer.

    See if it gives a hint of what is trying to install.
  5. 4world

    4world Private E-2

    Hi Adrynalyne,

    Thank you for taking the time to help so quickly!

    To be sure, I cleared both the "Application" and "System" logs and then repeated the procedure that causes the problem.

    After the Installer starts, the System log shows nothing whereas the Application log shows the following two lines preceded by an exclamation point in a yellow triangle (I've just given the most relevant columns) --

    Type Source Category Event
    Warning MsiInstaller None 1001
    Warning MsiInstaller None 1004

    Thank you.
  6. Adrynalyne

    Adrynalyne Guest

    Sorry, should have mentioned. Double click on those to open them up and get the information from them.
  7. 4world

    4world Private E-2

    Oh, I am sorry ... I should have tried double clicking myself. So, here's what the "Description" of the two warnings say


    Detection of product '{DC76EAE7-72B6-442E-AAD0-6A67F915C23D}', feature 'Intel_Modules' failed during request for component '{2BBD855C-60FD-421E-9BF2-D67E06AE0679}'

    For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.


    Detection of product '{DC76EAE7-72B6-442E-AAD0-6A67F915C23D}', feature 'Intel_Modules', component '{27FB8069-002F-11D4-B4C2-0010B50A9735}' failed. The resource 'C:\WINDOWS\system32\Msinet.ocx' does not exist.

    For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

    The links above do not give much help either.

    I searched the net and found this ...


    ... which has 36 comments but no clear solution (click on "See all 36 comments" on the bottom). confused

  8. Adrynalyne

    Adrynalyne Guest

    ok, Intel_modules.

    Is it safe to assume you have an Intel video card?

    If so, try uninstalling the video card software from add/remove. If that doesn work (as in you cannot), let me know, there are other ways to do this.
  9. Marshaz

    Marshaz Private E-2

    Hi 4world, I have a similar problem the windows installer pops up when start VLC media player. In my case when I click on the cancel button it will carry on for a few seconds (so you think the cancel button hasn't worked) and then it stops but immediately tries to install again. I find that if I click the cancel button the second time it stops it. Odd times it may take 3 times but it is liveable with. Not an answer to your problem but you may like to try clicking the cancel button 2 or 3 times if you haven't already tried. Good luck.
  10. 4world

    4world Private E-2

    Actually, this is an IBM Thinkpad T42 with an ATI Mobility Radeon 9600 series video card.

    The only items that have "Intel" in their description in the Device Manager are:

    * IDE ATA/ATAPI Controllers
    * Network Adapters (2 - one wired and one wireless)
    * System devices - several. SMBus Controller, LPC Interface Controller, PCI bridge, Proc to AGP controller, Proc to I/O controller
    * USB controllers - several. Most are some "Host Controllers"

    If I "uninstall" any such item from the Device Manager, would I need some kind of driver disk to install it back after the system reboots? If so, I better look for the driver before uninstalling!

  11. Adrynalyne

    Adrynalyne Guest

  12. 4world

    4world Private E-2

    Shows the following two Intel programs--

    Intel PROSafe for Wired Connections [8.00.0005]
    Intel PROSet for Wired Connections [7.10.0000]

    (I did not click "Remove" to clean up the installer config for these two since I didn't know if you wanted me to. I have just listed what I saw after running the program.)

    Thank you again for your sustained effort!
  13. Adrynalyne

    Adrynalyne Guest


    Find an updated driver/software download for your network card.

    Then we will look at removing those entries, but check back with me first on finding those drivers.
  14. 4world

    4world Private E-2

    Ok, after quite a few different tries, I found the correct drivers for both network cards (they are from the correct Lenovo website after automatic detection of my laptop config).

    I would have installed both as given in the directions on the webpage but I'm checking with you as you've asked. Shall I install them?

  15. Adrynalyne

    Adrynalyne Guest

    Not yet.

    Use the clean up utility to remove those Intel entries., then reboot and install those drivers.

    This is at your own risk, if those drivers you downloaded don't work, you won't be able to get back online.
  16. 4world

    4world Private E-2

    Didn't work! The installer still pops up on search.

    I did exactly like you said:
    1. Removed the 2 entries with Windows Installer Clean up utility
    2. Rebooted
    3. Installed the two drivers and rebooted (as instructed by install)

    Pls. note that I did not 'uninstall' the two drivers from the Device Manager at any point. One driver was installed by right clicking the network adapter and selecting "Update Driver ..." whereas the other driver was installed by running a supplied ACPSETUP.EXE (which automatically removed the earlier driver first and then installed the new one).

    I observed 3 things-
    a) After step 2. but before 3. above, I was still able to connect to the net as usual (in contrast to what you had said).

    b) After step 3., I ran the clean up utility again but I couldn't see any entry for Intel, even though I had installed both the new drivers. Do you know why?

    c) Under Computer Management, Application Log reveals the exact same two entries even now.

    Thanks again. Sorry I am putting you through so much trouble. :(
  17. Adrynalyne

    Adrynalyne Guest

    Ok...let me do a little research.

    A little background to why this is happening.

    A feature or application was installed, and failed on install. It is attached to the WIndows Installer service via the registry.

    Every time the windows installer service is invoked (starting up any windows installer installed app), you get this message.

    The key is to find the app, nuke it, and reinstall if needed.
  18. Adrynalyne

    Adrynalyne Guest

    Can you try something?

    Go to start, run, regedit.

    Go to edit, find

    Paste in DC76EAE7-72B6-442E-AAD0-6A67F915C23D

    Click Find.

    Go through the keys it finds, (left hand side) and see if you can delve any name of the application in question. That would help immensely.

    DO NOT MODIFY ANYTHING! There is no 'undo' here. Just look.

    I'll do some research in the meantime.
  19. Adrynalyne

    Adrynalyne Guest

    I may have something. Do you have iTunes?

    Uninstall it from add/remove, if yes.
  20. 4world

    4world Private E-2

    1. No I don't have iTunes.

    2. The registry search revealed the following keys (copied from left column):


    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\App Management\ARPCache\{DC76EAE7-72B6-442E-AAD0-6A67F915C23D}




    I don't know how to dig any further from the above data to find the defaulting application. Pls. let me know how.

    You are quite a guy! Putting in so much effort for someone you've never dealt with before and for nothing in return. Thank you v much.

Share This Page

MajorGeeks.Com Menu

MajorGeeks.Com \ All In One Tweaks \ Android \ Anti-Malware \ Anti-Virus \ Appearance \ Backup \ Browsers \ CD\DVD\Blu-Ray \ Covert Ops \ Drive Utilities \ Drivers \ Graphics \ Internet Tools \ Multimedia \ Networking \ Office Tools \ NEW! PC Games \ System Tools \ Macintosh \ Demonews.Com \ Top Downloads

MajorGeeks.Com \ News (Tech) \ Off Base (Other Websites News) \ Way Off Base (Offbeat Stories and Pics)

Social: Facebook \ YouTube \ Twitter \ Tumblr \ Pintrest \ RSS Feeds