1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Computer Password No Longer Works

Discussion in 'Software' started by Denise_M, Jan 14, 2008.

  1. Denise_M

    Denise_M MajorGeek

    Hi,

    I rebooted my computer about an hour ago but it wouldn't start up. I tried several times. Each time I got to the black screen with the Windows name and scrolling bar, it continued doing that for about 5 minutes, and I'd stop it.

    I first tried "Last Best Known Configuration" but it didn't work. I then told it to "Start Normally, but that didn't work either.

    I tried to do a repair. I inserted my Windows disk and chose to do a repair. It got to the point when it asked me for my password. My password is my first name, either with a capital D or a d but I previously changed my log-on to not ask me my password each time. When I entered my password, I typed it first with lower case d then D, but neither way worked. :cry :crybaby :banghead :***

    Is there a way to get around this without having to do a complete reinstall of windows?
     
  2. Denise_M

    Denise_M MajorGeek

    Well, this turned out to be very strange. I wrote the first post using my daughter's computer and waited around upstairs to see if I'd get a response. But, after I thought about it, I was actually asking how to get into a computer, any computer, in a manner that can be used by anyone illegally.

    So I came back downstairs, thinking that I was going to have to do another complete format. When I got downstairs, my desktop was there. I decided to do a restore to a checkpoint made yesterday and then I rebooted. I still had to wait about 15 minutes for that black screen with Windows on it and the scrolling bar to finish doing what it usually does during that time.

    I'm thinking about using another restore point from last Thursday or Friday. I don't know what got into my pc to cause this. Right before I rebooted, I ran Ad-Aware, SpyBot S&D and Advanced WindowsCare V2 Personal for an XP os and I have XP Pro X64, so it might have removed some files that X64 needs. http://www.download.com/3000-2086_4-10783002.html
     
  3. Denise_M

    Denise_M MajorGeek

    I did another System Restore to last Thursday when I was able to turn my computer on and off and the boot-up/reboot time was less than a few minutes. It still took about 15 minutes to boot up now.

    Does anyone have any ideas before I start another format?
     
  4. dlb

    dlb MajorGeek

    You shouldn't need to format. If absolutely necessary, you can do a safe re-install, but that shouldn't really be necessary either. Since you can't get into the Recovery Console due to a password issue, do this from the Desktop: click Start > Run type cmd and press Enter. Type chkdsk c: /r with a space before and after the "c:" and press Enter. You should get some type of message that will ask if you want to schedule chkdsk to run the next time you boot, answer Yes. Put your XP CD (be sure it's the right one for the version of Windows you're running) in the CD/DVD drive and click Exit when the big blue window opens. You should still be at the command prompt. Type sfc /purgecache with a space before the slash and press Enter. Let that run, it should take maybe 60 seconds, probably less. When it's done, type sfc /scannow again with the a space before the slash and press Enter. This may take some time. If prompted to insert the XP CD, click Retry. If this prompt comes up over and over, and you have a 2nd CD drive, move the XP disc to the other drive, and click Retry. Occasionally, you'll have to keep clicking Retry over and over, but not usually. When this has finished, type exit and press Enter, then reboot. Also, here's a link that is full of great info, and other links to more info that may be worth a look. Good luck, and let us know how it goes!
    http://www.softwaretipsandtricks.com/forum/windows-xp/5264-extremely-slow-boot-up-windows-xp.html
     
  5. Denise_M

    Denise_M MajorGeek

    This problem came out of the blue. One minute there was no problem and the next, all h*ll broke loose. . . the reason we named this potential piece of scrap metal Damien. During the build, everything, from start to finish didn't work the way it should have, and they were always weird problems.

    I wish I had waited for your reply, dlb, but I'm such a pest that I thought that everyone had already thrown their hands up in the air and given up trying to make this pc work right.

    I formatted this pc so often that I can almost do it blindfolded, but because it's time consuming, I was hoping a repair would do the trick. When it didn't and it had starting getting late, I decided to do a format, but I still have the problem . . . it takes about 15 minutes to boot up/reboot. The black window that says "Windows XP" and has the scroll bar beneath it takes about 10+ minutes to finish. I counted 400+ scrolls of the bar. It's the same problem that I had before I formatted it.

    I've already installed the mainboard's software, updated drivers and installed Avast, and then I came here right here. I'm going to Microsoft for their updates next and get the redistributable pack and SP3, and all the other updates.

    Since I formatted the pc, is there still a reason to follow your instructions? I don't think so but I thought I'd ask.

    Any idea why it's taking so long to boot up?
    .
     
  6. Novice

    Novice MajorGeek

    As dlb appears to have called it in for the night, hope that he won't mind me replying. Yes, following his instructions for chckdsk would still be good advice as it could be failing sectors on the hard drive causing the long boot time. :)
     
  7. Denise_M

    Denise_M MajorGeek

    Hi Novice . . . thanks for responding. I'll do a chkdsk and let you know what it says.
     
  8. Denise_M

    Denise_M MajorGeek

    The ChkDsk just finished. When it finished, the results were on the screen for about 2 or 3 seconds with no chance to generate a report. When the pc finished booting up, it said that ChkDsk found it to be "clean." This message showed up for only a few seconds also so I couldn't get the exact wording, but it did say it was clean.
     
  9. Denise_M

    Denise_M MajorGeek

    Sorry, I don't know what happened here but the info is in the next post.
     
  10. Denise_M

    Denise_M MajorGeek

    I just ran the HD Tune Test. These are the results:

    I just ran HD Tune. To make the story short, it found it to be in good health.

    Benchmark Test:
    - Min 36.9Mb/s
    - Max 74.3Mb/s
    - Burst Rate 74.7Mb
    - Access Time 13.3ms
    - CPU Usage 4.7%

    I did the Error Scan using the Quick method. If it had shown any sign at all of being damaged, I would've run the test again in regular mode.

    Info:
    The following boxes were checked
    - Capacity 49999Mb, Usage 25.78%, Type NTFS, Bootable=No
    - S.M.A.R.T.
    - Read Look-Ahead
    - Write Cache
    - Host Protected Area
    - Device Configuration Overlay
    - Firmware Upgradable
    - Power Management
    - Security Command Queuing (NCA)

    The following boxes weren't checked:
    - Automatic Acoustic Management
    - Advanced Powe Management
    - Interface Power Management
    - Power-up in Standby

    I attached a screenshot of the HD Tune: ST3320620AS Health


    Power On Time : 1221
    Health Status : Ok


    HD Tune: ST3320620AS Error Scan

    Scanned data : 305123 MB
    Damaged Blocks : 0.0 %
    Elapsed Time : 0:34


    I don't know if this might be of some help to give you an idea to where to look for the problem.
     

    Attached Files:

  11. dlb

    dlb MajorGeek

    Well, the title of this thread is no longer applicable. ;) Anyway- I'd start thinking about some other hardware issue if a format didn't fix the slow boot issue. Did it boot slow the whole time during install, or only after all the drivers had been installed? I see you ran some 3rd party drive tests, but you really should run Seagates newest diagnostic, in the extended/advanced mode. Download it from here (I usually use the bootable one, also called SeaTools for DOS) : http://www.seagate.com/www/en-us/support/downloads/seatools/ You may want to run a full extended memory diagnostic (I like this one, it's bootable too: http://www.majorgeeks.com/Microsoft_Windows_Memory_Diagnostic_d3955.html) and maybe swap out your hard drive data cables for new ones. Maybe check your BIOS settings and be sure that everything is kosher in there too...
     
  12. Denise_M

    Denise_M MajorGeek

    I haven't changed the BIOS settings and I wouldn't know if they were set correctingly or not. I left it up to the Windows x64 disk to do what it had to do. It did ask me if I wanted to flash the BIOS and I chose to do it.

    Right now, I'm running MemTest86. I'm going to leave it running all night and when I wake up in the afternoon (I'm a night owl), I'll stop it and start it again and let it run for at least 4 hours. So far, so good tho.

    I've run SeaTools once before, about 8 months ago. This pc has a very long history of problems. The only original parts left are the case, the mobo and the hard drive. Everything else was replaced at least once, if not twice.

    I'll run the SeaTools test tomorrow and order new hdd cables.

    I was very happy that the HD Tune test turned out a good report, or to my untrained eye it did.

    Thanks so much for your help dlb. :)
    .
     
  13. Denise_M

    Denise_M MajorGeek

    P.S.

    The installation wasn't slow but when I set a restore point after installing Windows, I rebooted and it took about 15 minutes for my desktop to open.

    Not too sure if I have
    tho. . . . not sure what it means.

    I run any test to determine what's causing this problem.
     
  14. Yargwel

    Yargwel MajorGeek

    In my humble opion a boot that takes a long time like yours has been doing is due to the PC fighting with a corrupt driver.

    Does it boot in a normal time in Safe Mode (as I couldn't see that you'd tried that)?
     
  15. Denise_M

    Denise_M MajorGeek

    Hi Yargwel,

    I tried to get into Safe Mode. When the partitioning page for the drivers loaded, it stopped right there. I think that if I had waited 15 minutes, I would have gotten to the desktop, but I stopped it after about 5 minutes.

    I also just tried to go back to a Restore Point that I set as soon as Windows had loaded, but the pc couldn't do it and, when it booted up, it gave me a message that said that nothing had been changed.

    You came up with a unique solution to the 15 min boot-up time . . . drivers. I think that when I tried to get into Safe Mode and the partitioning of files page started but stopped, the file names listed were mostly drivers, so it could be a corrupt driver.

    How can I tell which driver is causing a problem?
    .
     
  16. Denise_M

    Denise_M MajorGeek

    P.S. . . I saved SeaTools to a floppy disk, turned off my computer, put the floppy in the drive and booted up. It was supposed to boot up to DOS but it booted to Windows, as if it didn't recognize my floppy drive. I tried it a second time and the same thing happened. In CMOS, my floppy drive is first in the boot sequence. The floppy drive works fine, read/write, and it's recognized in My Computer.
     
  17. Denise_M

    Denise_M MajorGeek

    Well, I have great news! I swapped the ports for hard drive cable with the eSATA card and my computer started up right away. The port that I had it in just stopped working. This causes me some concern though. If it was a driver or my hard drive or something else in my pc that caused the port to stop working, it might happen again.
     
  18. Yargwel

    Yargwel MajorGeek

  19. Denise_M

    Denise_M MajorGeek

    Hi Yargwel . . . thanks for replying to my post.

    The article shows 2 methods to determine the service that's causing the problem. The first one is to get to a Restore Point when the pc was working right. I just formatted my pc a few days ago so this option is out.

    The second option is to turn on and off all the items in Services to see which one may be causing the problem.

    Thanks for the link :)
     
  20. Denise_M

    Denise_M MajorGeek

    Well, I found the solution to the 15 minute boot problem. I switched the SATA cables. I removed the cable from the SATA port that was connected to my SATA card and plugged my hdd cable into that port and now my pc starts up normally. But it means that the last of 2 ports on my mobo is bad. Considering all the problems that I've had with this computer, with things getting fried, sparks and smoke, etc, etc, etc, I can believe that my mobo went to h*ll and back. Fred, you weren't too far off when you dubbed this pc as Damien, but it was an unwilling hostage. It looks like it kept calling out, saying that something was wrong. The poor thing. But it's good that I found out for sure what the problem is and I have very good parts in my pc. I'll continue to use this mobo for a while since I have no problems with the rest of it. I just don't have a port for my eSATA HUB, and I can wait for that, no big deal.

    But, and this is a BIG but . . . I need you guys to find me a really good mobo. One with lots of internal and most especially external USB 2.0, firewire and SATA ports. In a few months, my piggy bank will start to fill up again and I'll be able to buy this mobo from heaven that you'll find for me.
     
  21. baklogic

    baklogic MajorGeek

    Hi Denise,
    Well done ! keeping all the checking tools, helps, but loose leads, and port failures really strech the imagination, don't they. Many moons since those standoffs were missed........and the headaches they caused you.
    Yargwel's point about drivers is always a good one.
    It might be worth your while to get some replacement leads for the sata drives, as the fittings can get loose, especially when connecting/diconnecting several times.
    Have you a spare slot to try the sata card in ?
    I thought that Seatools for startup is a different download, to the desktop version, I will check that out .
    Checked- seatools for dos is a different download to the one to use within windows, so that is probably why a 'saved ' version would not boot.
     
    Last edited: Jan 20, 2008
  22. Denise_M

    Denise_M MajorGeek

    Hi baklogic,

    The instructions at the site said to put SeaTools for DOD on a floppy drive. When I rebooted, it was supposed to "see" the floppy and go to DOS by itself from the instructions on the floppy.



    http://www.seagate.com/www/en-us/support/downloads/seatools
    SeaTools



    http://pcsupport.about.com/od/toolsofthetrade/gr/seagateseatools.htm

    Something may be wrong with the floppy drive connector. The disk has remained in the floppy drive since I tried to do the SeaTools for DOS scan and a message to remove the floppy never appeared. The green light is never lit on it either. The floppy drive that fried when connecting the eSATA hdd could have caused damaged the port the floppy drive port.

    I don't have a spare slot to try the SATA card.


    . . . I don't know what leads are . . . new cables or new cards/adapters?
     
  23. baklogic

    baklogic MajorGeek

    Sorry Denise, in England we tend to say leads, for your cables.
     
  24. Denise_M

    Denise_M MajorGeek

    I checked back over posts and I found the reason why I couldn't use SeaTools for Windows X64:

    http://forums.majorgeeks.com/archive/index.php/index.php?t-130536.html


    And the only other page that I could find for drivers and BIOS update was:

    http://www.biostar.com.tw/app/en-us/t-series/driver.php?S_ID=188

    I already have these installed.



    I don't know what to do regarding my computer not recognizing the floppy in my floppy drive so that I can run SeaTools for DOS. I've switch the cable every which way and no green light comes on. The drive does work tho.
     
  25. baklogic

    baklogic MajorGeek

    My e-sata leads/cables are the ones supplied with the external harddrive enclosure, and are pretty sturdy, and fit nice and tight - Did you get the better ones- I remember talking about them when you were building 'Gideon'.
     
  26. baklogic

    baklogic MajorGeek

  27. Denise_M

    Denise_M MajorGeek

    When I clicked on your link, I received a message that said:

    And I couldn't go any further.

    I remember having a hard time getting SeaTools to work for me way back when, and then it finally worked. I don't remember what I did or it did to make it suddenly work.
     
  28. baklogic

    baklogic MajorGeek

  29. baklogic

    baklogic MajorGeek

    I am sure your problem was in the bios boot startup option, when you had the problem before.
     
    Last edited: Jan 20, 2008
  30. Denise_M

    Denise_M MajorGeek

    This looks like an excellent site but it's written in Chinese to me. Anyone have an idea about any updates that I can use from this page? Specifically, the new dual core cpu working with the Biostar T-Force 939 mobo.
     
  31. Denise_M

    Denise_M MajorGeek

    My start-up option is to boot from floppy drive first. It's still set that way.

    When I clicked on 'Learn more about SeaTools for DOS' I received the same message.
     
  32. baklogic

    baklogic MajorGeek

  33. Denise_M

    Denise_M MajorGeek

    That one is mine but should I download and install the BIOS and driver at that site? I already updated:

    - Biostar TForce 6100-939 Chipset
    - Biostar TForce 6100-939 On-Board VGA
    - Nvidia - 93.71_forceware_winxp64_english_whql
     
  34. baklogic

    baklogic MajorGeek

    The date of that bios update is 2007-08-03. Apparently especially fixes a graphics card problem. What date is your present bios ?Updating the bios has its risks, remember .
    To check your floppy drive, I rember telling you, in the previous buil time, to test it by formatting a floppy didc , first, the when you know it does - then unzip the seagate tester to the floppy.
     
    Last edited: Jan 21, 2008
  35. Denise_M

    Denise_M MajorGeek

    Ok, so I need to download the BIOS update to my computer and save the unzipped files to a formatted floppy.

    For the last BIOS update, this is the name that I gave it when I saved it to my pc:
    "CU51M607.BST - Biostar update - Corrects a bug where the monitor does not resume after S3 state. With Biostar splash screen"

    Evidentaly, I copied and pasted what the BIOS update will do to the name of the file. On the folder in which I saved the BIOS update I typed in the dated of the update, which is 060706.
     
  36. Denise_M

    Denise_M MajorGeek

    I downloaded SeaTools for DOS and saved the file in My Documents. I formatted a floppy. A box opened with the option to save/move the contents of SeaTools for DOS onto a floppy and I clicked yes. I rebooted my pc with the disk in the fdd but it booted right to Windows. I opened the disk and saw another zipped folder so I unzipped the contents of the zip folder on the fdd. I rebooted again and it went directly to Windows again. What am I doing wrong?
     
  37. Denise_M

    Denise_M MajorGeek

    I found out what I was doing wrong but I won't tell you but I ran the long test and it passed, so that's two less components to check off in the "Working" list. I know my floppy drive, cable and port is working with no problems and my hard drive, cables and port are working with no problems.

    That leaves only the mobo. One of its SATA ports isn't working and it's unknown what else might not be working or not working correctly. For now, I'm happy that the problem was pinpointed, never mind what caused the problem in the first place. :cloud9

    So guys, please, Please, PLEASE think about what I'd like for a mobo. Lots and lots of ports and compatible with the rest of my hardware. I'll probably be able to buy one in April or May. :clap

    A question though . . . can the new hard drive be SATA II? :confused
     
  38. Denise_M

    Denise_M MajorGeek

    I have an itsy-bitsy problem now. My pc won't boot up unless the SeaTools floppy is in the fdd. *sigh*
     
  39. Denise_M

    Denise_M MajorGeek

    Correction to post #27 . . .

    I asked if the new hard drive would have to be compatible with SATA II.

    I meant to ask if the new mobo can be SATA II and still be compatible with the components that I already have.
     
  40. baklogic

    baklogic MajorGeek

    Did you solve the flppy problem, on startup?
    As far as I am aware, newer motherboards should recognise sata, and IDE.
    Sata hard drives can be downrated from sata 11 (350mps) to sata 1 (150 mps), and I have not seen anything to suggest new motherboards would only run sata 11 hard drive - I will look into it though, and have a look at motherboards, for your future use.
     
    Last edited: Jan 22, 2008
  41. baklogic

    baklogic MajorGeek

    I have lost track of your spec of your pc-
    Remind us, and it will help myself, and others in a search for motherboards, compatable, and not too out of date (you know how fast computers move on )
    OFF FOR A LITTLE , BACK SHORTLY.
     
    Last edited: Jan 22, 2008
  42. Denise_M

    Denise_M MajorGeek

    Thanks baklogic. I really appreciate it.

    I haven't solved the problem with a floppy disk having to be in the floppy drive or it won't start up. The only method that I can think of is to not have the floppy as the first in the boot sequence.

    I want to keep up with the newest type of mobo, as long as it's compatible with the other components that I have. If a SATA II mobo would be compatible (and I think it should be, but what do I know), then I'd like a SATA II mobo.. I have SATA I and SATA II ext hdds and I have cables that have SATA I on one end and SATA II on the other so I shouldn't have any problems with that. . . *a prayer sent to heaven*
     
  43. Yargwel

    Yargwel MajorGeek

    Are you sure that the seatools thingy hasn't written something into your autoexec.bat file (or possibly config.sys) that makes it still need the floppy in the drive? Try renaming the file(s) to autoexec.bat.old orsomething similar and see if that cures this particular problem.
     
  44. baklogic

    baklogic MajorGeek

    Or, if you are a little unsure of that method- run sfc /scannow with your XP disc in the rom drive- remember it ?
     
  45. Denise_M

    Denise_M MajorGeek

    I was just going to say that I did a search for autoexec.bat and no results turned up. I can put my disc in the drive and do sfc /scannow a little later on in the day.

    You guys are always on the ball! . . . :grouphug
     
  46. Denise_M

    Denise_M MajorGeek

    This is what I have:

    - Biostar TFORCE 6100-939 mobo which supports dual channel DDR
    - Seagate Barracuda 7200.10 SATA 3.0Gb/s 320Gb hard drive (RAID array not set up)
    - AMD Athlon 64 X2 4200+ Toledo 2.2GHz 2 x 512KB L2 Cache Socket 939 Processor
    - ARCTIC COOLING Freezer 64 Pro 92mm CPU Cooler
    - Corsair 620W PSU
    - Ballistix 2x1G RAM, 184-pin DIMM, 128MX64 DDR PC3200, Unbuffered
    - NORCO-4618 PCI-X / PCI eSATA / SATA II / SATA I Controller Card RAID 0/1/5/10/JBOD
    - Windows XP X64, SP2
    - NetFramework 2.0 Redistributable Pack for X64
    - up-to-date with Microsoft updates

    By the way, what is this: - NORCO-4618 PCI-X / PCI eSATA / SATA II / SATA I Controller Card RAID 0/1/5/10/JBOD . . . . . . -- is it for a RAID Array only?
     
  47. baklogic

    baklogic MajorGeek

    NORCO-4618 PCI-X / PCI eSATA / SATA II / SATA I Controller Card RAID
    http://www.directron.com/norco4618.html
    4 port eSATA host RAID controller card
    Says it can be used for JBOD (JUST A BUNCH OF DISCS- SEPERATE DISCS ON ONE UNIT)
     
  48. Denise_M

    Denise_M MajorGeek

    I went to the Biostar site. These are the specs that are listed there:

     
  49. baklogic

    baklogic MajorGeek

    At present socket 939 boards seem to be harder to find (your cpu socket type)
    Only one that I have found, with 4 sata ports, so far is this one, still available in some places, but like many, originally made in 2005.:foolish

    http://www.asrock.com/mb/overview.asp?Model=939NF6G-VSTA&s=939
    Asrock 939NF6G-VSTA Socket 939 DDR FSB 1000MHz Audio Video LAN M-ATX Board

    http://www.spotonuk.com/info.asp?It...+M-ATX+Board&Make=Asrock&ModelNo=939NF6G-VSTA



    Overview
    Socket 939 for AMD AthlonTM 64FX / 64X2 / 64 processors NVIDIA® GeForce 6100 / nForce 430 or GeForce 6150SE / nForce 430 Chipsets
    Specification
    Socket 939 for AMD AthlonTM 64FX / 64X2 / 64 processors,NVIDIA® GeForce 6100 / nForce 430 or GeForce 6150SE / nForce 430 Chipsets
    Windows® Vista™ Premium Logo Hardware Ready
    CPU - Socket 939 for AMD AthlonTM 64FX / 64X2 / 64 processors
    FSB 1000 MHz (2.0 GT/s)
    Chipset - NVIDIA® GeForce 6100 / nForce 430 or GeForce 6150SE / nForce 430
    Dual Channel DDR memory technology 4 x DDR DIMM slots
    Supports DDR400/333/266
    Max. capacity: 4GB*
    Graphics - Integrated NVIDIA® GeForce6-class graphics DirectX 9.0 VGA, Pixel Shader 3.0
    Audio - 7.1 CH Windows® Vista™ Premium Level HD Audio (ALC888 Audio Codec)
    LAN - Realtek PHY RTL8201CL Speed: 10/100 Ethernet
    Supports FSB 1000MHz (2.0GT/s) processor
    Slots - 2 x PCI slots 1 x PCI Express x16 slot 1 x PCI Express x1 slot
    Integrated NVIDIA® GeForce6-class graphics DX9.0 VGA, Pixel Shader 3.0, Max. shared memory 256MB
    Supports Dual Channel DDR400 with 4 DIMM slots, maximum capacity up to 4GB
    Hybrid Booster - ASRock Safe Overclocking Technology
    Untied Overclocking : During Overclocking, FSB enjoys better margin due to fixed PCIE/ PCI Buses
    1 x PCI Express x 16 slot
    4 x Serial ATAII 3.0 Gb/s connectors, support RAID (RAID 0, RAID 1, RAID 0+1, RAID 5, JBOD), NCQ, and Hot Plug" functions
    7.1 CH Windows® Vista™ Premium Level HD Audio (ALC888 Audio Codec)

    :major
     
    Last edited: Jan 22, 2008
  50. Denise_M

    Denise_M MajorGeek

    At the Biostar site, I found this under the BIOS tab:
    under the drivers tab, there are a lot of choices:


    The last time that I updated the drivers that you found for me, you told me not to install
    - Biostar TForce 6100-939 On-Board Audio
    - Single Processor - AMD Athlon™ 64 or FX Processor Driver


    I did install
    - Biostar TForce 6100-939 Chipset
    - Biostar TForce 6100-939 On-Board VGA
    - Nvidia - 93.71_forceware_winxp64_english_whql
     

Share This Page

MajorGeeks.Com Menu

MajorGeeks.Com \ All In One Tweaks \ Android \ Anti-Malware \ Anti-Virus \ Appearance \ Backup \ Browsers \ CD\DVD\Blu-Ray \ Covert Ops \ Drive Utilities \ Drivers \ Graphics \ Internet Tools \ Multimedia \ Networking \ Office Tools \ NEW! PC Games \ System Tools \ Macintosh \ Demonews.Com \ Top Downloads

MajorGeeks.Com \ News (Tech) \ Off Base (Other Websites News) \ Way Off Base (Offbeat Stories and Pics)

Social: Facebook \ YouTube \ Twitter \ Tumblr \ Pintrest \ RSS Feeds