1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Fatal error after boot post, but works perfectly (please read on)

Discussion in 'Software' started by Auto123, Dec 5, 2009.

  1. Auto123

    Auto123 Private E-2

    Having a problem with my free pc

    I just updated the bios and gave win7 a go on it.

    after it posts, I get this error:
    Fatal error: failed to locate necessary table(s) to make adjustments
    press any key to continue

    after wards the machine boots up and works perfectly

    but this freaks out other users of the pc, so does anyone know what this means or how to get rid of it

    the machine is a HP Compaq D530 small form factor,
    P4 2.8 ghz, 1 gig of ram, and ATI 9250 graphics

    thank you,
    -Tyler
     
  2. Auto123

    Auto123 Private E-2

    [​IMG]

    mmmkay, could any of this software be effecting my machine just after it powers on and loads the bios?

    because that's when the error appears

    btw just loaded some third party drivers for the radeon and now the machine shuts down without a blue screen :)
     
  3. Auto123

    Auto123 Private E-2

    I've tried a few bios configurations and from what I can tell when I booted it up with a full boot I don't get an error message

    however quick boot gives me this fatal error message

    I'm wondering if I mess with the hardware installed then maybe I can get a different result, it could be the bootloader

    thanks so far,
    -Tyler
     
  4. collinsl

    collinsl MajorGeek

    @DomLuc: Problem lies in the bootup process, not windows. Troubleshooting startup programs are unnecessary in this case.

    @Auto123: So you flashed the BIOS before installing windows 7?

    Did you have any particular reason for doing this?:)
     
  5. collinsl

    collinsl MajorGeek

    @DomLuc: Problem lies in the bootup process, not windows. Troubleshooting startup programs are unnecessary in this case.

    @Auto123: So you flashed the BIOS before installing windows 7?

    Did you have any particular reason for doing this?:)
     
  6. Auto123

    Auto123 Private E-2

    well, I upgraded the the cpu from a 2.6 to 2.8 ghz p4 about a month ago, and it would always load up an error message saying the cpu lacked a microcode update.

    thanks to google I found that this problem was fixed with a new version of the bios, and viola, microcode update message disappears then I start getting this message after about 3 blue screens caused by the ati drivers on shutdown.

    fixed the driver and now it boots and shuts down fine, but after even more testing this message only pops up when I restart the machine.

    if I shut down the computer and turn it on the next day it boots without the message (2 times in a row now) and it seems this message only displays on reboot.

    it's confusing me in the least, and I am still doing some more tests.

    mem test and hdd tests shows everything is fine and working, so I'm lost,
    -Tyler

    oh and I flashed from bios ver 1.11 to 2.44, not sure if that info is needed but there you go
     
  7. Auto123

    Auto123 Private E-2

    upon further testing this message is only displayed when I select restart in win 7

    when I select shut down the message does not appear.

    I will also try this with my primary win xp installation and see if I get similar results,
    -Tyler
     
  8. Auto123

    Auto123 Private E-2

    same result with win 7 and xp

    this only happens when the restart option is selected

    anyone got a clue what's going on here?
    -Tyler
     
  9. blackcivic

    blackcivic Private E-2

    just going to make a guess, but have you checked your boot.ini file for any unusual entries?
     
  10. Auto123

    Auto123 Private E-2

    no I have not, how do I check it and what should I look for?

    have never actually worked on a boot file before...
    -Tyler
     
  11. blackcivic

    blackcivic Private E-2

    your boot.ini file would be located under c:\boot.ini and to see it, you need to go to tools > folder options > and uncheck the option to hide hidden files and folders, and protected system files then click apply and ok...

    Once you see the boot.ini file, make a copy of it and copy it to another location and rename the copied one to another file name like boot.ini.test as you do not want to screw up the boot.ini file otherwise your system will have even bigger problems with not being able to boot up at all.

    Next thing i would do is post what your boot.ini.test shows. Not sure if you will have any problems, but that maybe something to check for since you are having problems with rebooting your system.
     
  12. sach2

    sach2 Major Geek Extraordinaire

    In isn't in your boot.ini file that is only used for Windows XP and as already stated this is a BIOS/setup problem.

    Not sure what the problem is yet. Just letting you know boot.ini isn't involved.

    Just for clarification full boot versus quick boot. Full boot works OK even from restart?
     
  13. sach2

    sach2 Major Geek Extraordinaire

  14. blackcivic

    blackcivic Private E-2

    no worries sach2, every option should always be explored... who knows, i still maybe wrong though
     
  15. Auto123

    Auto123 Private E-2

    looked over on xp and 7 and the boot.ini in C: won't show up

    I would guess it's using the win 7 loader as win 7 was installed second and looks like the loader used by vista on my laptop

    still confused, and thanks so far,
    -Tyler
     
  16. sach2

    sach2 Major Geek Extraordinaire

    I have to ask is your Win7 legit software? Most of the links on that google search point to warez boot loader software.

    Did you test this?
     
  17. Auto123

    Auto123 Private E-2

  18. sach2

    sach2 Major Geek Extraordinaire

    Did you get your BIOS update from Compaq? Just trying to rule things in and out since many people with that error also recently updated BIOS. For clarity you updated your BIOS before installing WIN7, correct?

    I don't know much about the Win7 bootloader or why people would need different ones. I just switched from XP to Win7 and skipped Vista altogether so all I can do is google and see if something comes up that looks like it might help.
     
  19. blackcivic

    blackcivic Private E-2

  20. Auto123

    Auto123 Private E-2

    Found the boot file thanks to easyBCD

    Windows/system32/winload.exe

    umm, what should I check or fix?
    -Tyler

    also the bios are from HP.com and from their support section, and they were installed just after I loaded win 7 if my memory serves me well
     
  21. sach2

    sach2 Major Geek Extraordinaire

    Do you have the fle ntbtlog.txt in the Windows directory? That is a boot log. If it exists do you see anything at the beginning that looks like an error?
     
  22. sach2

    sach2 Major Geek Extraordinaire

    I've been thinking about this I believe the scarcity of this problem is because of serveral factors. An unactivatied copy, upgrading BIOS after Win7 was installed and an older machine built for XP not Vista.

    I think has something to do with the way Activation passes information to/from BIOS. That it only happens on Restart probably has something to do with the boot loader remaining in memory with discrepancies between the information Windows has about the PC and the information BIOS has about the machine.

    I don't know how important the Win7 partition you have is but you may want to try a repair or a reinstallation.

    My basic point is that I think it is not a problem with your machine running Win7 just a problem with this particular installation. IF you are seriously considering keeping Win7 then I would try to fix the boot files and see if it runs OK. If it doesn't run OK then try a reinstallation and test before purchasing. Since it will be installing with the current BIOS there should be no discrepancies.
     
  23. Auto123

    Auto123 Private E-2

    all I got to say is wow. that did it.

    I can restart my computer worry free :)

    thanks Sach2 and Black Civic,
    -Tyler
     
  24. Simtrix

    Simtrix Private E-2

    I've made this account just to say thank you!
    I had same problem and your advice fixed it. I love you! :D
     

Share This Page

MajorGeeks.Com Menu

MajorGeeks.Com \ All In One Tweaks \ Android \ Anti-Malware \ Anti-Virus \ Appearance \ Backup \ Browsers \ CD\DVD\Blu-Ray \ Covert Ops \ Drive Utilities \ Drivers \ Graphics \ Internet Tools \ Multimedia \ Networking \ Office Tools \ NEW! PC Games \ System Tools \ Macintosh \ Demonews.Com \ Top Downloads

MajorGeeks.Com \ News (Tech) \ Off Base (Other Websites News) \ Way Off Base (Offbeat Stories and Pics)

Social: Facebook \ YouTube \ Twitter \ Tumblr \ Pintrest \ RSS Feeds