1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

I have a nasty virus (tojan.agent/gen-kazy)

Discussion in 'Malware Removal' started by pitching101, Nov 23, 2011.

  1. pitching101

    pitching101 Private E-2

    Hey guys,

    Please help me. This virus is destroying my computer. It is so slow now. Superantispyware has found 10 detections of trojan.agent/gen.kazy

    I tried turning off my system restore since and then running my virus and malware scans to remove it, but it did not work. Should I install combofix and post the log?

    Please help :(
  2. chaslang

    chaslang MajorGeeks Admin - Master Malware Expert Staff Member

    Welcome to Major Geeks!

    Please read ALL of this message including the notes before doing anything.

    Please follow the instructions in the below link:

    READ & RUN ME FIRST. Malware Removal Guide

    and attach the requested logs when you finish these instructions.
    • **** If something does not run, write down the info to explain to us later but keep on going. ****
    • Do not assume that because one step does not work that they all will not. MGtools will frequently run even when all other tools will not.

    • After completing the READ & RUN ME and attaching your logs, make sure that you tell us what problems still remain ( if any still do )!
    Helpful Notes:

    1. If you run into problems trying to run the READ & RUN ME or any of the scans in normal boot mode, you can run the steps in safe boot mode but make sure you tell us what you did later when you post logs. See the below if you do not know how to boot in safe mode:
    2. If you have problems downloading on the problem PC, download the tools and the manual updates for SUPERAntiSpyware and Malwarebytes ( links are given in the READ & RUN ME) onto another PC and then burn to a CD. Then copy them to the problem PC. You will have to skip getting updates if (and only if) your internet connection does not work. Yes you could use a flash drive too but flash drives are writeable and infections can spread to them.
    3. If you cannot seem to login to an infected user account, try using a different user account (if you have one) in either normal or safe boot mode and running only SUPERAntiSpyware and Malwarebytes while logged into this other user account. Then reboot and see if you can log into the problem user account. If you can then run SUPERAntiSpyware, Malwarebytes, ComboFix and MGtools on the infected account as requested in the instructions.
    4. To avoid additional delay in getting a response, it is strongly advised that after completing the READ & RUN ME you also read this sticky:
    Any additional post is a bump which will add more delay. Once you attach the logs, your thread will be in the work queue and as stated our system works the oldest threads FIRST.
  3. pitching101

    pitching101 Private E-2

    edit by chaslang: Inline logs changed to attachments

    Attached Files:

    Last edited by a moderator: Nov 23, 2011
  4. pitching101

    pitching101 Private E-2

    I have attached and posted all logs. When I run SuperAntispyware now it no longer finds any virus but my computer is still slower than normal (even just a week ago).

    Another problem I faced during this process was during one of the re-boots I could not get back onto the internet...it said something like refusing connection to the proxy. So I used my smartphone to find a website to help me out which told me to go into Firefox options --> advanced--> network --> settings --> no proxy. That fixed the problem but I don't know if that is a good long term solution.

    I appreciate the help and look forward to your response. Love you guys ;)
  5. pitching101

    pitching101 Private E-2

    Sorry for re-posting but before my last reply I replied with all of my logs and it said an administrator will review the post before posting it. Did it not go through? Should I post it again? Does it just take an admin a while to review posts with logs in it?

    Sorry for being such a newb
  6. chaslang

    chaslang MajorGeeks Admin - Master Malware Expert Staff Member

    Because you posted inline logs from ComboFix, MBAM and SAS. All logs must be attachments as stated in the instructions.

    I will post back with your next instructions as soon as I finish reviewing your logs.
  7. chaslang

    chaslang MajorGeeks Admin - Master Malware Expert Staff Member

    Now we need to use ComboFix
    • Make sure that combofix.exe that you downloaded while doing the READ & RUN ME is on your Desktop but Do not run it!
      • If it is not on your Desktop, the below will not work.
    • Also make sure you have shut down all protection software (antivirus, antispyware...etc) or they may get in the way of allowing ComboFix to run properly.
    • If ComboFix tells you it has expired or need to be updated to a new version, make sure you allow it to update.
    • Open Notepad and copy/paste the text in the below quote box into it:
    • Save the above as CFscript.txt and make sure you save it to the same location (should be on your Desktop) as ComboFix.exe
    • At this point, you MUST EXIT ALL BROWSERS NOW before continuing!
    • You should have both the ComboFix.exe and CFScript.txt icons on your Desktop.
    • Now use your mouse to drag CFscript.txt on top of ComboFix.exe
    • Follow the prompts.
    • When it finishes, a log will be produced named c:\combofix.txt
    • I will ask for this log below

    Do not mouseclick combofix's window while it is running. That may cause it to stall.

    If after running Combofix you discover none of your programs will open up because you recieve the following error: Illegal operation attempted on a registry key that has been marked for deletion then you will need to reboot your computer which will normally fix this problem.
    don't double click, use right click and select Run As Administrator).

    Then attach the below logs:
    • C:\ComboFix.txt
    • C:\MGlogs.zip
    Make sure you tell me how things are working now!
  8. pitching101

    pitching101 Private E-2

    My computer is running well now. The combofix log that pop-upped when it was just finished I saved as ComboFix log.txt so I attached that one also since I know it is the most updated one. It says AVG Antivir is still enabled or running and this is not true (I even uninstalled it and rebooted before running Combofix).

    It won't let me post the MGtools log because it says I have already uploaded this log in this thread (which I did).

    I wish you and your family a happy thanksgiving, thanks for all the help!

    Attached Files:

  9. chaslang

    chaslang MajorGeeks Admin - Master Malware Expert Staff Member

    We only needed one copy of the combofix.txt log ( the one in c:\ which is named combofix.txt.

    Because you did not follow the instructions.;) You need to run the C:\MGtools\GetLogs.bat program to create a new log.

Share This Page

MajorGeeks.Com Menu

MajorGeeks.Com \ All In One Tweaks \ Android \ Anti-Malware \ Anti-Virus \ Appearance \ Backup \ Browsers \ CD\DVD\Blu-Ray \ Covert Ops \ Drive Utilities \ Drivers \ Graphics \ Internet Tools \ Multimedia \ Networking \ Office Tools \ NEW! PC Games \ System Tools \ Macintosh \ Demonews.Com \ Top Downloads

MajorGeeks.Com \ News (Tech) \ Off Base (Other Websites News) \ Way Off Base (Offbeat Stories and Pics)

Social: Facebook \ YouTube \ Twitter \ Tumblr \ Pintrest \ RSS Feeds