1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logitech MK700 Keyboard+Mouse w/Setpoint 6.1 will not click on Vista Welcome Screen

Discussion in 'Software' started by Nealsandman, Jun 22, 2010.

  1. Nealsandman

    Nealsandman Private E-2

    Not sure if this is a software or a hardware issue, so I will post to both forums. I recently bought Logitech keyboard+mouse combo MK700 after reinstalling Windows Vista Home Premium on my HP Pavillion a1600n desktop computer. (I have 1gb RAM + 200gb hard drive). The problem is that the mouse (MK620?) will not click on my Windows welcome screen, on the icons for the separate desktops that I utilize for myself, my wife, and kids. Once past this welcome screen, the mouse is fine. It just will not click here. However, I have had issues with the mouse not clicking at all. I just installed Setpoint 6.1 and those problems have not resurfaced, yet. Any suggestions on how to resolve this issue are greatly appreciated.
     
  2. tunered

    tunered MajorGeek

    Re: Logitech MK700 Keyboard+Mouse w/Setpoint 6.1 will not click on Vista Welcome Scre

    Try plugging the usb reciever in one of the front usb's, possibly the signal is weak not letting it work at times, the welcome screen problem i think is OS problem. ed
     
  3. Nealsandman

    Nealsandman Private E-2

    Re: Logitech MK700 Keyboard+Mouse w/Setpoint 6.1 will not click on Vista Welcome Scre

    Thanks, I will give it a try. Tier two support at Logitech is telling me to update Bios. I checked the HP website, however, a Bios update is not available for the Pavilion a1600n. Any other suggestions/insight is greatly appreciated.
     
  4. DavidGP

    DavidGP MajorGeeks Forum Administrator - Grand Pooh-Bah Staff Member

    Re: Logitech MK700 Keyboard+Mouse w/Setpoint 6.1 will not click on Vista Welcome Scre

    Hi

    What Service Pack is your Windows Vista at?

    In Device Manager are there any yellow ! marks next to any devices, please name them all?

    What USB port are you plugging the reciever into? the best ones as they tend to have better power are one of the back USB ports direct into the motherboard, try one of those.

    Reset the Mouse and reciever (little button on both devices to allow them to re aquire each other).
     
  5. Nealsandman

    Nealsandman Private E-2

    Re: Logitech MK700 Keyboard+Mouse w/Setpoint 6.1 will not click on Vista Welcome Scre

    Thanks Halo,

    I just installed SP2, after reinstalling Vista last week. I do not think there are any yellow! marks in Device manager, but I will double check tonight, just to be sure. I am plugged into the right-most USB port in the back (the outside one). I have previously tried resetting the mouse keyboard connection with no luck. I will try it again tonight, after the install of Setpoint 6.1. Thanks for your input.
     
    Last edited: Jun 23, 2010
  6. Nealsandman

    Nealsandman Private E-2

    Re: Logitech MK700 Keyboard+Mouse w/Setpoint 6.1 will not click on Vista Welcome Scre

    Turns out this was a hardware problem, after all. The mouse was defective. Logitech replaced it, and the new mouse is working fine.

    Thanks for viewing.
     

Share This Page

MajorGeeks.Com Menu

MajorGeeks.Com \ All In One Tweaks \ Android \ Anti-Malware \ Anti-Virus \ Appearance \ Backup \ Browsers \ CD\DVD\Blu-Ray \ Covert Ops \ Drive Utilities \ Drivers \ Graphics \ Internet Tools \ Multimedia \ Networking \ Office Tools \ NEW! PC Games \ System Tools \ Macintosh \ Demonews.Com \ Top Downloads

MajorGeeks.Com \ News (Tech) \ Off Base (Other Websites News) \ Way Off Base (Offbeat Stories and Pics)

Social: Facebook \ YouTube \ Twitter \ Tumblr \ Pintrest \ RSS Feeds