1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

"My Computer" window takes too long to load

Discussion in 'Software' started by CatyCata, Jul 15, 2006.

  1. CatyCata

    CatyCata Private E-2

    Hey there. Thanks for taking time reading my post. Here's the thing... lately, whenever I try to open My Computer, things start to slow down... and it takes more than 5 minutes to load that simple My Computer screen, with the drives and stuff. This delay is already pretty annoying by itself, but sometimes it causes the PC to crash.. and I don't need to say how much I waste when it happens.
    May you want to know something more about my machine, here are some stuff in advance:
    1st - PC Specification:
    • OS: Windows XP SP2
    • 2 HDs - one with 80GB and other with 40GB
    • RAM: 768 MB
    • Intel Pentium 4 - 1.70GHz
    2nd - Activity
    I hadn't been using much my PC 'til last week, and it was about then I found out this problem... but I can't recall installing anything back then, nor doing anything but using things like Microsoft Word or Photoshop.
    My AVAST is up to date, and I've recently done some scans trying to find out anything wrong...
    But really it just seems like the trouble started alone, tho I know it has to have some cause. If anyone could give me a hand here, it would be great. I know I can use alternative ways to access things shown on My Computer, but it's a matter of routine and so on. Thanks in advance! :)
  2. Robert

    Robert Sergeant

    First thing I'd do is have a look in event viewer for the problem. If nothing there to indicate problems install Crapcleaner and clean out all the gunk that programs generate. CC available here at MG.
  3. Cobra

    Cobra Private First Class

    Do everything in the previous post and make sure your disk isn't fragmented. Make sure you have antispyware software installed and make sure you have a good firewall. (The windows one is usually good enough).
  4. TimW

    TimW MajorGeeks Administrator - Jedi Malware Expert Staff Member

  5. CatyCata

    CatyCata Private E-2

    It's gone back to track!

    First of all, thank you all for the helpful replies on such short time. :D
    I took a look at the event viewer, found some interesting events (it never occurred to me to look there - now it's going to be part of my routine), but nothing that I saw could solve the loading trouble. So I tryied the registry tweak TimW suggested, reseted and... it's working fine now :) so good to have things back again.
    For the defrag suggestion, spyware watch, firewalls and CrapCleaner, I agree that no matter what problem it's always good to keep all of this things in mind. Of those, I haven't tryied CC yet, now it's on my to do list. But for now, with the problem solved, I wanted to thank you for the help!

Share This Page

MajorGeeks.Com Menu

MajorGeeks.Com \ All In One Tweaks \ Android \ Anti-Malware \ Anti-Virus \ Appearance \ Backup \ Browsers \ CD\DVD\Blu-Ray \ Covert Ops \ Drive Utilities \ Drivers \ Graphics \ Internet Tools \ Multimedia \ Networking \ Office Tools \ NEW! PC Games \ System Tools \ Macintosh \ Demonews.Com \ Top Downloads

MajorGeeks.Com \ News (Tech) \ Off Base (Other Websites News) \ Way Off Base (Offbeat Stories and Pics)

Social: Facebook \ YouTube \ Twitter \ Tumblr \ Pintrest \ RSS Feeds