1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Network gaming problem

Discussion in 'Hardware' started by mr_flea, Sep 30, 2003.

  1. mr_flea

    mr_flea First Sergeant

    i'm running a workgroup 1/2 wired, 1/2 wireless network. I am trying to play multiplayer games on it, between a wireless and a wired computer, but when the wireless computer creates a game, no other computer can connect to it. But when a wired computer creates the game, everyone, wireless and wired can connect to it and play. Both computers have the same protocols installed. Running windows XP pro. Happens with Red Alert 2 and Empire Earth, which are the only one's i've tried so far.
     
  2. Adrynalyne

    Adrynalyne Guest

    Any firewalls on any computer?
     
  3. mr_flea

    mr_flea First Sergeant

    no firewalls, microsoft firewalling disabled
     
  4. Adrynalyne

    Adrynalyne Guest

    Do those games use tcp/ip or ipx?
     
  5. mr_flea

    mr_flea First Sergeant

    i think they're both ipx, and i have ipx protocols installed. I know one is, but i'm not sure about the other. give me a couple minutes and i'll figure out.
     
  6. Kodo

    Kodo SNATCHSQUATCH

    I'd bet that the routers don't support IPX.
     
  7. mr_flea

    mr_flea First Sergeant

    I think i know the problem. How do you change the default network adapter? I think the games may be trying to host a game on the wrong adapter, because i have 3 different adapters (wireless, 10/100, 1394) 1394 is disabled.
     
  8. mr_flea

    mr_flea First Sergeant

    How would i know if they don't? any way to tell?
     
  9. mr_flea

    mr_flea First Sergeant

    Got it! it's the default network adapter problem. Anyone know how to fix this? and kodo: My router is fully compatable, it's new.
     
  10. Kodo

    Kodo SNATCHSQUATCH

    new doesn't mean fully compatible.. IPX is extremely rarely used these days.
     
  11. mr_flea

    mr_flea First Sergeant

    Well it's a d-link if that changes anything
     
  12. Tater

    Tater Tot

    Empire Earth (great game by the way) is TCP/IP I'm almost positive. Have you forwarded the ports for the hosting P.C. ? I can post the ports needed if you haven't got em. Is the wired P.C. that work as a host the DMZ host btw?
     
  13. mr_flea

    mr_flea First Sergeant

    i tried using the DMZ on the one that wouldn't work, that did nothing as that partains to the internet I think. The one that can't start the game is using the wrong network adapter. Anyone know how to change the default one? When I changed it in the empire earth menu, it worked, but i'd really like to know how to change the default one so I don't have to go and change the adapter that each game uses, i don't think i can change the adapter red alert 2 uses.
     
  14. goldfish

    goldfish Lt. Sushi.DC

    port forwarding and DMZ does nothing to the internal network, so that wont be a problem.. What OS is the wireless using? Unforunatley i dont have a multiple NIC computer at hand so i cant really find out how to set it as default, but have you tried disableing the others while they arnt being used? (this is in XP btw)
     
  15. mr_flea

    mr_flea First Sergeant

    well i disabled the 1394 because i'll never use that. I am running XP pro. The firmware on the router is 3.20 (newest), I just upgraded it. I guess i'll try disabling the 10/100, but i'd really like a solution that didn't involve that.
     
  16. Tater

    Tater Tot

    @Goldfish If all of his P.C.'s are connected thru his router, isn't port forwarding required. To play Emp. Earth on my lan I've always had to forward the right ports. They're not only for WAN traffic are they? Sry, noob question I know.:(
     
  17. Adrynalyne

    Adrynalyne Guest

    Port forwarding is for the WAN port on the router.

    Anything on his side doesn't need it. The router (more accurate to call it a gateway) acts as a switch that uses DHCP on the local side. NAT is irrelevant in that case.
     
  18. goldfish

    goldfish Lt. Sushi.DC

    actually it would depend on how the router is wired, but i doubt very much that the wireless network isnt behind the NAT.....

    Hmm, an interesting problem, actually a friend of mine had around about the same problem with sending files over msn and his ADSL modem (it would try to connect via the LAN connection not the WAN connection) and disabling the LAN connection was the only way he found around it.

    Ill have a look on MS Technet maybe they have somthing about prioritizing network adaptors, would make sense if they did!
     
  19. Adrynalyne

    Adrynalyne Guest



    XP does prioritze them.


    Check it out:


    [​IMG]

    If you are curious where this is, go to Control Panel-Network Connections, Advanced Settings.
     
  20. mr_flea

    mr_flea First Sergeant

    i'm viewing the network connections folder right now and it's not there. Are you sure that's where it is?
     
  21. Adrynalyne

    Adrynalyne Guest

    Yep.


    Menu at the top, called Advanced, then Advanced Settings...


    Sorry, menu is 'Advanced'
     
  22. mr_flea

    mr_flea First Sergeant

    thanks, that should work.
     

Share This Page

MajorGeeks.Com Menu

MajorGeeks.Com \ All In One Tweaks \ Android \ Anti-Malware \ Anti-Virus \ Appearance \ Backup \ Browsers \ CD\DVD\Blu-Ray \ Covert Ops \ Drive Utilities \ Drivers \ Graphics \ Internet Tools \ Multimedia \ Networking \ Office Tools \ NEW! PC Games \ System Tools \ Macintosh \ Demonews.Com \ Top Downloads

MajorGeeks.Com \ News (Tech) \ Off Base (Other Websites News) \ Way Off Base (Offbeat Stories and Pics)

Social: Facebook \ YouTube \ Twitter \ Tumblr \ Pintrest \ RSS Feeds