1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Networking with a crossover cable

Discussion in 'Hardware' started by DJ_Tet, Jan 27, 2005.

  1. DJ_Tet

    DJ_Tet Private E-2


    I am having what is probably a very basic home networking problem. I have two PCs with Windows XP Home running on them. They are both clean of viruii and spyware to the best of my knowledge. I have two network cards, one installed in each PC, and two modems, again one in each PC.

    The setup will hopefully work like this.

    One PC will have two printers attached to it, and the main copy of all the work files (Quickbooks, Excel, Word documents). I would like to share access to the printers and access to the work files on the other PC. Each PC should be able to modify the work documents seperately. Each PC will retain the right to go online individually, as there is only dial-up. The phone line setup is a dedicated fax/internet line, so each computer can dial in separately, but not at the same time. The second PC has both printer drivers installed and the programs used to access the work files.

    To connect the two PCs I am using a Cat 5E Crossover cable.

    I have tried running the Network Wizard to no avail. Perhaps I am not running it correctly.

    On the control panel -> Network Connections I have modified the IP address of the first network adapter to and on the second computer. Both have the subnet of and the Network name MSHOME. Both computers have only one default user account, do I need to make administrator accounts on both PCs to make it work correctly?

    When I plug the crossover cable into both network adapters, the physical connection is recognized, however there is no success in sending packets or pinging from one PC to the other.

    Can anyone help? Am I missing an easy step?
  2. Coco

    Coco Sergeant Major

    I honestly don't see any problem with what you've done it should work. You could set the default gateway on both comps to Although that shouldn't be a needed step.

    It is possible that there is a flaw with the network cable. It's rare but I have seen network cables that connect but one of the wires is broken. Which causes windows to see a connection but not work. So if at all possible try it with a diffrent cross over cable and see if that works any better.
  3. Turcoloco

    Turcoloco MajorGeek

    Well, I would recommend changing the IP addresses to a more valid-feeling ones such as and (I am not too comfy with the '0' on the second octet but probably it is nothing). Anyhow my main concern is the Operating System you are using, I have never networked (even via crossover cable) two Windows XP HE PCs before so if it is feasible I'd recommend you open the command prompt: Start > Run > cmd > OK
    and try pinging each machine's own IP address first then the other PC, that would give you confirmation on how 'real' your connection is. The network icon in the system tray would tell you that the network connection is established even if you just plugged in a network cable where the other end could be not plugged into anything at all, so the icon and the system tray message means nothing as far as the 'real' connection goes.
    Check on those and repost...if someone has experience with networking XP HE they might be more helpful. ;)
  4. BrokenArrows

    BrokenArrows Sergeant

    While i was in college last year i was in a house with a group of lads and we were all running XP Home on out laptops. We had a crossover cable like yours and we had no problem hooking them together for a LAN game.

    We just plugged in the wires set the ip addresses and off we went. Exactly the same as you have done so i dont see what the problem is.

    Goto start -> run -> cmd or command

    type this command: nbtstat -c

    This should list any computers that are on your network. Give it a try and see.
  5. mcadam

    mcadam Major Amnesia

    Used to use exactly the same setup, only with xp pro. I had all my IP settings to asign automatically and never had any problems. Then ran the network setup wizard, enabled file and printer sharing wizard etc. Lastly, installed a network printer from adding printer.

    Try the automatic settings, they're simple but work well in most cases.

    Last thing I can think of is a problem with the cable, but if a connection is being recognised then probably not.
  6. Coco

    Coco Sergeant Major

    You can't use the automaticly detect setting with a cross over cable. The automatic setting requires something running to set stuff. For example if you use a router, the router will assign them. Or if you setup one computer to be the server then it can assign ips to the rest of the computers. But with just a single cross over cable and no server you can't use those options.

Share This Page

MajorGeeks.Com Menu

MajorGeeks.Com \ All In One Tweaks \ Android \ Anti-Malware \ Anti-Virus \ Appearance \ Backup \ Browsers \ CD\DVD\Blu-Ray \ Covert Ops \ Drive Utilities \ Drivers \ Graphics \ Internet Tools \ Multimedia \ Networking \ Office Tools \ NEW! PC Games \ System Tools \ Macintosh \ Demonews.Com \ Top Downloads

MajorGeeks.Com \ News (Tech) \ Off Base (Other Websites News) \ Way Off Base (Offbeat Stories and Pics)

Social: Facebook \ YouTube \ Twitter \ Tumblr \ Pintrest \ RSS Feeds