1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

New pc slower than my old one

Discussion in 'Hardware' started by krishner, Feb 18, 2008.

  1. krishner

    krishner Private E-2

    hi all - just got a new XPS 420 with Intel Core2 Quad CPU q6600@2.4Ghz, 1TB Raid 0 HD 2 x 500MB, with 3GB Ram. It has the misfortune of running Vista home premium - thought i'd try it out - slowly losing patience with :banghead - but get this...my old shed that I've had for years and tweaked to its best (bless it) running XP2 with a 40GB HD an Intel pentium 2 and 356 MB RAM was, granted, clunky, but reliable and had better download speeds than this beast. What am i doing wrong!? No Bad Vista jokes, please...well, not too many eh? Thanks all for reading. Krishner
  2. matrixblue

    matrixblue Private E-2

    Try disabling Vista's visual effects in Control Panel > System Properties > Advanced >Performance Settings
  3. DOA

    DOA MG's Loki

    If you have an extra HD or buy one...
    Download all the drivers you will need to install XP Pro and burn to a CD.
    Swap out the HD and install XP Pro from scratch.
    Test the new XP Pro setup. If you like it better you win, if not, swap back the original HD. You might think buying a new HD is not the best way, but if your time is worth much at all it is much cheaper than messing with the original. Especially if you have to go back to Vista.
  4. krishner

    krishner Private E-2

    Uh...thanks..I think..I guess my neural network isn't wired the same way yours is..!
  5. krishner

    krishner Private E-2

    I'll try. let u know. thanks. K
  6. studiot

    studiot MajorGeek

    This is nothing to do with Vista visual effects - If you like them keep them, if you don't ditch them.

    It may be due to a new Vista 'feature' called

    Receive Window auto tuning'

    This mouthful allows Windows to negotiate with suitably intelligent routers.
    Unfortunately there aren't many new ones and no older ones.

    open an administrator command prompt

    netsh interface tcp show global
    press enter

    you will see a list of TCP global parameters

    if receive window auto tuning level is set to normal

    type in

    netsh interface tcp set global autotuning=disabled

Share This Page

MajorGeeks.Com Menu

MajorGeeks.Com \ All In One Tweaks \ Android \ Anti-Malware \ Anti-Virus \ Appearance \ Backup \ Browsers \ CD\DVD\Blu-Ray \ Covert Ops \ Drive Utilities \ Drivers \ Graphics \ Internet Tools \ Multimedia \ Networking \ Office Tools \ NEW! PC Games \ System Tools \ Macintosh \ Demonews.Com \ Top Downloads

MajorGeeks.Com \ News (Tech) \ Off Base (Other Websites News) \ Way Off Base (Offbeat Stories and Pics)

Social: Facebook \ YouTube \ Twitter \ Tumblr \ Pintrest \ RSS Feeds