1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

New XP install, need drivers please.

Discussion in 'Software' started by Enorjizor, Oct 8, 2009.

  1. Enorjizor

    Enorjizor Private E-2

    I recently bought a used computer which had Vista installed. It was pretty glitchy and I tried to get it cleaned up for a while until I got fed up with it. I have a Windows XP Professional on disk so I ditched Vista and just installed the XP Pro. I have downloaded and run Everest and I am attaching the report. I have found some of the drivers, but don't want to install them until I have the chipset installed. I am having problems finding the proper chipset. Any and all help would be greatly appreciated. Thanks in advance, EJ

    Attached Files:

  2. Spad

    Spad MajorGeek

    The nice thing about XP (or Vista, for that matter) is you don't need to search for very many drivers - both OS have a decent range of driver files built in.

    It looks like this is the shortcut to your motherboard's homepage - http://www.ecs.com.tw/ECSWebSite/Do...New&DetailDesc=&CategoryID=1&MenuID=6&LanID=9

    (Your motherboard seems to support cpu socket 775)

    Now, this is the page for the 1.0B revision of your board . . . check your motherboard and make you search for the right revision number. The 1.0A shortcuts on the site seem broken.

    Everest says you have the Intel Lakeport-G i945G chipset.

Share This Page

MajorGeeks.Com Menu

MajorGeeks.Com \ All In One Tweaks \ Android \ Anti-Malware \ Anti-Virus \ Appearance \ Backup \ Browsers \ CD\DVD\Blu-Ray \ Covert Ops \ Drive Utilities \ Drivers \ Graphics \ Internet Tools \ Multimedia \ Networking \ Office Tools \ NEW! PC Games \ System Tools \ Macintosh \ Demonews.Com \ Top Downloads

MajorGeeks.Com \ News (Tech) \ Off Base (Other Websites News) \ Way Off Base (Offbeat Stories and Pics)

Social: Facebook \ YouTube \ Twitter \ Tumblr \ Pintrest \ RSS Feeds