1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Popping X-Fi

Discussion in 'Hardware' started by Baselerd, Mar 4, 2007.

  1. Baselerd

    Baselerd Private First Class

    I have an X-fi platinum that recently started to make popping sounds. I have z-5300e speakers. Here's the order of events. I used to have an audigy SE, and the speakers worked fine.

    I got an x-fi platinum about a month and a half ago, and it's been working fine un til about a few days ago, it would pop while playing GTA: SA. Now it always pops periodically (about once every 10 seconds) when it's in entertainment mode or game mode.

    So now I leave it in audio creation mode, but this is ridiculous. I know it's not the speakers because my integrated audio works. I tried updating the drivers and such, and no luck.

    Any ideas?
  2. toad42013

    toad42013 Private E-2

    I upgraded from the audigy SE to the X-fi platinum to. I also got the popping sound. To fix the problem I updated my drives. I have not has a problem since then. Have you tried to update drivers?

Share This Page

MajorGeeks.Com Menu

MajorGeeks.Com \ All In One Tweaks \ Android \ Anti-Malware \ Anti-Virus \ Appearance \ Backup \ Browsers \ CD\DVD\Blu-Ray \ Covert Ops \ Drive Utilities \ Drivers \ Graphics \ Internet Tools \ Multimedia \ Networking \ Office Tools \ NEW! PC Games \ System Tools \ Macintosh \ Demonews.Com \ Top Downloads

MajorGeeks.Com \ News (Tech) \ Off Base (Other Websites News) \ Way Off Base (Offbeat Stories and Pics)

Social: Facebook \ YouTube \ Twitter \ Tumblr \ Pintrest \ RSS Feeds