1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

"PXE-EC1: Base code ID stucture not found"?

Discussion in 'Hardware' started by gennarpierce, Aug 1, 2007.

  1. gennarpierce

    gennarpierce Private E-2

    I'm working with someone to image several systems using PXE boot but we receive a message...

    "PXE-EC1: Base code ID stucture not found"

    ... On searches I've found that there are references to the BIOS setup but we've flashed the BIOS to no avail and it happens on several systems so it can't be a corrupted BIOS.

    The error code itself is described as follows... "UNDI boot module could not find the BaseCode ROM ID structure. If there is a BaseCode ROM image in the system, it has probably been corrupted. "

    I've also found this bit of information "An UNDI Option ROM image is required for each boot device. This Option ROM image may be kept
    on a boot device’s local storage (for example, FLASH on a NIC) or built in to the Host System BIOS." from page 90/91 of this document ("Preboot Execution Environment (PXE) Specification") found at http://www.pix.net/software/pxeboot/archive/pxespec.pdf

    I have to admit that when I get into it I start to get crosseyed which is why I'm here to see if anyone can shed some light on the situation.

Share This Page

MajorGeeks.Com Menu

MajorGeeks.Com \ All In One Tweaks \ Android \ Anti-Malware \ Anti-Virus \ Appearance \ Backup \ Browsers \ CD\DVD\Blu-Ray \ Covert Ops \ Drive Utilities \ Drivers \ Graphics \ Internet Tools \ Multimedia \ Networking \ Office Tools \ NEW! PC Games \ System Tools \ Macintosh \ Demonews.Com \ Top Downloads

MajorGeeks.Com \ News (Tech) \ Off Base (Other Websites News) \ Way Off Base (Offbeat Stories and Pics)

Social: Facebook \ YouTube \ Twitter \ Tumblr \ Pintrest \ RSS Feeds