1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

shift keys won't work/are locked off - HP pavilion laptop

Discussion in 'Software' started by normalvideoartist, Apr 28, 2006.

  1. normalvideoartist

    normalvideoartist Private E-2

    HP Pavilion laptop running Microsoft ME. It has an Intel Pentium III inside and 128MB of RAM. The problem is that the shift keys - there are two of them, are not functioning. even now, to get an uppercase letter i have to turn capslock on and off, which is a pain. but the biggest problem is that i cannot use the characters on the number keys, like the @, which i just cut and pasted here.

    this has happened before by some unconscious keystroke and was turned off by trial and error/dumb luck pressing random keys in random combinations. now it has happened again. i am convinced that there is some keystoke that turns the shift keys on and off and not that my keyboard is on the fritz. hp support suggested shift plus caps and that seemed very probable, but did not work. they also seemed to think a num lock was on, but there is no numlock on my keyboard and that would not explain why i can't produce capital letters.

    i am thinking of getting an additional, external keyboard but if the problem is with the os, this will not help. yet if it is the keyboard itself, that would work.

    what do you think/ - that's my question mark. thanks.
  2. Mada_Milty

    Mada_Milty MajorGeek

    Hmmm...not sure if this is the problem, but could you have enabled sticky keys? Windows includes a feature for people with accessibility needs where if you press the shift key 5 times in a row, it changes it function.

    Try this:

    1. Open Control Panel
    2. Double-click 'Accessibility Options'
    3. Under 'Sticky Keys' make sure that the box next to 'Use StickyKeys' is unchecked
    4. Apply your settings

    Let us know if this works for you!
  3. bigbazza

    bigbazza R.I.P. 14/12/2011 - Good Onya Geek

    Until you sort out your problem I'd suggest fitting an external keyboard anyhow. Usually they are much better than laptop keyboards. Also get you further away from the screen so easier on the eyes. I always use an external mouse and keyboard when using a laptop from a static position (computer desk, table, whatever). Bazza


  4. normalvideoartist

    normalvideoartist Private E-2

    thanks for the advice. however, sticky keys was not checked in the accessibility options window. still stumped here. . . any more advice/
  5. bigbazza

    bigbazza R.I.P. 14/12/2011 - Good Onya Geek

    Only applicable (maybe) link I could find on google.


    Scroll down and you will see references to shift keys and things. Try other buttons on the page for manual and other bits and pieces. May help, probably not, but I hope so. Bazza
  6. MrCyberdude

    MrCyberdude Private E-2

    If you are playing Battlefield3 (BF3) they use ESN Sonar software that even when selected for voice activation will take over the keyboard.

    With Push-to-Talk you assign a button, which you press when you want to transmit. No matter what the key used I suggest that "Toggle blocking key" is not selected.

    So if you are using Left Shift (LShift) , Control (CTRL) , V key etc, then this could be the issue.

    If its a possible keyboard failure you can use the free 30 day software by PassMark called Keyboard Test to verify if its the keyboard or Windows.

  7. plodr

    plodr Major Geek Extraordinaire

    MrCyberdude, note this thread is more than 6 years old and the poster was running Windows ME. I suspect, he/she is on a different computer or at least on a different operating system.
  8. MrCyberdude

    MrCyberdude Private E-2

    I suspect you are right. ;) but who truly knows.. and your intent was? (friendly?,Trolling?) :-D
    I also suspect that others can benefit from the info without me starting a new thread of the same nature, coz thats all we need, another thread in the search engine. I also saw no other threads with a more suited title.

    BTW that was my first post at my favorite MajorGeeks and it wasn't a whining request for help or a flaming response but an actual helpful 1st post. I could have posted it elsewhere but I thought Majorgeeks could use the traffic for getting more readers.
    Oh and thanks for the Hi and Welcome to the forums like I might have guessed you were intending to do before being distracted so much by the relevent but old post. Cheers :wine
  9. moker777

    moker777 Private E-2

    when I press shift + 2 i get " (quotations) instead of getting the @ (at symbol)

    The solution to this is as follows!You need to hold down ctrl and function keys and then tap the shift key (let go of shift while still holding down the control and function keys)

    It was a left over for the blue keys (French Keys)
    these blue keys are french keys. if you change your keyboard settings to US or UK english , it will get rid of the blue functions, but for some reason, they tend to turn themslves back on again after time. (Most likely due to automatic updates followed by an auto restart.)

Share This Page

MajorGeeks.Com Menu

MajorGeeks.Com \ All In One Tweaks \ Android \ Anti-Malware \ Anti-Virus \ Appearance \ Backup \ Browsers \ CD\DVD\Blu-Ray \ Covert Ops \ Drive Utilities \ Drivers \ Graphics \ Internet Tools \ Multimedia \ Networking \ Office Tools \ NEW! PC Games \ System Tools \ Macintosh \ Demonews.Com \ Top Downloads

MajorGeeks.Com \ News (Tech) \ Off Base (Other Websites News) \ Way Off Base (Offbeat Stories and Pics)

Social: Facebook \ YouTube \ Twitter \ Tumblr \ Pintrest \ RSS Feeds