1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Sound Drivers

Discussion in 'Software' started by Retardasaurus, Aug 21, 2011.

  1. Retardasaurus

    Retardasaurus Private E-2

    Hi, i need help reinstalling my sound drivers.
    I tried every possible method in the book, and i recieved a code 39.
    I run a gateway gt 5481e on windows vista. Please help, i've tried to fix this for about two months, help would be appreciated.
  2. iain.t

    iain.t MajorGeek

    Hi and welcome to MG's.

    Download the free, Speccy http://majorgeeks.com/Speccy_d6358.html then run Speccy and click File > Save as Text File, then attach the log as per instructions below (note: as Speccy also now lists more data it likely will have your Windows licence serial key also in the log, so look for Operating System and under that Serial Number and delete the code and Save the log)

    Then attach your log to your next post as per these instructions http://forums.majorgeeks.com/showthread.php?t=86880

    This will give me a better picture of your systems set up and to getting you the correct fix for your issue.

    iain.t :major
  3. Retardasaurus

    Retardasaurus Private E-2

    Here you go man, hope this will help, and i think i'm missing a folder named realtek in my programs in the C drive, should i let the realtek installer make it's own folder or make it ahead of time? Thanks.

    Attached Files:

  4. iain.t

    iain.t MajorGeek

    Ok thanks for that ;),
    Right I need for you to download and install (but DO NOT RUN yet) Driver Sweeper... http://majorgeeks.com/Driver_Sweeper_d6171.html ... go to your device manager and uninstall the realtek driver from sound/video and games controllers, then go to programs and features and delete the realtek driver from your installed programs.Re-start your machine in Safe Mode (f8 at boot).

    >>>>>>>>>>>>>>>>>>>>>> YOU MUST COMPLETE THESE STEPS IN SAFE MODE >>>>>>>>>>>>>>>>>>>>>>>

    Run Driver Sweeper by right click "run as administrator" on the main screen you will see some options of what make of hardware drivers are installed, you need to select the "realtek sound" option by ticking the box along side it, click "Analyze" then click "Clean" in the bottom right of the sceen, run the "Clean" button 2x's to make sure it cleans up all residual left overs.

    Re- start your machine into Normal windows and click out of any "found new hardware" prompts. I need for you now to install these drivers here in the exact order that I instruct for you or the fix may not work ok!! ;).

    1.) Chipset Driver.....

    http://support.gateway.com/support/drivers/getFile.asp?id=21196&dscr=Windows Vista Intel Chipset Driver version:

    Re-start your machine.

    2.) Realtek Audio Driver.....

    http://support.gateway.com/support/drivers/getFile.asp?id=21404&dscr=Realtek High Definition Audio DriverVersion:

    Re-start your machine.

    It is very important that you re-start your machine after each install as this helps your system recognise the changes that have been made.
    Post back to let me know if the fix has worked or if you require any further assistance.

  5. Retardasaurus

    Retardasaurus Private E-2

    Sorry for the long delay, i was away from home for a while.
    Anyway, i did exactly what you said, the drivers working but it's unresponsive.
    As soon as i logged in after installing both the intel and the realtek drivers, microsoft sent me a message saying: " Realtek HD Audio control panel for Vista has stopped working properly." A newer version of this software is available for download that addresses this problem. Realtek Semiconductor Corp. recommends updating to take advantage of security and stability improvements.

    Should i download the new driver?
    Edit: There is still a code 39. I forgot to mention that in the last post. I looked in the device manager and it still had the same exact problems as the first time except the installation was successful.
  6. iain.t

    iain.t MajorGeek


    Yes download the updated driver, as the driver I supplied you with is the "original" driver for your system, it is always best to start "afresh" with the original drivers to resolve any issues first then update if it is required for security issues (like this is).

    iain.t :major
  7. iain.t

    iain.t MajorGeek

    When you say you are still experiencing the error code 39 can you tell me what device is causing this error, are there any yellow ! or red X in your device manager. If it is for your Audio Card then hopefully the updated driver will resolve it, if not for the audio then there is fixes available for the effected device.

  8. Retardasaurus

    Retardasaurus Private E-2

    I checked device manager and the two objects that have yellow !'s on them are as followed:
    Microsoft Kernel DRM Audio Descrambler
    Realtek High Definition Audio.
    I am currently downloading the audio software update that microsoft has given me. I'll be back soon to post the results of the download and installation.
  9. iain.t

    iain.t MajorGeek

    Ok let me know how you get on, I have a sneaky feeling that it might not work. But I have a fix that will if it doesn't.
  10. Retardasaurus

    Retardasaurus Private E-2

    Just installed the new update, same problem, it's not getting any better but it didn't get any worse.
  11. iain.t

    iain.t MajorGeek

    Ok, in your device manager where the ! is next to the DRM descrambler, delete the driver for this device (rightclick>delete). Restart your machine and see if windows re-installs the DRM driver, it may fix it, but if it doesn't you will have to do a reg fix.
  12. Retardasaurus

    Retardasaurus Private E-2

    It won't reinstall itself.
    Can you give me the link to the DRM descrambler so i can download it?
  13. iain.t

    iain.t MajorGeek

    here it is .... http://www.inetbridge.net/forum/download/file.php?id=2675 .... it is a zip file so you will have to unpack it, once unpacked double click wdmaudio.inf and follow the prompts. I have checked the file and it is safe (scanned with Iobit and Comodo).
  14. Retardasaurus

    Retardasaurus Private E-2

    I clicked the download link and it led me to error 404.
    File not found.
  15. tgell

    tgell Major Geek Extraordinaire

  16. Retardasaurus

    Retardasaurus Private E-2

    I just downloaded it and unpacked it.
    However, every time i open the inf, it leads me to a text document....
  17. iain.t

    iain.t MajorGeek

    Remove that from your machine, you are going to have to try the reg fix....

    Device manager: uninstall all the sound drivers. If your getting this: Microsoft Kernel DRM Audio Descramber Microsoft Streaming Clock Proxy Microsoft Quality Manager Proxy Microsoft Service Proxy Microsoft Tee/Sink-to-Sink Converter Realteck AC'97, uninstall all the DRM. Then go to regedit(start>type> regedit.ex) and see below Regedit Navigate to: HKeyLocalMachine\System\CurrentControlSet\Control\Class{4D36E96C-E325-11CE-BFC1-08002BE10318} ON RIGHT PANE...I deleted: Dword value for LOWER FILTERS. Reboot and don't let Windows auto-install....don't let it...it will give you all that ____ mentioned above,when you restart your system, to stop Windows reinstalling the old/default drivers you need to start task manager and stop the process called 'rundll32'. Reinstall the sound from a package from Realtek for Vista from here.... download and save to your desktop before trying the fix.... http://www.realtek.com/downloads/do...=24&Level=4&Conn=3&DownTypeID=3&GetDown=false ....you need to select "I accept to the above" on the next page you need to download the top driver "Vista, Windows7 Driver (32/64bits) Driver only (Executable file) R2.64 ... right click and run as administrator, follow the prompts and restart your machine.
  18. Retardasaurus

    Retardasaurus Private E-2

    I'm sorry, i didn't really get the DWORD Values part....
    can you explain in a little more detail please? Sorry about that.
  19. Retardasaurus

    Retardasaurus Private E-2

    Never mind, just fixed it by myself. Thanks for your help guys!
  20. iain.t

    iain.t MajorGeek

    Sorry about not been able to respond to you before now, been a very hectic week!!

    I am pleased to hear that you have resolved the issue ;). Thanks for the feed back!! could you explain how you managed to resolve it ?? it may help another poster with a similar issue.


Share This Page

MajorGeeks.Com Menu

MajorGeeks.Com \ All In One Tweaks \ Android \ Anti-Malware \ Anti-Virus \ Appearance \ Backup \ Browsers \ CD\DVD\Blu-Ray \ Covert Ops \ Drive Utilities \ Drivers \ Graphics \ Internet Tools \ Multimedia \ Networking \ Office Tools \ NEW! PC Games \ System Tools \ Macintosh \ Demonews.Com \ Top Downloads

MajorGeeks.Com \ News (Tech) \ Off Base (Other Websites News) \ Way Off Base (Offbeat Stories and Pics)

Social: Facebook \ YouTube \ Twitter \ Tumblr \ Pintrest \ RSS Feeds