1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Startup Repair Infinate Loop can't Enter Safe Mode

Discussion in 'Software' started by SLoTH_XVX, Jun 25, 2012.

  1. SLoTH_XVX

    SLoTH_XVX Private E-2

    I have a Toshiba laptop running Windows 7 that is stuck in a Startup Repair Loop. I have read through some of the postes here and other sites including Microsoft and not been able to 1) Stop this infinite loop or 2) access Safe Mode.

    I thought it would be better to begin a new thread instead of adding to an existing one.

    I have gotten to the point where the Startup Repair says it has found a solutiona nd will reboot to complete but it continually returns to the Startup Repair 'software' after rebooting.....

    Any one been able to get out of this loop?

    I do not have a recovery disk or other disks. We did not receive and disks as everything was loaded on the laptop when we purchased it.
  2. tgell

    tgell Major Geek Extraordinaire

    See if the process here will help. It is a long article so it may help to read through it first. You can click on any image to get a larger view. In step 14 it says to type the command.

    copy *.* ..

    You have to include a space after the last * and then two periods. This copies the files to the parent directory of Regback which is config.

  3. SLoTH_XVX

    SLoTH_XVX Private E-2

    Thanks 'tgell' I have tried this and it did not correct the issue.
  4. tgell

    tgell Major Geek Extraordinaire

    I do not like to mess with the MBR of an OEM computer because it might cause your recovery partition to fail. Toshiba has the option of doing a factory reset. All data would be lost since purchase but it can be backed up using a small linux distro like Puppy. Would you be willing to try a factory reset after you back up your data?

    Also, this might be a problem with the BCD but I do not have much experience with that. sach2 hopefully will see this and jump in. He may have some ideas on fixing the problem.
  5. SLoTH_XVX

    SLoTH_XVX Private E-2

    I think I figured out what MBR is but what is BCD?
  6. tgell

    tgell Major Geek Extraordinaire

    BCD Boot Configuration Data store. It has the boot configuration parameters and controls how the operating system is started. In XP it was done with the Boot.ini file. Windows Vista and Windows 7 went to BCD which I think is way more complicated.

    At the command prompt, type BCDEDIT and post the contents. It may help.
  7. SLoTH_XVX

    SLoTH_XVX Private E-2

    I would be willing to do the factory reset but I will need guidance on how to do the back-up.

    I will post the contents via the BCDEDIT command prompt.....how do I get the info from the command window to here if I can not access anything on the computer?
  8. tgell

    tgell Major Geek Extraordinaire

    That's a very good question. I forgot about that. I am going to have to do some research on this. Hopefully we can get it to a USB flash drive or you can write it down and type it worse case. I will be coming back tomorrow. Hopefully sach2 may jump in with his thoughts.
  9. SLoTH_XVX

    SLoTH_XVX Private E-2

    It is not that much I can simply retype here.

    Windows Boot Manager
    identifier {bootmgr}
    device partition+D:
    description Windows Boot Manager
    locale en-US
    inherit {globalsettings}
    default {default}
    resumeobject {12800476-f24b-11df-b935-9f54c4a67c27}
    displyorder {default}
    toolsdisplayorder {memdiag}
    timeout 30

    Windows Boot Loader
    identifier {default}
    device partition=C:
    path \windows\system32\winload.exe
    description Windows 7
    locale en-US
    inherit {bootloadersettings}
    recoverysequence {current}
    recoveryenabled Yes
    osdevice partition=C:
    systemroot \windows
    resumeobject {12800476-f24-11df-b935-9f54c4a67c27}
    nx OptIn
    winpe No
  10. tgell

    tgell Major Geek Extraordinaire

    Have you tried safe mode by tapping F8 at boot? If not, go into safe mode and select Last Known Good Configuration. If it still loops, go into safe mode again and select Disable automatic restart on system error. It may throw up a blue screen with an error.
  11. SLoTH_XVX

    SLoTH_XVX Private E-2

    Can not access Safe Mode at all.
  12. tgell

    tgell Major Geek Extraordinaire

    For backing up your important data, do you have a external USB drive?
  13. SLoTH_XVX

    SLoTH_XVX Private E-2

    Yes, I has a 2gb USB Flash and also several external Hard Drives.
  14. tgell

    tgell Major Geek Extraordinaire

    First can you do the following. Disconnect any external drives. Type the following in a command prompt.

    list disk
    select disk 0
    I believe this will be the disk to select as you only have one hard drive.
    detail disk

    What is shown under Volume## and the rest of the headings?
  15. SLoTH_XVX

    SLoTH_XVX Private E-2

    Under Volume ##:

    Volume 1 - C - TI105952W0C - NTFS - Partition - 22 GB - Healthy
    Volume 2 - D - System - NTFS - Partition - 1500 MB GB - Healthy - Hidden
  16. tgell

    tgell Major Geek Extraordinaire

    That is kind of weird that the drive is listed as only 22GB. Too small for a Windows 7 install. When you did the "detail disk" command did it list Volume 1 as being a system disk. That would show up after the healthy listing. What was the size of disk 0 and the amount of free space available under the "list disk" command? The hidden partition is only 1.5 GB so I believe if this is in fact the recovery partition, it is not Windows 7 but maybe XP. Was Windows 7 installed on this computer later.
  17. tgell

    tgell Major Geek Extraordinaire

    I will be stepping out for a couple of hours.
  18. SLoTH_XVX

    SLoTH_XVX Private E-2

    Sorry my mistake....that should have been 222 GB not 22
  19. tgell

    tgell Major Geek Extraordinaire

    That sounds okay but the 1.5GB repair partition has me a little worried. If you used that, you may not be getting Windows 7. What is the make and model of the Toshiba.

    After the command select disk 0

    list partition

    What is listed? Is should list Partition 1 and Partition 2. Type:

    Select Partition 1
    list Partition 1

    What is listed under the headings? Does it say System under the Info heading?

    Now type:
    Detail partition
    Does it list the partition as Active:Yes?

    Select Partition 2
    Detail Partition

    Is the size 15GB or 1.5GB?
  20. SLoTH_XVX

    SLoTH_XVX Private E-2

    It lists 3 partitions:

    Partition 1 - Recovery - 1500 MB - 1024 kb (offset)
    Partition 2 - Primary - 222 GB - 1501 Mb (Offset)
    Partition 3 - Primary - 9 GB - 223 GB (Offset)

    After typing "list Partition 1" I get the following
    "The arguments specified for this command are not valid. For more information on the command type: HELP LIST PARTITION"

Share This Page

MajorGeeks.Com Menu

MajorGeeks.Com \ All In One Tweaks \ Android \ Anti-Malware \ Anti-Virus \ Appearance \ Backup \ Browsers \ CD\DVD\Blu-Ray \ Covert Ops \ Drive Utilities \ Drivers \ Graphics \ Internet Tools \ Multimedia \ Networking \ Office Tools \ NEW! PC Games \ System Tools \ Macintosh \ Demonews.Com \ Top Downloads

MajorGeeks.Com \ News (Tech) \ Off Base (Other Websites News) \ Way Off Base (Offbeat Stories and Pics)

Social: Facebook \ YouTube \ Twitter \ Tumblr \ Pintrest \ RSS Feeds