1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Unable to register some Windows Updates components

Discussion in 'Software' started by pvtford, Jul 17, 2012.

  1. pvtford

    pvtford Private E-2

    Dell Dimension 4300S, Pentium 4 1.60 GHz, 768 MB RAM
    XP Home SP3, version 2002
    IE 8.0.6001.18702IC, 128-bit cypher strength, Update Versions: 0

    I'll cut to the chase and then give a bit of background. The current hurdle is that three updates from Windows Update have failed repeatedly to install. They are Security Update for Windows XP (KB2510531), Security Update for Internet Explorer 8 for Windows XP (KB2544521) and Cumulative Security Update for Internet Explorer 8 for Windows XP (KB2699988).

    The error code is 0x8007f0da. One of the things Microsoft suggests is to "reset the Windows Update componenets." It's a fairly involved procedure which went well until I went to %windir%\system 32 and ran regsvr32.exe on about forty .dll files. I hit snags with three of them:

    mshtml.dll -- "mshtml.dll was loaded, but the DllRegisterServer entry point was not found. This file can not be registered."
    wucltux.dll and wuwebv.dll -- "LoadLibrary ([filename]) failed - The specified module could not be found."

    Sounds to me like the first of these files is corrupted, and the other two are missing.

    Question: If I'm right about this, and if it really is causing the problem, how can I get good copies of these files? I have my XP CD.

    The road to this pass has been a bit convoluted. I set out to solve two persistent problems: One, when I would close an online article from a particular site, the page would reopen itself on several tabs, which would bring my memory-starved machine to its knees. And, two, more recently, when I clicked on a link to a .PDF, it would open in a browser window, followed by a message from C++ Runtime saying the application had requested to be closed in an unusual way. Windows would then close the window, offer to send a report to Microsoft, and then recover the tab, where the cycle would begin again.

    A Microsoft help page said,"If the problem is caused by damaged or incompatible Internet Explorer settings or add-ons, you can usually resolve the problem by resetting Internet Explorer settings."

    After I did that, the original problems went away, but Windows Update stopped working, suddenly unable to load the page showing the available updates. Then I hit a Microsoft page that claimed I was running IE7, although control Panel > System showed 8. I clicked a link to upgrade to 8, the popup window said it was removing the old IE, and then installing IE8, until it hit a snag, was unable to continue and was putting everything back the way it was.

    Now I was able to download updates, but only three out of ten would install. A few reboots later, Windows Update reports only three outstanding updates, which I have downloaded but still can't install.
  2. tgell

    tgell Major Geek Extraordinaire

    wuwebv.dll is a Vista dll. For XP it should be wuweb.dll

    Copies of mshtml.dll and wuweb.dll can be found in C:\Windows\ServicePackFiles\i386
  3. pvtford

    pvtford Private E-2

    Many thanks, tgell! Just what I was hoping for.

    Next question: How many steps should I repeat in the lather lengthy procedure (copied below, minus explanatory details) that revealed the need for the above files?

    I assume that at a minimum I will need to copy/overwrite the missing/defective files, stop the BITS and Windows Update services, register the replacement files, restart the services and reboot.

    Will I need to regsvr.exe all the .DLLs, or just the replacements? Will I need to repeat steps 3, 7 or 8? Here is the procedure:

    To reset the Windows Update components, follow these steps:

    1. Open a Windows Command Prompt Windows.

    2. Stop the BITS service and the Windows Update service.

    3. Delete the qmgr*.dat files. [Del "%ALLUSERSPROFILE%\Application Data\Microsoft\Network\Downloader\qmgr*.dat"]

    4. If this is your first attempt at resolving your Windows Update issues by using the steps in this article, go to step 5 without carrying out step 4. [I skipped step 4.]

    5. Type the following command at a command prompt, and then press ENTER:
    cd /d %windir%\system32

    6. Reregister the BITS files and the Windows Update files. [regsvr32.exe atl.dll -- that file, and about 40 others]

    7. Reset Winsock.

    8. If you are running Windows XP or Windows Server 2003, you have to set the proxy settings.

    9. Restart the BITS service and the Windows Update service.

    10. Install the latest Windows Update Agent.

    11. Restart the computer.
    Last edited: Jul 18, 2012
  4. pvtford

    pvtford Private E-2

    More problems. Took my ailing CPU to visit relatives a couple of days ago. I usually use mouse and keyboard with PS/2 plugs, but booted up with theirs, which are both USB. The lights on both were on during POST, but went out by the time the XP logo came up. Neither one worked - couldn't click on my user name to get to the Welcome screen.

    Borrowed PS/2 keyboard and mouse; able to use both. Oddly, a USB card reader works. Decided to re-run the procedure alluded to on 7/17 and 7/18 on this thread. I still don't have wucltux.dll, but it's not in my Windows\servicePackFiles\i386 folder either, so I didn't worry about trying to register it.

    I did hit a snag I don't remember from the earlier attempt. I attempted to do the following:

    "6. Reset Winsock. To do this, type the following command at a command prompt, and then press ENTER: netsh reset winsock" The series of errors that followed this are detailed in the attached screenshot, reset winsock.gif.

    I gave up on that step and did the remainder of the procedure. Now it's worse. On my IE home page, which is the sign-in page for Juno Email on the Web, when I click on the username and passsword fields, nothing happens. No insertion point appears, and typing produces no result. In the address bar, when I click on the existing address, it becomes highlighted and the insertion point appears; my typing replaces the highlighted text and produces a drop-down list of site suggestions; clicking on one of these puts it into the address bar, but I can't navigate to it. When I click the AVG Search Bar, the existing test disappears, and I can type, but instead of a menu of suggested search terms, I see "An error occurred." Clicking the "go" button has no effect. Internet Explorer does not accept text from me.

    Hyperlinks work normally, however, so I have a partial workaround. I wrote a hyperlink to majorgeeks.com and saved it as geeks.htm. I double-click that, click the resulting link, and I can get around on this site, but I still can't enter my username or password, so I submitted this on another computer.

    Some Windows things don't open. Help and Support opens a window of the right dimensions, which remains blank white. Ditto for Interner Explorer > Help > About Internet Explorer.

    Attached Files:

Share This Page

MajorGeeks.Com Menu

MajorGeeks.Com \ All In One Tweaks \ Android \ Anti-Malware \ Anti-Virus \ Appearance \ Backup \ Browsers \ CD\DVD\Blu-Ray \ Covert Ops \ Drive Utilities \ Drivers \ Graphics \ Internet Tools \ Multimedia \ Networking \ Office Tools \ NEW! PC Games \ System Tools \ Macintosh \ Demonews.Com \ Top Downloads

MajorGeeks.Com \ News (Tech) \ Off Base (Other Websites News) \ Way Off Base (Offbeat Stories and Pics)

Social: Facebook \ YouTube \ Twitter \ Tumblr \ Pintrest \ RSS Feeds