1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Windows not showing both DVD drives

Discussion in 'Hardware' started by Gale_Fujimiya, May 26, 2009.

  1. Gale_Fujimiya

    Gale_Fujimiya Private E-2

    Hi guys

    Right now I have a newly assembled PC. It runs on Core 2 DUo 2.8GHZ, a Gigabyte G31S2L MB, 2GB ddr2 RAM, one 250GB SATA HDD and two SATA DVD Writers.

    Here is the problem. In bios, both DVD Writers are detected. But after XP home, both drives cannot be detected in Windows. I tried removing the cables of one drive, and the other drive shows up in Windows!

    But I were to connect both at the same time, none will show up. In device manager, there will be an exclaimation mark on the one cd-rom drive, and the error says that the device wont start because a similar device is already running.

    I tried reinstalling Windows several times, but nothing would work.:(

    Help~ SOS~
  2. dlb

    dlb MajorGeek

    What service pack are you using with WinXP Home? Have you installed all the motherboard drivers, esp. the chipset INF drivers? The full model number of your motherboard appears to be GA-G31M-S2L which is a bit different from what you posted above, and you can download all your drivers from this link. Double check the connections on the motherboard; be sure the HD is on SATA1. With the PC unplugged from the power, disconnect both DVD drives from the motherboard and boot to Windows with no DVD drives. Then power down as usual, unplug the power, and hook up one DVD to SATA2, then reboot and hook up the 2nd DVD to SATA3. If that doesn't work, try 'skipping' a SATA port and use SATA3 and SATA4 for the DVD drives and leave SATA2 empty. If none of this helps, please post the Windows service pack and the exact error message you're getting. Good luck!
  3. Gale_Fujimiya

    Gale_Fujimiya Private E-2

    To be honest, I tried SP1, SP2 and SP3. (SP1 belongs to the customer, SP2 belongs to me and SP3 belongs to my company.) The problem is, even before I install the drivers, the drives disappeared!

    Well, the computer has been returned already, but I would like to get to the bottom of this weird case though..just in case it decides to happen to me again

Share This Page

MajorGeeks.Com Menu

MajorGeeks.Com \ All In One Tweaks \ Android \ Anti-Malware \ Anti-Virus \ Appearance \ Backup \ Browsers \ CD\DVD\Blu-Ray \ Covert Ops \ Drive Utilities \ Drivers \ Graphics \ Internet Tools \ Multimedia \ Networking \ Office Tools \ NEW! PC Games \ System Tools \ Macintosh \ Demonews.Com \ Top Downloads

MajorGeeks.Com \ News (Tech) \ Off Base (Other Websites News) \ Way Off Base (Offbeat Stories and Pics)

Social: Facebook \ YouTube \ Twitter \ Tumblr \ Pintrest \ RSS Feeds