MajorGeeks Support Forums

Go Back   MajorGeeks Support Forums > ----------= PC, Desktop and Laptop Support =---------- > Software
Register FAQ Members List Calendar Casino Mark Forums Read

Software Software such as operating systems like Windows XP, Windows Vista, Windows 7 etc., or specific programs.


Reply
 
Thread Tools Display Modes
  #1  
Old 07-20-08, 13:59
Tal Tal is offline
Private E-2
 
Join Date: Sep 2002
Location: Lancashire, UK
Posts: 14
Thanks: 3
Thanked 0 Times in 0 Posts
Default C-Media AC97 Audio Device

My friends computer has the above Sound Card, but no sound.

I have tried to help by downloading what seems to be the most recent driver package, (after being tricked into endless downloads of *Driver Management* apps which only revealed the necessary fee payment at the last moment).

But still there is no sound. Can anyone help?
__________________
Utram bibis? Aquam an undam?
Reply With Quote
Sponsored links
  #2  
Old 07-20-08, 21:40
musksnipe
Guest
 
Posts: n/a
Default Re: C-Media AC97 Audio Device

Check: Speakers connected? Do they work?
Check: Master Volume control. (not muted)
Check that Windows Audio Service is started.
Go to Control Panel>Administrative Tools>Services
Scroll down the list of services until you find the Windows Audio service.
Right click on it and choose Properties.
Make sure it is set to Automatic and Start is checked.

Check: Device Manager for bad drivers.
For XP: Go to Start>Control Panel> System. On the Hardware tab, click Device Manager, then click the plus sign in front of Sound, Video, Game Controllers.
For Vista: Go to Start>Control Panel>Device Manager
In Device Manager, if there is a ? in front of your audio device, that means no audio driver is installed.
A ! means driver installation attempted but with problems.


What OS are you using?
Reply With Quote
  #3  
Old 07-20-08, 22:13
Tal Tal is offline
Private E-2
 
Join Date: Sep 2002
Location: Lancashire, UK
Posts: 14
Thanks: 3
Thanked 0 Times in 0 Posts
Default Re: C-Media AC97 Audio Device

Check: Speakers connected? Do they work? Check

Check: Master Volume control. (not muted)Check

Check that Windows Audio Service is started.
Go to Control Panel>Administrative Tools>Services
Scroll down the list of services until you find the Windows Audio service.
Right click on it and choose Properties.
Make sure it is set to Automatic and Start is checked.Check

Check: Device Manager for bad drivers. Check. Info reads "This device is working properly".

What OS are you using? Windows XP Service Pack 3
__________________
Utram bibis? Aquam an undam?
Reply With Quote
  #4  
Old 07-20-08, 23:56
musksnipe
Guest
 
Posts: n/a
Default Re: C-Media AC97 Audio Device

Goto Start>Control Panel>Sounds and Audio Devices.
Click the Audio tab.
Is C-Media set as the default device?
Click Advanced there, are the type speakers you're using, selected?
Reply With Quote
The Following User Says Thank You to For This Useful Post:
Tal (07-21-08)
  #5  
Old 07-21-08, 02:23
Tal Tal is offline
Private E-2
 
Join Date: Sep 2002
Location: Lancashire, UK
Posts: 14
Thanks: 3
Thanked 0 Times in 0 Posts
Default Re: C-Media AC97 Audio Device

Thanks dude, problem solved! There was an old installation of some other thing still set as default device, silly of me not to think of that.
__________________
Utram bibis? Aquam an undam?
Reply With Quote
Sponsored links
  #6  
Old 07-21-08, 10:12
musksnipe
Guest
 
Posts: n/a
Default Re: C-Media AC97 Audio Device

It's the simple things that, sometimes, catch us up.
I spent 3 days and 15 posts with a problem that turned out to be unplugged speakers!

Reply With Quote
  #7  
Old 07-23-08, 10:50
Tal Tal is offline
Private E-2
 
Join Date: Sep 2002
Location: Lancashire, UK
Posts: 14
Thanks: 3
Thanked 0 Times in 0 Posts
Default Re: C-Media AC97 Audio Device

Hey dude, thanks for your help, but guess what? I just discovered that while any mp3 or video file which is actually stored on the PC hard drive plays absolutely fine, any *streamed* video or audio (eg. Youtube) is still weirdly silent!

I'm clueless as to why. If I download the streamed video or audio (eg. with save2pc or freecorder), then it works just fine.

Any ideas??
__________________
Utram bibis? Aquam an undam?
Reply With Quote
  #8  
Old 07-23-08, 11:11
musksnipe
Guest
 
Posts: n/a
Default Re: C-Media AC97 Audio Device

Try intalling the K-Lite Codec Tweak Tool:

http://majorgeeks.com/K-Lite_Codec_T...ool_d5738.html

Then check the box next to [Registry] Fix non-working system sound
It should fix the problem
Reply With Quote
  #9  
Old 07-23-08, 16:38
Tal Tal is offline
Private E-2
 
Join Date: Sep 2002
Location: Lancashire, UK
Posts: 14
Thanks: 3
Thanked 0 Times in 0 Posts
Default Re: C-Media AC97 Audio Device

Aww...

...you had my hopes up for a minute dude, but it's a negative. Still got perfect playback with any audio or video on the machine, but silent Youtube and any other streamed audio.
__________________
Utram bibis? Aquam an undam?
Reply With Quote
  #10  
Old 07-23-08, 17:15
musksnipe
Guest
 
Posts: n/a
Default Re: C-Media AC97 Audio Device

I've seen a few threads here with that problem and didn't pay a lot of attention to them. I'm not sure if there ever was a solution.
There are a lot of them on the 'net, too. Some go back more than a year with no solution.
Most say update and reinstall to the newest Flashplayer. That's a possible cure for you.

I also saw this and it seemed to help quite a few folks.
Make sure to set a Restore Point!
Go to Start>Run, type regedit.exe
Press Enter.
Find:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Drivers32
Create a new String value named “wavemapper“. As a value, give it “msacm32.drv“.
(Right Click the Right Window: New/String Value –enter wavemapper
Highlight wavemapper for VALUE AS and enter: msacam32.drv
)

If you have no Volume Control now. Go to
Control Panel>Sounds and Audio Devices> Volume.
"Place volume icon in the taskbar" Make sure it is checked. Click Apply.

You should now have a sound.
Reply With Quote
Sponsored links
  #11  
Old 07-24-08, 09:25
Tal Tal is offline
Private E-2
 
Join Date: Sep 2002
Location: Lancashire, UK
Posts: 14
Thanks: 3
Thanked 0 Times in 0 Posts
Default Re: C-Media AC97 Audio Device

I'm afraid it's not possible for me to do that, because a string called 'wavemapper' with the exact value you've given already exists at that location in the registry! (The XP has service pack 3 installed, could this be why?)

Anyway I really appreciate your attempts to help, it's starting to look like this is some kind of defect in the C-Media hardware or software and the best thing my friend could do would be to replace it. (What a great company they are! You go to their website for help and it says 'we do not give support to users, seek help on our forums'. You then try to register on the forum, but just get an email which says something like 'you will soon receive an email confirming that an administrator has made your account active'. That was about 4 days ago now I guess.)
__________________
Utram bibis? Aquam an undam?
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Baffling C-Media AC97 Audio Device Ibsen3 Software 3 08-19-07 07:03
AC97 C-Media Drivers? Ctrl-Alt-Del Software 9 05-09-06 16:24
AC97 Audio getuonline Hardware 4 04-23-06 04:15
C-Media AC97 Audio Device Dynex Software 1 01-18-06 01:13
which Realtek Ac97 audio drivers??? jpmad4it Software 6 09-23-05 05:58


All times are GMT -5. The time now is 22:01.

MajorGeeks.Com Menu

MajorGeeks.Com \ All In One Tweaks \ Android \ Anti-Malware \ Anti-Virus \ Appearance \ Backup \ Browsers \ CD\DVD\Blu-Ray \ Covert Ops \ Drive Utilities \ Drivers \ Graphics \ Internet Tools \ Multimedia \ Networking \ Office Tools \ NEW! PC Games \ System Tools \ Macintosh \ Demonews.Com \ Top Downloads

MajorGeeks.Com \ News (Tech) \ Off Base (Other Websites News) \ Way Off Base (Offbeat Stories and Pics)

Social: Facebook \ YouTube \ Twitter \ Tumblr \ Pintrest \ RSS Feeds


All content Copyright © MajorGeeks.com source code Powered by vBulletin® Version 3.8.4
Copyright © 2009 vBulletin Solutions, Inc. All rights reserved.
Ad Management by RedTyger