MajorGeeks Support Forums

Go Back   MajorGeeks Support Forums > ----------= PC, Desktop and Laptop Support =---------- > Software
Register FAQ Members List Calendar Casino Mark Forums Read

Software Software such as operating systems like Windows XP, Windows Vista, Windows 7 etc., or specific programs.


Reply
 
Thread Tools Display Modes
  #1  
Old 05-11-08, 11:17
tyrael98 tyrael98 is offline
Private E-2
 
Join Date: May 2008
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Default Realtek Ac'97 Audio Driver Problem

Hi everyone!

I try to give as much detail of this problem as I can think of right now:
I just freshly reformated my C: drive, and when I went to reconfigure my drivers, the sound driver can't seem to work properly.
The computer beeps whenever it should give the standard windows ding from the speekers, the device manager shows a yellow exclamation mark (!) at my sound driver, which is a Realtek AC'97 Audio driver, and when I try to refresh or dowload another one, it says: Device cannot be activated (Code :10). I've downloaded the latest version from Realtek's page, did not fix it. It gives me a warning when I try to refresh it though, that 'This device did not pass the Windows Logo test', saying it's not compatible with XP. Which is funny, since before the reformat, I've been using it for a year without any problems. My Audio Card is an Intel 82801GB ICH7 - AC'97 Audio Controller [A-1], according to Everest. I've also checked the audio support in BIOS, it's enabled. In the Control Panel->Sound & Audio Devices panel everything is grayed out, every checkbox and every combobox on all tabs.

Can someone help me with this problem? I'm in a serious need of music right now...
Reply With Quote
Sponsored links
  #2  
Old 05-11-08, 11:52
musksnipe
Guest
 
Posts: n/a
Default Re: Realtek Ac'97 Audio Driver Problem

Some things to check:
Check that Windows Audio Service is started.
Go to Control Panel>Administrative Tools>Services
Scroll down the list of services until you find the Windows Audio service.
Right click on it and choose Properties.
Make sure it is set to Automatic and Start is checked.

Make sure all your updates are current, including DirectX.

If you aren't able to fix this post a make and model # if your PC is manufactured (Dell, Gateway, HP, etc.) or your motherboard ID, if it is a build. Or even better:
Use Everest to get a report of your system’s hardware, OS, and drivers. Upload the report as an attachment
Everest: http://www.majorgeeks.com/download.php?det=4181
When Everest is done scanning, click "Report" at the top of the Everest window, click next to get to "Report Profile", select "Hardware related pages", click next, select "Plain Text", click "Finish". Then when it is done processing, click "Save To File". Save it where you want to. (I would use Desktop.)
Click "Go Advanced" in the MG reply box, scroll down a little way until you see "Manage Attachments", click it, browse to your file, click "Upload", and close the window. Then submit the post. You may have to also type something in the reply box, like, "Here's my report.", so that it will submit.


Also, the attachment below may help you out some.
Attached Files
File Type: txt Missing XP Sound Read Me.txt (5.1 KB, 36 views)
Reply With Quote
  #3  
Old 05-11-08, 13:32
tyrael98 tyrael98 is offline
Private E-2
 
Join Date: May 2008
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Default Re: Realtek Ac'97 Audio Driver Problem

Thx for the reply.

Well I've made the Everest report as you asked, and read the attachment file, though I've already tried a lot of them before. (I just forgot to mention them :o). Yes, the Windows audio is set to automatic and is enabled. I also tried to reenable it without any changes.

The only thing I can give a 20% chance to happen is that something there really does conflict with the driver.

As for other problematic devices, I have a Non Plug'n'Play plugin called EIO displayed in the device manager with a similiar exclamation mark, though as I read about it, it's just something for printers (I don't have a printer connected).

Hope this helps. (BTW, my XP isn't english, so the report might have some words you don't understand. If so just ask.)
Attached Files
File Type: txt Report.txt (195.6 KB, 16 views)
Reply With Quote
  #4  
Old 05-13-08, 23:27
musksnipe
Guest
 
Posts: n/a
Default Re: Realtek Ac'97 Audio Driver Problem

Try reinstalling your chipset driver, if you have the disc, if not here is the Intel 945P chipset driver:
INF Update Utility - Primarily for Intel® 3, 900 Series
And this is the Realtek AC'97 driver. Not sure that is the proper one, but Intel usually uses them with that audio controller.
Realtek audio/WDM_A404.exe
Reply With Quote
  #5  
Old 05-14-08, 07:04
tyrael98 tyrael98 is offline
Private E-2
 
Join Date: May 2008
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Default Re: Realtek Ac'97 Audio Driver Problem

Nope, still nothing

Are you sure this has to be the drivers fault?
e.g. some other software - driver or otherwise - messes with Realtek's drivers or a file's missing from somewhere or an old file which hasn't been updated automaticly or I don't know. (Or a government conspiracy or Elvis want's to send a message this way. I'm getting out of ideas.)

Also, do you think that buying a sound card might work here?
(The one I got now is onboard sound) Or it'll just mess things up more with having more then one of them.
I've found a hell lot of similiar forums and topics about this particular sound drive, so there has to be a problem with it. (What's worse, none of them were seem to be solved)

I'm seriously waiting your answer
Reply With Quote
Sponsored links
  #6  
Old 05-14-08, 11:52
musksnipe
Guest
 
Posts: n/a
Default Re: Realtek Ac'97 Audio Driver Problem

An add on card would probably solve your problem, yes. When you add one, you disable the on board sound, so there would be no conflict between them.
There could be a conflict between the driver and something else you have installed. The best way to avoid that in a fresh install is to load the chipset drivers, then the audio. After that the rest of the drivers.
Here are a couple of things to try before running out and spending money.

Delete your Realtek through Add/Remove programs.
Run CCleaner, both the Cleaner and Registry.
http://www.majorgeeks.com/CCleaner_S...ish_d4191.html
Install your driver.

Plug and Play Software Device Enumerator
Scenario One
You DO have "Plug and Play Software Device Enumerator" listed under System Devices
Carry out the following steps;
* Copy C:\WINDOWS\inf\machine.inf to a temporary location
* Edit your copy of machine.inf in Notepad
* Remove line 20 (ExcludeFromSelect=*)
* Right-click “Plug and Play Software Device Enumerator” and click “Update Driver”
* Choose “Install from a list or specific location (Advanced)” and click Next
* Choose “Don’t search. I will choose the driver to install” and click Next
* Click “Have Disk”
* Browse to the location of your copy of machine.inf and click OK
* Select “Plug and Play Software Device Enumerator” and click Next
* Wait for the software to install then click Finish

Scenario Two
You DON’T have "Plug and Play Software Device Enumerator" listed under System Devices
Carry out the following steps;
* Copy C:\WINDOWS\inf\machine.inf to a temporary location
* Edit your copy of machine.inf in Notepad
* Remove line 20 (ExcludeFromSelect=*)
* Go to the Control Panel and run “Add Hardware”
* When the Add Hardware Wizard appears, click Next
* Wait for it to search for new hardware
* Choose Yes, I have already connected the hardware and click Next
* Scroll all the way down and select “Add a new hardware device”, click Next
* Choose “Install the hardware that I manually select from a list (Advanced)”, click Next
* Select “Show All Devices” and click Next
* Click “Have Disk”
* Browse to the location of your copy of machine.inf and click OK
* Under Model, select “Plug and Play Software Device Enumerator”, click Next
* To start installing the drivers, click Next
* Wait for the software to install then click Finish

Now see if you can install your driver.
Reply With Quote
  #7  
Old 05-14-08, 15:37
tyrael98 tyrael98 is offline
Private E-2
 
Join Date: May 2008
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Default Re: Realtek Ac'97 Audio Driver Problem

Sorry, didn't work either.

So you were saying that as a last resort I should reinstall Windows (or reformat the system again) and start the driver installations all over - this time starting with the audio, or buy an add-on card and make sure the old one's turned off in BIOS.
Well I try to hold myself off until next week (maybe someone will come to save me while I'm waiting ....... not), then I'll start in the above order.

The only thing I don't understand is what can possibly go wrong at a fresh reformat...
Reply With Quote
  #8  
Old 05-15-08, 21:44
musksnipe
Guest
 
Posts: n/a
Default Re: Realtek Ac'97 Audio Driver Problem

I just found some info on your board that I was looking for and most have overlooked. You have HD audio. You will need an HD driver, not a plain AC'97 one. You also need to install the MS UAA Bus driver first.
This is what we need to do:
1) In Device Manager, remove the High Definition audio device (or the unknown device, if there is one) under Sound, Video & Game controllers.
2) Go into Device Manager>System, right click the UAA Hi-Def Bus driver.
Disable the device and then uninstall it. (Do not re-boot yet)
3) Uninstall Realtek High Definition Audio Driver (you may just have a folder that says Realtek) through Add/Remove Programs (if it's installed but not working)
KB888111
In Add/Remove Programs, look for the KB888111 update and uninstall it. (It may have uninstalled in last step)
If you install, remove, and then re-install this update, the update is no longer listed in Add or Remove Programs in Control Panel.
Therefore, you cannot remove this update from your computer.
To work around this problem, follow these steps.
1. Click Start, click Run, type regedit in the Open box, and then click OK.
2. Locate and then click the following subkey in the registry:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Updates\Windows XP\SP2\KB888111 (may be in SP3)
3. On the Edit menu, click Delete.
4. Click Yes, and then exit Registry Editor.
Run CCleaner, both the Cleaner and Registry.
http://www.majorgeeks.com/CCleaner_S...ish_d4191.html
Reboot, but don't let Windows install the driver.
Install the MS UAA Bus driver:
Microsoft-UAA-Bus-Driver-for-High-Definition-Audio
Install your driver, then reboot, again.
http://www.majorgeeks.com/Realtek_Hi...P03_d4902.html
Reply With Quote
  #9  
Old 05-16-08, 04:14
tyrael98 tyrael98 is offline
Private E-2
 
Join Date: May 2008
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Default Re: Realtek Ac'97 Audio Driver Problem

The more I dig myself into this, the more strange behaviours I find.
But lets start from step 1.
Actually, there were a lot of missing steps here I couldn't make.

1. I uninstalled every audio driver once again.
2. under device manager ->system devices there wasn't anything called UAA Hi-Def Bus driver
3. In the add/remove programs there wasn't anything called KB888111
4. Neither was in the registry. The only key SP3 uses is a KB926929
5. Since I haven't done anything yet, I didn't run CCleaner
6. I downloaded the MS UAA Bus driver.
7. And the HD driver.

Now there are a few things I'd like to write here.

I did remember vaguely that I was using a HD audio control back when it was working, but as the installation behaved, I thought it's more like an add-on symbiote for ac'97. My driver CD does have a folder named 'HD' inside the audio part, but
1.) The splash menu always installed ac'97 when clicked
2.) When I put it up manually without any ac'97 drivers, not even the device manager could recognize it, and still thought there's a driver missing.

Whats more, this still is the case with the links you gave me. If I don't have the plain ac'97 the device manager shows an unindentified Multimedia Audio Driver inside the Other Devices segment. Says the plugins are missing for the device, code 28.
Reply With Quote
  #10  
Old 05-16-08, 09:42
musksnipe
Guest
 
Posts: n/a
Default Re: Realtek Ac'97 Audio Driver Problem

I took a step back and looked over this whole thread, because i am getting confused, but I think I finally have a grasp of what's going on.
First, that AC'97 has been throwing me off. Second, all the review specs and even the specs at Abit only state: On board HD 7.1 CH Audio CODEC.
I finally found a diagram that may help to straighten this all out. If you look at the thumbnail you will see your audio chip. (The diagram is of your motherboard) It states Intel HD audio and I believe Intel uses the AC'97 chip for that.
So now we have to remove all Realtek.
Perform these steps again: (Don't worry if one isn't there, we just want to clean up stray driver bits)
  1. Click Start > Control Panel > Add/Remove Programs.
  2. Look for the following two items: Realtek* High Definition Audio Driver and High Definition Audio driver Package - KB888111.
  3. If these items are listed in Add/Remove programs, remove them.
  4. Run CCleaner, both the Cleaner and Registry.http://www.majorgeeks.com/CCleaner_S...ish_d4191.html
  5. Download the latest audio driver for your desktop board from Download Center.
  6. This is The HD audio driver from Intel and is for your chipset and Realtek chips: AUD_allOS_5605_PV_Realtek.exe Download
  7. Double-click the filename to extract the files.
  8. Go to the folder where the files have been extracted and browse to the \HDAQFE\xpsp2\us\ folder or the \MSHDQFE\Win2K_XP\us\ folder. (The name of this folder depends on your desktop board model.)
  9. Double-click the file kb888111xpsp2.exe to install the High Definition Audio Driver Package.
  10. Restart Windows.
  11. Install the audio driver.




Reply With Quote
Sponsored links
  #11  
Old 05-16-08, 13:22
tyrael98 tyrael98 is offline
Private E-2
 
Join Date: May 2008
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Default Re: Realtek Ac'97 Audio Driver Problem

Well, I'm not sure here. You said I have to remove all Realtek. I didn't take that literally, since my Ethernet driver's Realtek too. If that was a mistake, just tell me.
Anyway, I removed the other one's, the ac'97 and the HD ones.
Then I ran CCleaner.
I wasn't sure what you meant by point 5. I guessed it's the HD audio driver you gave me before (?)
Downloaded the exe and extracted.
Tried to run KB888111xpsp2.exe. Gave me an error that the version I already got is more up to date that the one I'm trying to run, probably referring to that it's made for SP2, and I got SP3. So I downgraded XP to SP2, ran the file, tried to run the HD setup from the folder I just extracted, then tried to run setup from the folder I downloaded before from the download center, then tried to run setup from my driver CD, but all of them ended the same. Unindentified Multimedia Audio Device, please run Wizard to make Windows detect the missing devices. (Which would put up ac'97 if I have the drivers' CD in, or otherwise wouldn't even find anything and quits.)
I put back Service Pack 3 eventually.
Reply With Quote
  #12  
Old 05-16-08, 15:35
musksnipe
Guest
 
Posts: n/a
Default Re: Realtek Ac'97 Audio Driver Problem

Quote:
I didn't take that literally, since my Ethernet driver's Realtek too. If that was a mistake, just tell me.
Yepper, you did right.
Quote:
I guessed it's the HD audio driver you gave me before (?)
No, this one is from Intel and should be specifically for your i945p chipset.
Quote:
Unindentified Multimedia Audio Device
Look in the System section of Dev. Man. Is there a UAA yet?
I'm not understanding this at all. Realtek driver's can be a pain but we have gone through most of the different fixes that enable them to install.
There must be a conflict somewhere. Do you have any software that uses audio like Skype or a gaming headset?
Reply With Quote
  #13  
Old 05-16-08, 17:11
tyrael98 tyrael98 is offline
Private E-2
 
Join Date: May 2008
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Default Re: Realtek Ac'97 Audio Driver Problem

Quote:
Look in the System section of Dev. Man. Is there a UAA yet?
Nope, definitely no sign of it. Neither in System, nor anywhere else.

Quote:
Do you have any software that uses audio like Skype or a gaming headset?
Not much to mention...
There's MSN of course, or Live Messenger as they call it nowadays.
I also got a headset, but it doesn't use any extra software, it works the same way as the loudspeakers, I just plug it in the PC.
Other than that, nothing. (Except for the media players)

Quote:
this one is from Intel and should be specifically for your i945p chipset.
Well I picked this one up along the way, just to make sure it's not because I missed out this step: http://www.majorgeeks.com/Intel_Real...ive_d5838.html but as usual still nothing
Reply With Quote
  #14  
Old 05-16-08, 22:13
musksnipe
Guest
 
Posts: n/a
Default Re: Realtek Ac'97 Audio Driver Problem

Quote:
Look in the System section of Dev. Man. Is there a UAA yet?
Nope, definitely no sign of it. Neither in System, nor anywhere else.
I think I may see part of the problem. If the UAA Bus driver isn't installed, Windows will not recognize a HD audio driver.
You weren't able to do this earlier. (without difficulty)
Quote:
  1. Go to the folder where the files have been extracted and browse to the \HDAQFE\xpsp2\us\ folder or the \MSHDQFE\Win2K_XP\us\ folder. (The name of this folder depends on your desktop board model.)
  2. Double-click the file kb888111xpsp2.exe to install the High Definition Audio Driver Package.
The MS UAA was never installed. It is a must for that to be installed first (for HD audio) and then install your driver. Try this UAA, then either my last driver (updated 4/29/08) or the one you found here at MG.
(On some PCs the UAA may be called the HD Audio Controller, but it will always reside in the System Device section of Device Manger.)

Microsoft-UAA-Bus-Driver-for-High-Definition-Audio
Reply With Quote
  #15  
Old 05-17-08, 09:47
tyrael98 tyrael98 is offline
Private E-2
 
Join Date: May 2008
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Default Re: Realtek Ac'97 Audio Driver Problem

Quote:
If the UAA Bus driver isn't installed, Windows will not recognize a HD audio driver.
Well, I tried out your link, as well as tried to make some research about this bus driver myself, but most of the files I found - including the one you sent - only downloaded a folder of an HD audio driver, the same kind we were trying a few steps before and didn't work (The one with the setup.exe), though all of them said it's the Microsoft UAA Bus driver I'm downloading.
I even found another one which looked promising, but the wizard quits after prepairing itself for the installation.
Somethings not right here, even I can smell that.
Reply With Quote
Sponsored links
  #16  
Old 05-24-08, 19:15
musksnipe
Guest
 
Posts: n/a
Default Re: Realtek Ac'97 Audio Driver Problem

I don't know what to try now. If you followed all the steps in the fixes, one of them should have worked.
This is a link to a page with some info and also a link to another version of the UAA.
http://geekswithblogs.net/lorint/arc.../11/81540.aspx
Reply With Quote
  #17  
Old 05-25-08, 14:38
tyrael98 tyrael98 is offline
Private E-2
 
Join Date: May 2008
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Default Re: Realtek Ac'97 Audio Driver Problem

Thanx for everything, but since this issue really was getting dragged for quite a while I just bought a new sound card.
Everything's working swell now. So I guess this case is now closed.
Thanx for your advices, at least now I know not to trust Realtek anymore
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Realtek AC'97 Audio for VIA (R) Audio Controller sbrister Software 1 11-07-06 12:59
Realtek AC'97 Audio Help PaiinKiilla Hardware 3 07-08-06 09:06
Realtek AC'97 Audio Problem adam98090 Software 3 05-13-06 06:40
Problem with Realtek AC'97 Audio/ ?Video controller NMH Software 5 04-10-06 13:52
update realtek ac'97 audio via (r) boliall Software 1 09-01-04 06:49


All times are GMT -5. The time now is 18:17.

MajorGeeks.Com Menu

MajorGeeks.Com \ All In One Tweaks \ Android \ Anti-Malware \ Anti-Virus \ Appearance \ Backup \ Browsers \ CD\DVD\Blu-Ray \ Covert Ops \ Drive Utilities \ Drivers \ Graphics \ Internet Tools \ Multimedia \ Networking \ Office Tools \ NEW! PC Games \ System Tools \ Macintosh \ Demonews.Com \ Top Downloads

MajorGeeks.Com \ News (Tech) \ Off Base (Other Websites News) \ Way Off Base (Offbeat Stories and Pics)

Social: Facebook \ YouTube \ Twitter \ Tumblr \ Pintrest \ RSS Feeds


Powered by vBulletin® Version 3.8.4
Copyright © 2009 vBulletin Solutions, Inc. All rights reserved.
Ad Management by RedTyger