MajorGeeks Support Forums

Go Back   MajorGeeks Support Forums > ----------= PC, Desktop and Laptop Support =---------- > Software
Register FAQ Members List Calendar Casino Mark Forums Read

Software Software such as operating systems like Windows XP, Windows Vista, Windows 7 etc., or specific programs.


Reply
 
Thread Tools Display Modes
  #1  
Old 11-23-11, 15:06
Tueur's Avatar
Tueur Tueur is offline
Sergeant Major
 
Join Date: Apr 2011
Location: Essex UK
Posts: 887
Thanks: 21
Thanked 155 Times in 148 Posts
Default Stop Ubuntu Automatically Capitalizing Filenames

Hi Guys,

I dont class myself as a Linux power user in any shape but I have come across a really irritating problem.

My main rig is dual boot with Ubuntu 10.04 and Windows 7. I have recently started a bit of web design and I use primarily use Linux for this. I am hard coding the HTML and CSS using GEdit but for some reason when I save or rename anything Ubuntu is automatically capitalizing the first letter of the file name. this is a real pain as I am using filezilla to upload my site to my webspace and HTML is case sensitive. This means that my relative urls dont work but more importantly index.html is being renamed to Index.html which is causeing a 403 Forbidden error. Is there anyway that I can turn off the "feature" as I currently have to upload the site then re-name everything on the FTP!!!

TIA
__________________
The keyboard on my laptop is terrible so I apologise for any letters missing from posts!
Reply With Quote
Sponsored links
  #2  
Old 11-23-11, 15:56
BoredOutOfMyMind's Avatar
BoredOutOfMyMind BoredOutOfMyMind is online now
Picabo, ICU
 
Join Date: Nov 2002
Location: 36.071835,-119.035191
Posts: 3,021
Thanks: 1,031
Thanked 211 Times in 192 Posts
Default Re: Stop Ubuntu Automatically Capitalizing Filenames

Quote:
Originally Posted by Tueur View Post
Hi Guys,

I dont class myself as a Linux power user in any shape but I have come across a really irritating problem.

My main rig is dual boot with Ubuntu 10.04 and Windows 7. I have recently started a bit of web design and I use primarily use Linux for this. I am hard coding the HTML and CSS using GEdit but for some reason when I save or rename anything Ubuntu is automatically capitalizing the first letter of the file name. this is a real pain as I am using filezilla to upload my site to my webspace and HTML is case sensitive. This means that my relative urls dont work but more importantly index.html is being renamed to Index.html which is causeing a 403 Forbidden error. Is there anyway that I can turn off the "feature" as I currently have to upload the site then re-name everything on the FTP!!!

TIA
To turn a gedit plugin on or off, to go Edit->Preferences, and go to the Plugins tab.

This appears to be the Change Case plugin which is disabled by default.

You would also enjoy -- View> Highlight Mode> HTML

or use of Geany
__________________
"Unless someone like you cares a whole awful lot, nothing is going to get better. It's not"
- The Lorax, Dr. Suess
Reply With Quote
  #3  
Old 11-23-11, 16:24
Tueur's Avatar
Tueur Tueur is offline
Sergeant Major
 
Join Date: Apr 2011
Location: Essex UK
Posts: 887
Thanks: 21
Thanked 155 Times in 148 Posts
Default Re: Stop Ubuntu Automatically Capitalizing Filenames

Quote:
Originally Posted by BoredOutOfMyMind View Post
To turn a gedit plugin on or off, to go Edit->Preferences, and go to the Plugins tab.

This appears to be the Change Case plugin which is disabled by default.

You would also enjoy -- View> Highlight Mode> HTML

or use of Geany
Hi BoredOutOfMyMind,

Its not in the HTML code but the actual files themselves. ie the Ubuntu equivelent of Windows Explorer. The actual filename index.dat is renamed automatically to Index.dat. If i try and rename the file to remove the capital then Ubuntu just changes it back!
__________________
The keyboard on my laptop is terrible so I apologise for any letters missing from posts!
Reply With Quote
  #4  
Old 11-24-11, 00:34
BoredOutOfMyMind's Avatar
BoredOutOfMyMind BoredOutOfMyMind is online now
Picabo, ICU
 
Join Date: Nov 2002
Location: 36.071835,-119.035191
Posts: 3,021
Thanks: 1,031
Thanked 211 Times in 192 Posts
Default Re: Stop Ubuntu Automatically Capitalizing Filenames

Quote:
Originally Posted by Tueur View Post
Hi BoredOutOfMyMind,

Its not in the HTML code but the actual files themselves. ie the Ubuntu equivelent of Windows Explorer. The actual filename index.dat is renamed automatically to Index.dat. If i try and rename the file to remove the capital then Ubuntu just changes it back!
Hmmm, your original question said you were hard coding in gedit (like notepad) and now you are saying Caps occurs in save to Nautlius?

I made a small "test" file, saved in ~/Desktop and then a new file and save would be "Unsaved Document 1". The file name is highlighted and typing and hitting enter renames it what you want- as per test. Change filename in Nautlius is still with F2. I am at a loss what you are seeing.

__________________
"Unless someone like you cares a whole awful lot, nothing is going to get better. It's not"
- The Lorax, Dr. Suess
Reply With Quote
  #5  
Old 11-24-11, 06:50
Tueur's Avatar
Tueur Tueur is offline
Sergeant Major
 
Join Date: Apr 2011
Location: Essex UK
Posts: 887
Thanks: 21
Thanked 155 Times in 148 Posts
Default Re: Stop Ubuntu Automatically Capitalizing Filenames

Sorry, I was trying to give the background to the problem (ie I code a file path in gedit as "pictures/image1.jpg" and if works fine but when I upload to FTP the site fails to display correctly because Ubuntu appears to be re-naming the link to "Pictures/Image1.jpg")

I may have just been having a moment because I was very tired last night and I cant find anything on Google to support my findings.

I will have another look tonight and see.

Thanks
__________________
The keyboard on my laptop is terrible so I apologise for any letters missing from posts!
Reply With Quote
Sponsored links
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Editing filenames box closes too quickly johndh Software 3 07-29-09 16:09
XP Thumbnails filenames missing Bill_Marsden Software 3 07-18-08 11:14
Tabulating gif files with sequential filenames. MasterAir Software 0 06-01-06 08:47
How do I stop xp from "filling in the blanks" automatically?? ndnprincesss Software 3 12-30-05 20:14
Stop flashplayer from loading automatically augiedoggie Software 4 03-14-03 20:43


All times are GMT -5. The time now is 01:12.

MajorGeeks.Com Menu

MajorGeeks.Com \ All In One Tweaks \ Android \ Anti-Malware \ Anti-Virus \ Appearance \ Backup \ Browsers \ CD\DVD\Blu-Ray \ Covert Ops \ Drive Utilities \ Drivers \ Graphics \ Internet Tools \ Multimedia \ Networking \ Office Tools \ NEW! PC Games \ System Tools \ Macintosh \ Demonews.Com \ Top Downloads

MajorGeeks.Com \ News (Tech) \ Off Base (Other Websites News) \ Way Off Base (Offbeat Stories and Pics)

Social: Facebook \ YouTube \ Twitter \ Tumblr \ Pintrest \ RSS Feeds


All content Copyright MajorGeeks.com source code Powered by vBulletin® Version 3.8.4
Copyright © 2009 vBulletin Solutions, Inc. All rights reserved.
Ad Management by RedTyger