1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Game wont recognize the disk is IN THE DRIVE!

Discussion in 'Software' started by lordofthepings, Aug 16, 2006.

  1. lordofthepings

    lordofthepings Private E-2

    This happened with DVD based game before.

    I just installed TitanQuest DVD version and everything went great. I click to play the game and it says to insert the game disk!! now obviously i have the disk in the drive.
    I have one cdrom and one dvdrom/burner. I tried disabling the cd and my floppy disk. I tried to reassign the dvd to the letter D:
    I cant get it to recognize the disk in in the freaking drive to play the game! althought when i run cd based games everything is fine. THANKS IN ADVANCE
  2. jedandjess

    jedandjess Private First Class

    Uninstall and then reinstall the game, try a different drive or install type (full/medium/small). If all else fails, take the game back and get a refund or exchange.
  3. lordofthepings

    lordofthepings Private E-2

    I tried putting a CD based game in the dvd rom and it loaded fine. So my problem is with not recognizing DVD based games only when the game loads. The dvd rom will install fine and all that stuff only games arent finding the dvds during disk check.

Share This Page

MajorGeeks.Com Menu

Downloads All In One Tweaks \ Android \ Anti-Malware \ Anti-Virus \ Appearance \ Backup \ Browsers \ CD\DVD\Blu-Ray \ Covert Ops \ Drive Utilities \ Drivers \ Graphics \ Internet Tools \ Multimedia \ Networking \ Office Tools \ PC Games \ System Tools \ Mac/Apple/Ipad Downloads

Other News: Top Downloads \ News (Tech) \ Off Base (Other Websites News) \ Way Off Base (Offbeat Stories and Pics)

Social: Facebook \ YouTube \ Twitter \ Tumblr \ Pintrest \ RSS Feeds