1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

mrvgina.dll

Discussion in 'Software' started by vrod, Mar 30, 2006.

Thread Status:
Not open for further replies.
  1. vrod

    vrod Private E-2

    I just updated my driver from Netgear for my wireless modem.
    Went to shut the laptop off (Windows XP Professional) different screen, drop down box instead of the STANBY, SHUT DOWN, RESTART.
    No matter which one I select it shut down.

    When I start up it ask for a password. I click OK and it loads windows. (no password, thank God)

    I went to the control panel to User Accounts and try to change and it won't let me. It says to delete mrvGINA.dll from the windows system32 file.

    Any help would appreciated.

    Larry
     
  2. DavidGP

    DavidGP MajorGeeks Forum Administrator - Grand Pooh-Bah Staff Member

    Looks like from what I have been reading up on this update from netgear is that this driver disables Fast User Switching, which in turn gives you this error at boot.

    Users on the Netgear site that have this problem are reverting back to the original driver issue from the CD, which doesnt have this problem until Netgear release an updated fixed driver.
     
  3. vrod

    vrod Private E-2

    Thanks Halo
     
  4. vrod

    vrod Private E-2

    Remover the downloaded driver and the computer went back to normal.

    The reason I download the driver in the first place the wireless quit working.

    Tried to reload the original driver from the disk and its not working. Tried to uninstall the original driver and it locks up.

    Have to use the downloaded version to get wireless.

    Hope Netgear gets this problem resolved.
     
  5. jerrymac2

    jerrymac2 Private E-2

    I had the same problem ... My netgear wg511 v.2 was acting up on XP.
    updating the driver and connection utility seemed to be working great...then I realized it had disabled the Windows XP welcome screen and fast user switching. This was because of the mrvgina.dll.
    I have found an answer and it worked on my pc...however it involves editing the registry so it would probably be good to have a back out plan (just in case....i.e. do so at your own risk)

    after installing the new netgear driver/utility go to Start -->Run and type regedit.

    when the registry editor opens browse to HKEY_LOCAL_MACHINE/Software/Microsoft/Windows NT/Current Version/WINLOGON
    Delete the key named GINAdll

    Thats it....afterward you may want to go back into the control panel and check the 'change the way users log on or off' and make sure the welcome screen and fast user switching are both checked.
     
  6. vrod

    vrod Private E-2

    jerrymac2

    Before I tried your suggestion I tried to uninstall and reinstall the driver.
    Now it wont do either. Error massage on both.

    Tried your suggestion and GINAdll was not there.

    I going to connect Netgear tech support. If they don't help I'll buy another brand.

    Thanks
     
  7. jcasey2005

    jcasey2005 Private E-2

    I was having trouble getting RDC to work correctly and getting an error about MrvGINA being incompatible. I took the suggestion above, deleting it from the registry, and it fixed it immediately. Thanks for the help.
     
  8. tc7

    tc7 Private E-2

    I had the same issue re an upgraded version of netgear drivers for WG311v3/wireless util for XP. I followed the directions above - removed the ginadll reference - and instant fix for user switching.

    thanks heaps.
     
  9. wolverines

    wolverines Private E-2

    I'm desperate for some help on this issue and I was hoping someone here could help me out. I've got the WG511v2 card. I installed it with the new drivers downloaded from Netgear. No problems. Until I tried to get back in. It tells me it can't find the MrvGINA.dll, contact my administrator. The only choice is to restart. I can't even get into Windows XP to delete the driver! I've tried everything I can think of - restore last good configuration, boot into Safe Mode. I even tried booting to the CD recovery disc provided by Compaq. Nothing. I don't have a floppy drive. Netgear basically told me too bad, it's a windows issue and they've never heard of this problem. I know for a fact it was the damn driver.

    Anyway, do you guys have any thoughts on how to get into windows XP to delete this driver and get my computer back?

    Thanks.
     
  10. DavidGP

    DavidGP MajorGeeks Forum Administrator - Grand Pooh-Bah Staff Member

    Hi Wolverines did you try the information posted in post #5 above?
     
  11. wolverines

    wolverines Private E-2

    Halo, I can't even get to that step. I cannot load Windows XP because of this damn driver issue. The computer boots up, starts loading XP, then gives me that error - saying it cannot load XP because its missing that dll, contact your administrator. Only choice from there is to restart. I cannot get into Safe Mode, can't use the recover utility. Right now I'm at a loss. I need to find a way around this to access XP so I can edit the registry like suggested in post 5, or to delete the driver and reinstall the older one. Any ideas? Thanks.
     
  12. stancilmor

    stancilmor Private E-2

    hey wolverines,


    That's really odd that safe mode won't boot. Humor me and give it another try by pressing F8 during bootup. If that won't work, then you can try what I did.

    I bought a second harddrive, took out the first harddrive, installed the second harddrive, spent my weekend installing windows.

    Then I put the old harddrive back in, booted to the second harddrive and accessed the first one. Alternately you could just try putting your harddrive in a second computer.

    While a pain, I keep the two harddrive, one for using and the second for trying out new stuff on.

    goodluck
     
  13. raylytheous

    raylytheous Private E-2

    i now this is slightly old, but i have found a round about way to still use the updated drivers but still have quick logoff.

    if u install the drivers as usuall, then copy the drivers to a completely diff folder. Then uninstall the update and reboot,
    after u logon xp will look for and install the drivers needed for the network card (the drivers u copied) without editing the quicklog off.
    hopefully that helps <3
     
  14. sradwxi

    sradwxi Private First Class

    hi guys, ive got exactly the same problem, mrvgina.dll cant be found so windows wont load up, only option is to restart, cant get onto windows to remove driver or edit the registry, the only difference being that i didnt delete the file, i just moved it to my desktop incase i needed it again,
    as it came from system 32 i thought it might be wise not to delete it
    so if anybody can tell me how i can get to this file, to put it back where it should be then i will be able to send a copy of the file via email so anybody else who has the problem can use it to fix theirs
    i think its a bit wrong for netgear to release a driver update, which actually takes u back in time and causes this much grief
    luckily i have another few computers and can still access the net
    what about the people who only have one pc, they will be in the brown stuff now
    netgear have a lot to answer for with this one?????
    anyway, is there a way to access the file thru dos or by using a startup disk or even the windows cd, any help would be much appreciated
    thanx carl
     
  15. sradwxi

    sradwxi Private First Class

    :) :) :) :) :) :) :)
    lol, right i attempted to humour both yourself and me by pressing f8 to start in safe mode, it worked
    last time i was messing round with it i was pressing esc, f1, f2 and f10 to try to get to safe mode
    anyway what ive done is started in safe mode and moved the file back into system 32, all sorted now, although i cant use the welcome screen (disabled)
    ive made a copy of the misfit file and zipped it up incase anybody wants it
    just send me a message if u want it
    cya soon
    carl
     
  16. Memphis

    Memphis Private E-2

    Thanks Man Took to seconds and worked like a charm :}
     
  17. omnimark

    omnimark Private E-2

    Instant fix.!! Thanks!!! Don't know how you know what you know but it's great that you are willing to share your knowledge. Take me to your leader..
     
  18. skodaseven

    skodaseven Private E-2

    Well done jerrymac2!! Tried your fix and it worked perfectly first time! Better than waiting for Netgear help to respond! If you try this yourself make sure you follow the instructions exactly!
     
  19. shyngentle

    shyngentle Private E-2

    Carl, I would love that file if you could send it to me. shy_pincess [at] msn.com thanks :eek:
     
    Last edited by a moderator: Nov 14, 2006
  20. windshift

    windshift Private E-2

    Wow! What a pain in the butt mrvgina.dll was/is. I would like to thank the good people on this site for the advice as to how to deal with the SOB. But for those like me who were stumped with this problem, here is another workaround. My problem with the "administrator" loop was that when I booted to "safe mode" all I got on my screen was a blank black screen that said "safe mode" in each corner; probably for the same reason the mrvgina.dll locked out my desktop page. Pretty hard to go to the start-run function when it ain't there. If this is your headache here is how I overcame it: Reboot to safe mode with the command prompt. That will give you the old prompt that was associated with DOS. And surprise, the DOS commands, or at least some of them still work. At the prompt simply type in "regedit" and it will bring up the registry editor, then you can go through the steps outlined elsewhere which explains how to edit the problem out.
     
  21. main identity

    main identity Private E-2

    my thanx to jerrymac2 for his walkthru on this problem i just fixed my daughters machine.

    thanx again from main identity from down under
     
  22. Will-e

    Will-e Private E-2

    jerrymac2, your solution worked for me...Thanks for the help. Netgear never responded to my e-mailed requests for help. This is the 2nd piece of equipment I have purchased from Netgear and it will be my last, I had problems with my wireless router also.
     
  23. Dr_Xem@cs

    Dr_Xem@cs Private E-2

    :cool Hi there!
    I guess I'm far too late to help in this matter, I just want to share my own experience!

    I did exactly the same here, but one difference, I baptized MrvGINA.dll to MrvGINA.dxx. THAT - dear folks - was my savior!!!!!

    After a sweaty nights work I finally found (yes I'm a great Linux fan) a CD image containing "Midnight Commander", which I downloaded and burned. Then I booted up and started MC, in which I could administrate NTFS to some extent, i.e. I could not create new files, but I could erase, and change existent files, so I looked MrvGINA.dxx up again, rebaptized it to dll, and with my heart beating like crazy I rebooted WinXP, and it was back!

    Now consider my having deleted that file! I would have had to backup my entire XP partition, recreate it using the rescue CD-s and start putting all stuff in order again! Experienced geeks know what that implies!!!! So I was glad the freeware developers provided this great program!

    All the best, and keep hacking!!! Doc

     
  24. spcnet

    spcnet Private E-2

    How did you fix this problem. I have the same thing going on and I can not get to windows xp????
     
    Last edited by a moderator: Feb 9, 2007
  25. Dr_Xem@cs

    Dr_Xem@cs Private E-2

    :cool Hi!

    Given that I only named MrvGINA.dll to MrvGINA.dxx (or whatever), not
    deleted it, I did as follows:

    1) I downloaded and burned the Linux Start CD ISO image containing
    Midnight Commander at

    http://www.ntfs-linux.com/demo.htm
    title: Paragon NTFS for Linux Mount NTFS under Linux - Read-Write

    2) Booted the CD on the computer with faulty NTFS-partition, enterred MC
    and named MrvGINA.dxx back to MrvGINA.dll

    3) When NTFS restarted I went into the registry with regedit and deleted
    the key

    HKEY_LOCAL_MACHINE/Software/Microsoft/Windows NT/Current
    Version/WINLOGON/GINAdll

    which Netgear has added to point at MrvGINA.dll.

    ===============

    Given the MrvGINA.dll is deleted and MC supports copying from another
    media (which I actually don't know) I would choose to try to overwrite a
    dispensable file with a copy of MrvGINA.dll instead.

    ===============

    Good luck with Your efforts! I hope You manage all the way, otherwise
    please do not hold me responsible for any loss. This is all on ones own
    risk, which I appreciated fully. MC could be a good tool to save all
    data before a total system reinstall.

    My rescue in this situation was also that I run a triple-boot system, so
    with WinXP down I could get around using Linux, in which I created the
    boot CD.

    Greetings, Doc.
     
    Last edited by a moderator: Feb 9, 2007
  26. turtlemoon

    turtlemoon Private E-2

    Greetings,

    Several weks ago I purchased a netGear wireless card and after installing from the cd in the box was then unable to switch between user profiles, make new user profiles, etc. Aftrer roaming around the web I found the following link and script which has fixed the problem. I am now able to switch between user profiles, make new profiles, etc., and the wireless card works.



    Put the default msgina.dll back by running this util.
    > http://www.dougknox.com/xp/scripts_d...x_xp_logon.htm
     
  27. jsm138

    jsm138 Private E-2

    I came SO close to just deleting this file, because I thought for sure it was something a buddy using my machine picked up visiting a porn site given its suspicious name "mrvGINA.dll" as in "Mr. vaGiNA". Thanks for your removal tips!

    too funny.
     
  28. turtlemoon

    turtlemoon Private E-2

    You bet! Share the wealth...local knowledge...and all that. I'm 65 years of age and find it a real breath of fresh air that you youngsters share knowledge so freely. As my granny used to tell me...more power to your elbow.

    :cool
     
  29. Alonzo

    Alonzo Private E-2

    Major thank you to jerrymac2 and the Forum.
    Deleted the registry key and all is well and
    back to normal. Just had to join after this
    experience!
     
  30. masterofnada

    masterofnada Private E-2

    I am a happy camper. :hyper

    Thank you Jerrymac2. I followed your instructions listed below. Quick and easy fix.

    when the registry editor opens browse to HKEY_LOCAL_MACHINE/Software/Microsoft/Windows NT/Current Version/WINLOGON
    Delete the key named GINAdll


    Found this forum using Goggle search string mrvgena.dll. This site was listed at top of the page.

    Never have I fixed a problem with less trouble. PLUS, I'm GLAD I DIDN'T DELETE THE DDL. That would have been my first fix to the problem. WHEW :cry

    I'm not sure what caused the new login screen. I did install a Linksys wireless router a few days ago and a trendnet laptop wireless card. Plus some program deletes plus ??? (living dangerously) Bad memory, getting old I guess.
     
  31. masterofnada

    masterofnada Private E-2

    The edit key was disabled for my original message, thus the quote.

    The problem was with the TRENDnet wireless card. Re-installed the driver and same problem BUT... I now know how to fix it. Good card but I'll never understand why the mfg. release with a major BUG.

    :crap
     
  32. Chatstasy

    Chatstasy Private E-2

    This fix worked like a charm. THANK YOU THANK YOU THANK YOU
     
  33. Doria88

    Doria88 Private E-2

    I am at my wits end with this nonsense. I have reverted back to the earlier driver, un installed,reinstalled, deleted mini-dump etc. Mean while Netgear pretends to know nothing about the problem or the MrvGINA.dll file even existing! last they wanted me to install the latest driver which is the original driver that caused the problem!
    Anyway my computer now shuts down & restarts every time I leave a site! HELP!
     
  34. Chatstasy

    Chatstasy Private E-2

    I didn't do anything with my drivers that I am aware. All I did was go to start-run and typed in regedit. Then I followed the path that is listed in this thread. I found the MrvGina key and deleted it. It worked perfectly.

    when the registry editor opens browse to HKEY_LOCAL_MACHINE/Software/Microsoft/Windows NT/Current Version/WINLOGON
    Delete the key named GINAdll

    Good luck to you. I hope you get it fixed. This forum rocks!
     
  35. DavidGP

    DavidGP MajorGeeks Forum Administrator - Grand Pooh-Bah Staff Member

  36. zDa

    zDa Private E-2

    I have read most of the previous posts on this thread because I encountered this same problem after installing a new Netgear wireless card. As noted in one post, luckily I renamed instead of deleting the MrvGINA.dll file. Also, I was able to boot off a Dell-supplied installation CD. When I chose the Repair Console, I got the DOS prompt. I was able to remember from who knows when how to use DOS to find and name the file back to its original form. This allowed me to boot again, albeit with the unwanted log-in window. After reading this thread, I went to the registry to make the change that worked for others, but did not find it in WINLOGIN. What I did find may answer other poster's frustrations in getting help from Netgear. The registry has an entry under Software for Marvel (my grandsons use this machine), which was what showed when I did a get info on the dll before I renamed it in the first place. The registry has these entries under Marvel:

    (default) REG_SZ (value not set)
    GUIPATH REG_SZ C:\\Program Files\NETGEAR\WG311v3\WinDomainlogon.exe

    I'm not registry knowledgeable. Since I don't have the same registry entry as others have reported, and am not willing to risk editing the registry on my own, can someone here help with a safe registry edit? It would be great to get the regular log-on screen restored. TIA for your help.
     
  37. begrif

    begrif Private E-2

    i have the same trouble
    but why would netgear do that????

    :cry
     
  38. dinbob

    dinbob Private E-2

    thank you! thank you! thank you! to all.......we just set up our wireless over the weekend, couldn't work out why the logon had changed (after we'd loaded the netgear card).......so thank you very much to all, very much appreciated.:wave

    btw....we had to ring netgear tech support as we were having trouble with the IP address on the router set up.....guess what?????......someone else had it registered to them, we'd bought it just 4 hours before......hmmmm....maybe netgear shouldn't have the serial numbers printed ON THE OUTSIDE OF THE BOX for people to copy down while window shopping.!

    Have a great day all and thank you all so very much again
     
  39. pstretch

    pstretch Private E-2

    THANKS jerrymac2: Now, will I screw things up if I download Netgear's latest driver for the card? I'm still working off the original one from the CD.
     
  40. sradwxi

    sradwxi Private First Class

    if your old driver is working with no disconnects then keep using it
    carl
     
  41. matsing

    matsing Private E-2

    Tanks jerrymac2, your solution worked for me also!! You are clever!!
     
Thread Status:
Not open for further replies.

Share This Page


MajorGeeks.Com Menu

Downloads All In One Tweaks \ Android \ Anti-Malware \ Anti-Virus \ Appearance \ Backup \ Browsers \ CD\DVD\Blu-Ray \ Covert Ops \ Drive Utilities \ Drivers \ Graphics \ Internet Tools \ Multimedia \ Networking \ Office Tools \ PC Games \ System Tools \ Mac/Apple/Ipad Downloads

Other News: Top Downloads \ News (Tech) \ Off Base (Other Websites News) \ Way Off Base (Offbeat Stories and Pics)

Social: Facebook \ YouTube \ Twitter \ Tumblr \ Pintrest \ RSS Feeds


<