MajorGeeks Support Forums

Go Back   MajorGeeks Support Forums > ----------= PC, Desktop and Laptop Support =---------- > Software
Register FAQ Members List Calendar Casino Mark Forums Read

Software Software such as operating systems like Windows XP, Windows Vista, Windows 7 etc., or specific programs.


Reply
 
Thread Tools Display Modes
  #1  
Old 04-26-12, 15:05
GeoffB GeoffB is offline
Private E-2
 
Join Date: Apr 2012
Posts: 20
Thanks: 2
Thanked 0 Times in 0 Posts
Angry No Sound on Toshiba Laptop

Hi everyone, A newby here.

I lost the sound on my Toshiba L350 laptop just after I installed an audio analyser program which I beleive tried to instal a soundblaster drive, but I'm not sure!

However, I've tried deleting, updating and unstalling the Realtek HD audio driver with no success. I've also downloaded the lated drive from the Realtek site (ver.2.68, dated 12/4/2012).
Each time open the driver and run the test, I can see the bar graph change with the test signal but still no sound.

I also ran Microsoft Fixit which says there are no issues with the sound and even re-installed windows vista using the 'clean windows option - still n change.
Any help would be most welcome

Geoff.
Reply With Quote
Sponsored links
  #2  
Old 04-26-12, 21:12
tgell tgell is offline
Major Geek Extraordinaire
 
Join Date: Oct 2010
Posts: 3,598
Thanks: 208
Thanked 938 Times in 883 Posts
Default Re: No Sound on Toshiba Laptop

From what I have read, the Toshiba L350 has a mute button. Make sure that it has not been enabled by accident. There may also be some kind of mechanical switch to increase the sound. Can you hear sounds through earphones?
Reply With Quote
  #3  
Old 04-27-12, 02:49
GeoffB GeoffB is offline
Private E-2
 
Join Date: Apr 2012
Posts: 20
Thanks: 2
Thanked 0 Times in 0 Posts
Default Re: No Sound on Toshiba Laptop

Hi Tgell,
Many thanks for the quick responce. You are correct there is a speaker on/off switch just above the keyboard and, a "function esc key" that puts a speaker on/off sigh next on the bottom right of the screen. However activating either of these still fails to give give me sound. I can also confirm no sound when headphones pluged in.

The fault does indeed look a though it could have been the above problem as everything looks fine. All the tests I've done thus far suggest the sound card is working .

Geoff.
Reply With Quote
  #4  
Old 04-27-12, 06:18
tgell tgell is offline
Major Geek Extraordinaire
 
Join Date: Oct 2010
Posts: 3,598
Thanks: 208
Thanked 938 Times in 883 Posts
Default Re: No Sound on Toshiba Laptop

Are there any errors shown when you run dxdiag? Are there any yellow exclamation marks in Device Manager? Is more than one sound device shown in Device Manager? Can you provide the last four digits after L350 on your computer? Is it a Satellite or Equim L350?

The following isn't exactly related to your problem, but make sure that digital is not selected.

http://www.spyontech.com/how-to/here...ed-problem.htm

Last edited by tgell; 04-27-12 at 06:26..
Reply With Quote
  #5  
Old 04-27-12, 10:26
GeoffB GeoffB is offline
Private E-2
 
Join Date: Apr 2012
Posts: 20
Thanks: 2
Thanked 0 Times in 0 Posts
Default Re: No Sound on Toshiba Laptop

Hi,

I've run dxdiag as suggested and no problems are reported. Also no yellow triangles on any hardware.

The computer is shown as a Satilite L350-159. Model No.PSLD0E-03Q0 1 MEN


Your last comment regarding the digital output is interesting as I've been doing some research in tinternet which has led me to the following:
When I open the playback device window and double click on the speaker Icon, to bring up speaker properties, it shows both the APAPI internal Jack and front panel 3.5mm jack under jack information. However, the LR (left/Right I assume) is next to the APAPI black dot, which suggest to me that the sound is being routed to the digital output and not the front panel jack and Speakers.

However, I cant find any way of changing which output is selected. I tried following the video on the website you kindly attached but my version of Vista does not show a Realtek menu when I go through Hardware and Sound from the control panel .

Your further comments would be appreciated.

Geoff.
Reply With Quote
Sponsored links
  #6  
Old 04-27-12, 11:46
tgell tgell is offline
Major Geek Extraordinaire
 
Join Date: Oct 2010
Posts: 3,598
Thanks: 208
Thanked 938 Times in 883 Posts
Default Re: No Sound on Toshiba Laptop

If you right click on the speaker icon and select playback devices, is Realtek HD shown there? Realtek HD manager should be in the system tray. Is there a Realtek HD manager icon when you set the Vista Control Panel to classic view in the left pane?
Reply With Quote
  #7  
Old 04-28-12, 12:14
GeoffB GeoffB is offline
Private E-2
 
Join Date: Apr 2012
Posts: 20
Thanks: 2
Thanked 0 Times in 0 Posts
Default Re: No Sound on Toshiba Laptop

Hi Tgell,

Many thanks for your efforts thus far, I know it can't be easy without the computer in front of you.

When I right click the speaker Icon and select playback device, the playback sub-window opens showing a speaker Icon with a green tick next to it and says " speakers Realtek high definition audio working". There is also a bargraph to the right. If I left click on the speaker Icon and run test, you can see the bar graph rising indicating sound. But nothing from the speakers.

Since I've installed an updated driver, I can now see the Realtek HD manager. However, trying all the facilities, there's still no audio.
Also if I play a track from windows media player and open the volume mixer, you can again see the display changing with the sound.

To date I've tried the following drivers, all with the same results:
version Date
6.0.6000 21/6/2006
6.0.1.5559 30/1/2008
6.0.1.6602 27/3/6602
2.68 12/4/2012

Geoff.
Reply With Quote
  #8  
Old 04-28-12, 12:47
tgell tgell is offline
Major Geek Extraordinaire
 
Join Date: Oct 2010
Posts: 3,598
Thanks: 208
Thanked 938 Times in 883 Posts
Default Re: No Sound on Toshiba Laptop

If you right click your speaker icon and select Open Volume Mixer, make sure all of the setting are at max. and the speaker icons do not have a red circle next to them.

I really do not understand what is going on other than it may be a hardware issue, especially since you reinstalled Vista.

Is this Vista 32 bit. If so, download the Value added package. This may have some additional setting for sound. You may already have it installed if you reinstalled from the recovery partition of the hard drive. It provides support for the different function buttons. This is for 32bit only.

http://uk.computers.toshiba-europe.c...verLanguage=42
Reply With Quote
  #9  
Old 04-28-12, 17:31
GeoffB GeoffB is offline
Private E-2
 
Join Date: Apr 2012
Posts: 20
Thanks: 2
Thanked 0 Times in 0 Posts
Default Re: No Sound on Toshiba Laptop

Hi Tgell,

When I open volume mixer I can see the speaker Icon and slider. the slider moves with the manual volume control. There are no red circles to show mute or audio switched off. Indeed when I hover over the speaker Icon( next to clock bottom right) the baloon reads "Volume 88 and Realtek High definition audio".
I re-installed the Toshiba value added package as suggested and it seems pretty basic. When it tests the sound device all it askes if I can hear sound from either speaker. When I click no it just shows FAIL against that test but does not provide and further information as to the possible cause.
Even Microsoft's Fixit tells me that everthing is working OK

It look just like someone has unplugged the speaker ! If I turn the speakers off via a key-press I can be clearly seen a red circle next to the speaker icon and I can turn this on and off at will with any of these controls.



Geoff.
Reply With Quote
  #10  
Old 04-28-12, 17:58
tgell tgell is offline
Major Geek Extraordinaire
 
Join Date: Oct 2010
Posts: 3,598
Thanks: 208
Thanked 938 Times in 883 Posts
Default Re: No Sound on Toshiba Laptop

Right click the speaker select playback devices. Right click in the blank area of the window and select show disabled devices. Does anything pop up?

Now that you have the value added packaged installed. See if the pressing the mute button on and off has any effect.

I am truly starting to run out of ideas on this.
Reply With Quote
Sponsored links
  #11  
Old 04-30-12, 08:15
GeoffB GeoffB is offline
Private E-2
 
Join Date: Apr 2012
Posts: 20
Thanks: 2
Thanked 0 Times in 0 Posts
Default Re: No Sound on Toshiba Laptop

Hi Tgell,

There are no other drivers shown when I tick "enable disabled drivers"

Also now I've downloded Toshiba's ADP the following happens:

1 when I press the FN (function) all the "f" keys ICONS are visable across the top of the screen.
2 Now if I hold down the FN key and press the ESC key I can toggle a spreaker mute ICON on the top of the screen on/off (ICON changes to shown speaker mute). However the speaker ICON (bottom right) no longer shows on/off. The only way I can get this to toggle on/off is to disable the driver whilst in driver properties.
3 I've also noticed that the speaker on/off button just above the keyboard seems to no longer have any effect.

I don't know what this tells you but the whole thing is driving me mad!

I'm just greatfull for your help.

Geoff.
Reply With Quote
  #12  
Old 04-30-12, 08:58
tgell tgell is offline
Major Geek Extraordinaire
 
Join Date: Oct 2010
Posts: 3,598
Thanks: 208
Thanked 938 Times in 883 Posts
Default Re: No Sound on Toshiba Laptop

I am really at a loss as to why this is happening. If you have all of your data backed up, you can try to do another factory reset using the recovery partition on the hard drive. This should take it back to the state it came from the factory. Any programs or data added will be lost.

Quote:
1) Press and hold the 0 (zero) key and at the same time, tap the power button once to switch on your notebook.

2) When the machine Starts beeping; release the 0 key.

3) When prompted by the warning screen; select Yes to continue with the system recovery.

4) Select Recovery of Factory Default Software; click Next.

5) Select Recover to out-of-box state click Next again.

6) Click Next to Start recovery.
Another option to see if this is indeed a hardware or software error is to download Puppy Linux. Burn the iso with Imgburn. Boot the CD and when you get to the Puppy desktop, play a song you have on your computer. When you get to the desktop, a hard drive will show at the bottom left. Click it and you will open the file manager. Browse to the location on your computer with a MP3 and click. Edit: you can also click the play icon on the desktop and browse you an MP3.

Edit: Here is a link showing the file manager in Puppy. Scroll down to "Mounting drives and partitions in Puppy"

http://help.artaro.eu/index.php/data...hard-disk.html

How to write an image file to a disc using ImgBurn

Last edited by tgell; 04-30-12 at 09:04..
Reply With Quote
  #13  
Old 05-01-12, 10:24
GeoffB GeoffB is offline
Private E-2
 
Join Date: Apr 2012
Posts: 20
Thanks: 2
Thanked 0 Times in 0 Posts
Exclamation Re: No Sound on Toshiba Laptop

Hi Tgell,

I ran Puppy Linux and tried to play a MP3 file but still no sound. I think you are therefore going to tell that I have a sound heardware fault !!! Is this correct?

I also tried the recovery you suggested but because I've no sound I can't hear "the beep" so I don't know how long to hold down the zero key. I tried holding the zero down for approx. 60 sec, the after release windows started to load. Should I be able to see any other visual indication to shown when I need to release the key? Unless your going to tell me not to bother because of a hardware issue!

As an aside, the Puppy Linux tooks like a very good little program.Geoff
Reply With Quote
  #14  
Old 05-01-12, 10:46
tgell tgell is offline
Major Geek Extraordinaire
 
Join Date: Oct 2010
Posts: 3,598
Thanks: 208
Thanked 938 Times in 883 Posts
Default Re: No Sound on Toshiba Laptop

If Puppy could not play the sound, then I would say it is a hardware fault.

60 seconds is too long. You may not have the recovery partition on the computer. Go to Disk management and look for a recovery partition. It should be around 10GB. Try tapping the zero key instead of holding it down as the laptop powers on.

Here is the procedure as outlined by Toshiba.

https://www.csd.toshiba.com/cgi-bin/...737864&pf=true

And another:

http://khy-tech.blogspot.com/2010/02...book-with.html

Yes, Puppy is very good, especially when you have to recover files if Windows does not boot.
Reply With Quote
  #15  
Old 05-01-12, 10:57
tgell tgell is offline
Major Geek Extraordinaire
 
Join Date: Oct 2010
Posts: 3,598
Thanks: 208
Thanked 938 Times in 883 Posts
Default Re: No Sound on Toshiba Laptop

I am pretty sure this is not the problem because you see the bar graph when playing audio, but make sure onboard audio is enabled in BIOS.
Reply With Quote
Sponsored links
  #16  
Old 05-01-12, 11:06
GeoffB GeoffB is offline
Private E-2
 
Join Date: Apr 2012
Posts: 20
Thanks: 2
Thanked 0 Times in 0 Posts
Default Re: No Sound on Toshiba Laptop

Hi Tgell,

That sounds like some good news!

I've tried looking for something relating sound in my bios setting but don't realy know where to look. Some advice would be helpfull.
I've also noticed that since re-booting, my Realtek driver has reverted back to the old driver dates 21/6/2006 ver. 6.0.6000. If I re-run the latest driver installation program again I can reload this latest 2012. Do you think I have a driver conflicked, and how can I delete unwanted drivers. Because since I started this ( which seems like years! ), I must have tried several driver versions?

Geoff.
Reply With Quote
  #17  
Old 05-01-12, 11:54
GeoffB GeoffB is offline
Private E-2
 
Join Date: Apr 2012
Posts: 20
Thanks: 2
Thanked 0 Times in 0 Posts
Default Re: No Sound on Toshiba Laptop

HI Tgell,

Further to the below thread. Whilst looking a bios issues I ran a "memory test" and whilst the test was running there was a status message saying the computer has a hardware fault. Also after the test and an auto re-boot the computer said there was also a memory fault. However, when I run dxdiag it shows 2038meg of RAM or is it talking about hard drive memory?

Geoff
Reply With Quote
  #18  
Old 05-01-12, 11:59
tgell tgell is offline
Major Geek Extraordinaire
 
Join Date: Oct 2010
Posts: 3,598
Thanks: 208
Thanked 938 Times in 883 Posts
Default Re: No Sound on Toshiba Laptop

I am not sure where the setting in BIOS would be. It may not have that option available. Just go through all of the options and see if something like audio or sound is available.

Delete your sound drivers in ADD/Remove Programs if shown. Then download DriverSweeper. You need .Net 3.0. Run it in safe mode in an admin account and select the Realtek audio drivers if any show up. Then reinstall the v2.68 drivers.

http://majorgeeks.com/Driver_Sweeper_d6171.html

http://phyxion.net/item/driver-sweeper.html

Edit: Yes, that would be your RAM memory it is talking about. You could also test with Memtest+ and let it run 7 complete passes. But, not sure why that would cause a sound issue. Burning the iso will create a boot cd. Let it

http://majorgeeks.com/Memtest86_d4226.html

http://www.sevenforums.com/tutorials...memtest86.html

Last edited by tgell; 05-01-12 at 12:07..
Reply With Quote
  #19  
Old 05-04-12, 04:36
GeoffB GeoffB is offline
Private E-2
 
Join Date: Apr 2012
Posts: 20
Thanks: 2
Thanked 0 Times in 0 Posts
Default Re: No Sound on Toshiba Laptop

Hi Tgell,

Not been on the computer for a few day as I got fet up with the whole thing!

Anyway, had another look in the BIOS settings and these is nothing relating to sound at all.

Also ran driver sweep in safe made and it came up with the following:
ASUS sound
Creative Sound, and
Realtek sound

I ticked all three, cleaned, re-booted and ran the 2.68 Realtek software, confirmed Windows was showing it as the sound driver but still no sound.

However, after switching off and on again onvernight I was amaised to see that Windows had re-loaded the old Microsoft 2006 sound driver I thought driver sweep had deleted.

I also asked driver manager to show old drivers but it didn't show any other drivers apart from the old Microsoft 2006 driver.

Repeating a driver sweep again showed the above 3 drivers I thought had been deleted.

Does it look like I still have a driver conflict issue?

Geoff.
Reply With Quote
  #20  
Old 05-04-12, 06:52
tgell tgell is offline
Major Geek Extraordinaire
 
Join Date: Oct 2010
Posts: 3,598
Thanks: 208
Thanked 938 Times in 883 Posts
Default Re: No Sound on Toshiba Laptop

I am not sure why they came back after deleting with DriverSweeper unless Windows still had the drivers available. What I do not understand is why Driver Sweeper saw the Creative along with the Asus drivers, since you have a Toshiba laptop. Maybe it just gave you the option to delete those if needed or the Realtek Driver package added those drivers.

You could try to go through the same procedure, remove Realtek through ADD/Remove programs. Uninstall the sound drivers with Driver Sweeper. Then do not install the Realtek Drivers. Let Windows Update try and find the driver.

I have a feeling this is a hardware issue as Puppy did not detect your sound card and you do see the graph when sound is trying to play but no sound is coming from the computer or through the earphone jack. You could try another Linux distro like Ubuntu but that is a large download and I do not know if you have a bandwidth limit or not. If that does not detect your sound card, I would go with the hardware problem and then look to a USB solution using earphones like this or go to a shop and see if they can find the problem.

http://www.newegg.com/Product/Produc...82E16829118013
Reply With Quote
Sponsored links
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Toshiba Tecra sound problem dlb Software 6 06-08-13 04:10
Toshiba M45-S165 No Sound Hornnumb2 Hardware 11 05-04-11 03:07
No sound in Toshiba P35 S609 dking Software 10 10-20-08 15:55
Dos Sound Drivers - Toshiba/Ac 97 crossmr Software 0 09-22-05 21:47


All times are GMT -5. The time now is 01:20.

MajorGeeks.Com Menu

MajorGeeks.Com \ All In One Tweaks \ Android \ Anti-Malware \ Anti-Virus \ Appearance \ Backup \ Browsers \ CD\DVD\Blu-Ray \ Covert Ops \ Drive Utilities \ Drivers \ Graphics \ Internet Tools \ Multimedia \ Networking \ Office Tools \ NEW! PC Games \ System Tools \ Macintosh \ Demonews.Com \ Top Downloads

MajorGeeks.Com \ News (Tech) \ Off Base (Other Websites News) \ Way Off Base (Offbeat Stories and Pics)

Social: Facebook \ YouTube \ Twitter \ Tumblr \ Pintrest \ RSS Feeds


All content Copyright MajorGeeks.com source code Powered by vBulletin® Version 3.8.4
Copyright © 2009 vBulletin Solutions, Inc. All rights reserved.
Ad Management by RedTyger