1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Any Arch users? Arch wireless setup.....FAIL

Discussion in 'Software' started by ichase, Feb 10, 2011.

  1. ichase

    ichase Corporal

    I’m frustrated that I have to ask for help on this one. :-o I have followed the Arch wiki, downloaded the appropriate driver, and extracted the firmware with b43-fwcutter.
     export FIRMWARE_INSTALL_DIR="/lib/firmware"
    wget http://downloads.openwrt.org/sources/broadcom-wl-
    tar xjf broadcom-wl-
    cd broadcom-wl-
    b43-fwcutter -w "$FIRMWARE_INSTALL_DIR" wl_apsta.o
    No failures or messages stating anything other than successful. I added the driver to my MODULES in my /etc/rc.conf. and blacklisted the one I do not need to prevent conflict per the wiki.

     MODULES=(. . . !b43legacy b43. . .)
    I have set up wifi with no problem on 4 other distros on this same lappy. UE 2.8, Mandriva 2010.0-2, Pinguy as well as Mint Julia. I am currently multibooting with XP Pro, Arch and Mandriva 2010.2 (Wireless works great in both XP and Mandriva) The chip set for my wireless is: BCM4318

    ifconfig wlan0 up
    brings up eth0, lo, and wlan0 so I know it recognizes there is a wifi card installed.
    When I run
    iwlist wlan0 scan
    I get something along the lines of Interface does not support scanning, network down. (Network is not down I confirmed this)
    I installed wireless-tools during the initial installation by selecting it from the available packages but can’t seem to find it as an available program to use. When I search the Wiki for “Wireless-tools” there is not a wiki for it but in the Wireless management section of the Wireless Setup wiki it states:

    Well I know I did not forget to install the firmware. The firmware installed fine. I further read that If my encryption is WPA/WPA2 I need to edit the /etc/wpa_supplicant.conf file with my ESSID and passkey. I did that. It then states to run the following command:

     # wpa_supplicant -B -Dwext -i wlan0 -c /etc/wpa_supplicant.conf
    Then states
    Now this is the first time I have seen ANYTHING about a “WEXT” driver and pretty sure I am not using one of those.

    Other things I have read is download Madwifi, Wicd or Wifi Radar. Have not done this as of yet.

    I have tried not to ask for help as I am truly of the mind set of figuring it out on my own by doing my own research so that I do not come off as a “Help Junkie” for lack of a better phrase. I have almost everything set up, boots into KDE in about 10 seconds from the time I turn the lappy on. Want to get the wireless working so I can get everything else set up the way I want it. Ultimately wanted to achieve all of this WITHOUT asking for help but here I am. I truly appreciate your help. :)

    All the best,

  2. ichase

    ichase Corporal

    Well for anyone reading this thread, it is {SOLVED}
    Here is what I did and how I corrected the issue.
    First off, I re-installed Arch from scratch. I believe what happened was, through much reading, I installed the wrong driver for the more updated kernel. I believe I installed broadcom-wl- instead of broadcom-wl- which is for the newest kernel.
    Once I DL this driver and extracted with b43-fwcutter then ran
    # ifconfig wlan0 up 
    The light on my wifi lit up. I then installed KDE then installed Wicd. Now when I log in, Wicd prompts me for a password (root password) then alas, I am connected to my router. I set up Wicd with my essid and passkey (WPA/2) and to connect to this essid upon log in. Wicd will also allow you to search for other available networks as well.

    Now once you have this set up correctly, make sure you blacklist "!network" in DAEMONS so that you will not have a network hang up during boot up. Learned that real quick as well. You will get about a 45 second hang in verbose when Network comes up and it will then fail. So, blacklist it by putting a "!" in front of "Network" and it will skip that step. Not needed if you have wireless properly set up. :)

    Oh, if a moderator reads this, if you would be so kind, mark this thread as {SOLVED}

    Thank you.

    All the best,


Share This Page

MajorGeeks.Com Menu

Downloads All In One Tweaks \ Android \ Anti-Malware \ Anti-Virus \ Appearance \ Backup \ Browsers \ CD\DVD\Blu-Ray \ Covert Ops \ Drive Utilities \ Drivers \ Graphics \ Internet Tools \ Multimedia \ Networking \ Office Tools \ PC Games \ System Tools \ Mac/Apple/Ipad Downloads

Other News: Top Downloads \ News (Tech) \ Off Base (Other Websites News) \ Way Off Base (Offbeat Stories and Pics)

Social: Facebook \ YouTube \ Twitter \ Tumblr \ Pintrest \ RSS Feeds