1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Asus Eee PC 900 - complete loss of power

Discussion in 'Hardware' started by mommysews, Feb 25, 2011.

  1. mommysews

    mommysews Private E-2

    We were recently given an Asus Eee PC 900 Netbook. It came from my father, so I know the history. It was essentially not used for more than occasional email when traveling. It has not seen any abuse and looks brand new.

    The battery drained once and was successfully recharged. I don't know if it was a full charge as I only used it plugged in to the wall.

    The battery was low when I grabbed it to take with me while I watched one of our children at lessons. I booted up, did a quick Google search and then had to put it down to attend to something else. It was closed up and placed in the protective neoprene sleeve and placed on the seat of the car. I didn't turn it off as our other netbook simply hibernates when the cover is closed. I assumed the Asus was the same.

    About 2 hours later, I brought it into the house. It was "dead". I plugged it in. The charger light came on, but the charging or power lights didn't light up on the netbook at all. I tried another outlet "just in case" (although the charger light was on). I assumed that it was like an iPod that doesn't respond immediately if the battery is totally drained. I left it over night.
    This morning, still nothing.
    I called Asus. They had me disconnect the power, remove the battery and hold the power on button for 40 seconds. Nothing happened when the power was reconnected. I also tried the reset button/hole on the bottom. Nothing.

    Asus advised me that it is out of warranty.
    Now what?

    Thanks a bunch.
  2. GCWesq

    GCWesq MajorGeek

    What happens if you try running it plugged in while the battery is removed?

    Is the 'charger light' to which you refer (the one that comes on) on the laptop or on the charger?
  3. plodr

    plodr Major Geek Super Extraordinaire

    Probably not. You press the Function and F1 key to bring it out of hibernation; or I think the silver on/off power button might do this too. I don't remember because I never hibernate my 701. I turn it off before I close the lid.
    I suspect the battery can't be charged because it has run down too low.
    You might also have a charger that has died too.

    What is printed on your charger? All models do not use the same adapter so it is critical to get the proper one for your netbook.
  4. mommysews

    mommysews Private E-2

    Thank you for your replies.

    When I remove the battery and plug it in, nothing happens on the netbook. The blue light on the charger cord comes on, but none of the lights on the actual machine come on.

    The charger cord says:
    ASUS AC/DC Adapter Model ADP-36EH-C
    Output 12V (etc., and so on)
    The blue light that comes on is on the "box" that is midway up the charging cord. It is where the two pieces of the cord connect (the light is on the cord section closest to the computer, so I know that the connection between cord pieces is secure).

    I did attempt to try the Function & F1 combination as suggested. Still nothing.

    This is crazy. It was just fine. It wasn't banged or dropped or plugged in backwards or subject to anything weird (although the van was cold).

    Any more ideas are most appreciated.
  5. GCWesq

    GCWesq MajorGeek

    Probably not a battery problem then. That leaves the charger or the netbook. The light on the charger says that some power is getting through, but it could still be faulty. Before going any further though, it would pay to look inside the socket where the charger plugs into the netbook. Make sure the centre pin is in there and is straight - assuming it is that type of connection. Otherwise, just have a look to make sure nothing looks broken inside whatever socket it has. Sometimes things break when you're plugging in, or unplugging.
    Also, wiggle the charger wire around a bit with everything turned on, and watch to see if any light comes on while you're doing that, as a test for a broken cable or a faulty connection.
  6. jlphlp

    jlphlp Master Sergeant

    Hi all,

    Just a thought: That's an AC (to DC) adaptor and not a Charger. If it runs the computer it is Ok. It could be defective which would explain why she can't run with the batt out and the adaptor plugged in. Probably a problem with the cord to the comp if the pilot lite comes on the adaptor. Hope this helps a little.

    Good Luck, Jim
  7. plodr

    plodr Major Geek Super Extraordinaire

    I need to know the amps.
    I'm not sure if a 12 V charger is the proper one. My 701 model came with a 9.5V charger. If I'd used a 12, it would slowly cook the insides of my eeepc.

    Let me see what the original specs for the 900 charger are.

    Which specific model is it? 900, 900A, 900HD, 900HA, 900SD
    Or is it possibly a 901 or a 904 model?
  8. mommysews

    mommysews Private E-2

    Thanks for the help.
    From what the stickers on the back say, I think that this is simply a EeePC 900 model. There are no other indications anywhere on the unit. The seriel number sticker lists it as: EEEPC900-BK039X. It is running an authentic copy of Windows XP. There are no unlawful modifications nor any "sketchy" software installed.

    The cord says:
    Input 100-240V~1A 50-60Hz
    Output 12V --- 3A

    It has the Asus brand name on it and is the one that came with the netbook. It is in perfect, no wiggle, no fray shape. As mentioned earlier, this has been barely used.

    I am wondering if the 2 hours in a cooling and then fairly cold van might have discharged an already low battery below recharge point. Is this possible? The battery discharging and now not recharging is the only problem that I can see (no other abuse). If this is possible, are these type of batteries replaceable?

    Thanks again.
  9. plodr

    plodr Major Geek Super Extraordinaire

    Even if the battery completely discharged, the netbook should still work when you plug in the adapter.
    The fact that it does not, has me scratching my head. It should work whether the battery is in or out of the netbook - mine does.

    Your adapter is the correct one. It took me a bit to find the specs.

    When you connect the power plug and press the silver button to turn it on, nothing happens. Is that correct?
  10. jools1976

    jools1976 Sergeant

    If you know somebody who has access (and is familiar with using) a multimeter (voltmeter) I would definately check the output on the adapter (charger). You should be getting anywhere from 11.5 to 12.5 volts out. Like jlphlp mentioned earlier, with the battery out (or dead) and the AC adapter not working properly, the netbook isn't going to start up. And the blue light on the adapter doesn't necessarily mean that it is working right.
  11. jbaksha

    jbaksha Private E-2

    I have the same issue. Did you find resolution. I own two of these so I was able to try both power chords, the one fromt he broken one and the one from my working one. I also took it apart and checked for burning etc. and saw no issues. Is it possible the onboard battery is dead causing a problem?
  12. mommysews

    mommysews Private E-2

    I never did find a resolution to this problem. It is so totally weird.
    It doesn't make any sense to me that the computer would just "die" while sitting there - no action, not doing anything.

    I am trying to decide if it is worth the $$ to take it in to a repair shop.
  13. jools1976

    jools1976 Sergeant

    I would check the power adapter before taking it in to get repaired. If the battery is dead and the adapter isn't recharging, the netbook wouldn't power up.
  14. braddana06

    braddana06 Private E-2

    I have a asus eee 900 i am having the same problem. will not come on pluged in with battery in or out. every so often when you press the power button it will come on for about 10 secs then back off and it will do nothing for hours
  15. MrSmalls

    MrSmalls Private E-2

    Saw this forum as it appeared that I had the same issue. I played with the chord while pressing the power button and the computer just turned on. Will be looking for new chord soon.
  16. Gentlejosh12

    Gentlejosh12 Private E-2

    Mabye there's a lose wire inside and mabye if you move it around
    It will work
  17. plodr

    plodr Major Geek Super Extraordinaire

    Gentlejosh12, welcome to MajorGeeks. Please don't drag up a 2 year old thread. I'm sure the original poster has moved beyond this netbook during the past 2 years.
  18. khanivour

    khanivour Private E-2

    Not specifically trying to help the Original Poster, however my EEEPC900 recently stopped charging, and this was the most comprehensive discussion available from Google, so though it would be fastidious to add my (little) knowledge and experience (for other netizens who end up here).

    History: Device worked well for the first 2 odd years, then was "lost" when I moved house, found it again a couple of days ago, plugged it into a generic charger (Kaver brand, Voltage selectable, multiple sized tips). Charged it over night, used it for an hour the next day (on the original battery), thought "all is good".

    Used it again yesterday, (with only 10% battery left), plugged it into the charger... and suddenly realise there's no charging light (on the laptop).

    Tried turning the unit on with charger attached and no battery, but nothing happens.

    Quick test with the multimeter shows the charger is still outputting 12.3 volts (no load). Tried some of the suggestions above (the battery out, hold the power button thing didn't work).

    No matter what I did, nothing helped.

    Finally decided to pull apart the netbook to see if maybe the DC socket had come loose (found a pretty comprehensive video on youtube on how to disassemble the EEEPC900), pulled off the keyboard and upper casing to expose the motherboard. Multimeter shows 12.3 volts across 2 of the solder points on the back side of the DC power socket.

    So... to summarise, I still don't know why my EEEPC900 is no longer charging, or accepting power, Motherboard has access to 12V (which is the appropriate supply voltage), but somewhere further along the line, something is wrong, and I sincerely don't think it's something that the average geek could fix.

    It saddens me to say goodbye to this very versatile and hardy laptop (one of the earliest affordable "laptops" with a solid state drive). My EEEPC701 is still working well though... we'll see how long before that dies.
  19. blvtzpk

    blvtzpk Private E-2

    I know this is an old thread, but my problem is the same as khanivour's - my eepc 900 just suddenly decided not to accept any power - while the charger/adaptor is plugged into the wall socket, its blue light comes on, but when the cord is inserted into the eeepc 900 - nothing. I've used another charger that works well with other computers, but no response from the eeepc 900.

    No ideas from anyone? My next step is to get inside the computer and try disconnecting and reconnecting the CMOS battery, but I think that's a 'fix' when the the LEDs are blinking, but the computer doesn't boot up or has a black screen...

    Any advice very welcome!!!
  20. khanivour

    khanivour Private E-2

    Hey blvtzpk, I feel your frustration, I would love to know how you go... from my research (and notice you've seen the same), the CMOS reset only helps EEEPC's that have LED's lit, but a Black Screen... I'm pretty sure we have a different issue (since our LED's don't even turn on). Although, I did have my CMOS Battery removed for about an hour when I pulled my unit apart...

    That said, I am really looking forward to your reply to see how you went!

    Best of luck!
  21. blvtzpk

    blvtzpk Private E-2

    khanivour, unfortunately, I got nowhere. I have built computers, but I'm not an electrical whiz, so the power issue is very hard for me to work out. I followed the take-apart video here http://www.youtube.com/watch?v=nIthAeN49hI but it didn't change the power issue. It's pretty much a paperweight now. :(
  22. Alnair

    Alnair Private E-2

    Just for the records,

    I have an Eee PC 1005P and today stopped working. Does nothing at all. No lights when plugged in.

    The battery is not discharged. I know because I was at about 50% and I plugged in because it was doing a long process and I need to left it unattended. When I came back the PC was dead.

    Also, the charger blue light slightly blinks when is plugged to the PC, but not when is not plugged. So I suppose there are some kind of short circuit inside de PC.

    It seems is an usual failure for this family of PC.

Share This Page

MajorGeeks.Com Menu

Downloads All In One Tweaks \ Android \ Anti-Malware \ Anti-Virus \ Appearance \ Backup \ Browsers \ CD\DVD\Blu-Ray \ Covert Ops \ Drive Utilities \ Drivers \ Graphics \ Internet Tools \ Multimedia \ Networking \ Office Tools \ PC Games \ System Tools \ Mac/Apple/Ipad Downloads

Other News: Top Downloads \ News (Tech) \ Off Base (Other Websites News) \ Way Off Base (Offbeat Stories and Pics)

Social: Facebook \ YouTube \ Twitter \ Tumblr \ Pintrest \ RSS Feeds