1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Autochk program not found

Discussion in 'Software' started by Baxter Stockman, Feb 16, 2011.

  1. Baxter Stockman

    Baxter Stockman Private First Class

    When starting up the customer's PC. It gives the error "Autochk program not found. Skipping autocheck"

    Windows XP

    Can't boot into Safe Mode.

    Things I've tried:
    1. Chkdsk /r
    2. PTEDIT.exe change type to "07"
    3. Plugging Hard Drive into another computer and manually copying a different autochk.exe from C:\WINDOWS\ServicePackFiles\i386 to C:\WINDOWS\System32
    4. Check disk within Windows on my computer.

    I have access to everything on the drive.

    I've read many threads which have lead to the things that I've tried. Unfortunately what seems to solve it for others has not for me.

    Any ideas?
  2. DavidGP

    DavidGP MajorGeeks Forum Administrator - Grand Pooh-Bah Staff Member


    What XP Service Pack?

    What security software is installed? (antivirus, firewall etc) and doesnt matter which ones apart from would like to know for background, but uninstall them all and run say CCleaner and do a cleaner and then a registry clean (run the registry one until nothing lists for removal) then reboot and see if XP loads.

    just wondering if an app is causing this, also try msconfig and untick all startups as well and see if you can boot ok.
  3. Baxter Stockman

    Baxter Stockman Private First Class

    Well it won't boot. Not even into Safe Mode. So running ccleaner is out, as is stopping startup apps.

    I plugged it into my computer to find out the AV and Service Pack.

    Looks like it is Trend Micro Internet Security 12
    Windows XP Service Pack 2
  4. TimW

    TimW MajorGeeks Administrator - Jedi Malware Expert Staff Member

    Have you gone into the Recovery console and done a fixboot? What other things have you tried in the RC?
  5. Baxter Stockman

    Baxter Stockman Private First Class

    In Recovery Console I've:

    1. chkdsk /r
    2. fixboot
    3. fixmbr

    Nothing has improved or changed the situation.
  6. TimW

    TimW MajorGeeks Administrator - Jedi Malware Expert Staff Member

    Then I would do a backup while you have it slaved and save all the important data and files and then replace the drive and do a clean install. :(
  7. Baxter Stockman

    Baxter Stockman Private First Class

    Yeah I've got the data all backed up already.

    I was just curious of a work around for this.
  8. TimW

    TimW MajorGeeks Administrator - Jedi Malware Expert Staff Member

    I figured that you knew that it might come to a reinstall. I frankly can not come up with a work around.
  9. Baxter Stockman

    Baxter Stockman Private First Class

    I fixed it! Wow! Patience paid off this time. :celebrate

    I had read about 20 threads about this very issue. Each would link me to http://www.pchell.com/support/autochknotfound.shtml. I had done what it said like and it didn't work. Well low and behold at the bottom there is another suggestion. Which I looked over. After my 20th redirect to that site I finally read the bottom. :banghead

    Missing Mountmgr.sys File
    Another situation where you might receive the Autochk Program Not Found error. This occurs when the mountmgr.sys file is missing from the folder Windows\System32\Drivers.

    If you have all the service packs installed, you can copy the mountmgr.sys file from the location C:\Windows\ServicePackFiles\i386\mountmgr.sys to the C:\Windows\System32\Drivers directory and reboot.

    In my case I copied it from one of the $servicepackUninstall folders.

    Thanks for the suggestions.
  10. TimW

    TimW MajorGeeks Administrator - Jedi Malware Expert Staff Member

    Good to know!! ;)
  11. sach2

    sach2 Major Geek Extraordinaire

    Nice work!

    I looked at this problem this morning and missed your eventual solution. I was leaning towards a boot.ini problem but the fixboot you had done would have remedied that. Your solution is the first I saw of the missing Mountmgr.sys file. Good catch! :)
  12. Maine Geeks

    Maine Geeks Private E-2


    Many threads don't address the core issue.
    The Hard drives are locked by these imaging applications like Ghost and Acronis.
    All we have to do is reset the HDD properties.

    Fixed in only 3 Dos commands. Nothing fancy.

    Diskpart , select, Clean

Share This Page

MajorGeeks.Com Menu

Downloads All In One Tweaks \ Android \ Anti-Malware \ Anti-Virus \ Appearance \ Backup \ Browsers \ CD\DVD\Blu-Ray \ Covert Ops \ Drive Utilities \ Drivers \ Graphics \ Internet Tools \ Multimedia \ Networking \ Office Tools \ PC Games \ System Tools \ Mac/Apple/Ipad Downloads

Other News: Top Downloads \ News (Tech) \ Off Base (Other Websites News) \ Way Off Base (Offbeat Stories and Pics)

Social: Facebook \ YouTube \ Twitter \ Tumblr \ Pintrest \ RSS Feeds