1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Baffling C-Media AC97 Audio Device

Discussion in 'Software' started by Ibsen3, Aug 16, 2007.

  1. Ibsen3

    Ibsen3 Private E-2

    Hello all,

    I'm utterly stumped and ruining my holidays by having to sort out irritating little problems like this one. I reformatted Windows XP after continual random restarts whilst working. Everything has installed perfectly okay but I can't get any sound except the odd dull beep from the PC when I get a system message. My speakers have never presented any problems to me in the past but now, all of a sudden, they've gone dead!

    The model I have is a Trust product called 14935 - 2.0 Speaker Set SP-2350S UK and here's a link to what they look like: http://www.trust.com/products/default.aspx?cat=_Current&grp=SPEAKERS&type=2.0&item=14934 . I have a C-Media AC97 Audio Driver already installed and, according to the only advice I've managed to squeeze out of Trust's customer service, I should uninstall and reinstall the driver and the soundcard. Well, I'm not technologically brilliant but I worked out how to do the former and no banana! I'm not sure if the soundcard is something different.

    The bottom line is that even after reinstalling it still says that the speakers aren't working properly. The error message is 'This device cannot start. (Code 10)'. The troubleshooter does nothing (as always!) but I have heard elsewhere on the forums that someone else had this problem and they reset their driver to an earlier version but, of course, I think they at least had the original CD that came with the speakers. It's so long ago that I've lost mine.

    PLEEEAAAASSEEE help. I just want to go outside and enjoy the sunshine but this thing's got it's hooks in me. Thanks to everyone again for making this such a reliable, friendly and useful forum.


  2. DavidGP

    DavidGP MajorGeeks Forum Administrator - Grand Pooh-Bah Staff Member


    When you reinstalled XP did you also re-install your Chipset Motherboard drivers? these tend to be crucial to some other hardware being picked up correctly, also if your motherboard and being a C-Media driver its likely its onboard sound you have, is that driver you installed specifically from your motherboard or PC makers website as not all AC97 drivers work correctly.

    If you can supply your PC maker and model version or motherboard make and version we maybe able to point you in direction of a sound drive that will work without the code 10 error.
  3. Ibsen3

    Ibsen3 Private E-2

    Thanks Halo,

    But I just managed to work it out. It is, however, as you say. I found the driver on my motherboard disc. It was the 'Realtek' codec that I needed. A quick scan for suitable drivers on that disc was all it took. Thanks for your help, though. These forums really are the best around. I should know. I've tried asking for help before in all sorts of places but I can always rely on this one. ;)
  4. DavidGP

    DavidGP MajorGeeks Forum Administrator - Grand Pooh-Bah Staff Member

    No probs glad you have sounds back.

Share This Page

MajorGeeks.Com Menu

Downloads All In One Tweaks \ Android \ Anti-Malware \ Anti-Virus \ Appearance \ Backup \ Browsers \ CD\DVD\Blu-Ray \ Covert Ops \ Drive Utilities \ Drivers \ Graphics \ Internet Tools \ Multimedia \ Networking \ Office Tools \ PC Games \ System Tools \ Mac/Apple/Ipad Downloads

Other News: Top Downloads \ News (Tech) \ Off Base (Other Websites News) \ Way Off Base (Offbeat Stories and Pics)

Social: Facebook \ YouTube \ Twitter \ Tumblr \ Pintrest \ RSS Feeds