1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

BIOS won't detect IDE Hard Drive

Discussion in 'Hardware' started by TheBladeRoden, Dec 30, 2011.

  1. TheBladeRoden

    TheBladeRoden Private E-2

    On my old secondary computer my setup was

    Motherboard: Chaintech VNF2-350
    Master 0: HDS722516VLAT80 with Windows XP SP3
    Slave 0: WD800BB-53CCB0

    But then I started getting Machine Check Exceptions and my motherboard ultimately perished. So I replaced that with a Foxconn K8S755A-6ELRS. But this new motherboard won't detect the hard drive.

    It will hang at the part that says "Detecting IDE drives", sometimes it will give up and display "0" where the drive is supposed to be, other times it will hang until you unplug the cable.

    If it's on the same channel as the Hitachi drive with XP on it, the BIOS recognizes the other drive, but fails to boot from it.

    If they are on different channels, it boots the XP drive but will see no hint of the drive on the other channel., even in Disk Management or Device Manager.

    I also tried connecting it to my other computer's Intel DP35DP mobo, and it was able to detect/read/write and all that, though it does have a few bad sectors.

    Any help?
  2. Burrell

    Burrell MajorGeek

    The only thing i can suggest is going into the BIOS and playing about with the HDD settings, sorry but that's all i've got.

    I'm sure some other guys will be round soon to help you.
  3. sach2

    sach2 Major Geek Extraordinaire


    I know these are basics but some boards can be picky.

    Are you changing jumper settings as you move the drive from its own channel to sharing a channel?

    I would suggest checking the jumpers and using dedicated Master/Slave positions rather than Cable Select. And remember that Hitachi and WD may have different jumper settings for the same position so use the diagram on the label of each drive to determine the correct setting. ie. If using WD as slave then set the WD to slave according to the diagram on its own label and make sure it is in middle position on the cable.

    Check that the boot HD cable is connected to the primary (0) IDE connection on the motherboard it will be printed on the board.

    Might also swap IDE cable just to rule out a bad cable.

    If none of that helps try setting the WD jumper to master according to its label, put it in master position on the primary cable by itself--leave Hitachi disconnected and see if BIOS will recognize the drive. Of course it won't boot but see if it is capable of at least recognizing it.
    Last edited: Dec 30, 2011
  4. TheBladeRoden

    TheBladeRoden Private E-2

    When I do that, it hangs at "detecting IDE drives" for 1:35 minutes, then it displays "none" for the channel, and goes to the next screen with a disk boot error. I did try different cables and the master jumper setting.

    edit: woah just got thrown off by the board displaying messages in reverse order. o_0
  5. Toke

    Toke MajorGeek

    I have had this prob before and as sach2 rightly suggested configuring Jumper settings it doesn't always work. I had 2 different makes of HD's and 1 I had to set to 'MASTER' as indicated on the Drive but when I came to 'Slave' I had to experiment with different settings so the correct settings might not work as written on the drive, so try swapping Jumper positions on the Slave. Try what sach2 says firstly and if you still get the same prob try my suggestion. PS. you might also try swapping the Master/Slave HD's around as this can sometimes rectify the problem.
    Last edited: Jan 1, 2012

Share This Page

MajorGeeks.Com Menu

Downloads All In One Tweaks \ Android \ Anti-Malware \ Anti-Virus \ Appearance \ Backup \ Browsers \ CD\DVD\Blu-Ray \ Covert Ops \ Drive Utilities \ Drivers \ Graphics \ Internet Tools \ Multimedia \ Networking \ Office Tools \ PC Games \ System Tools \ Mac/Apple/Ipad Downloads

Other News: Top Downloads \ News (Tech) \ Off Base (Other Websites News) \ Way Off Base (Offbeat Stories and Pics)

Social: Facebook \ YouTube \ Twitter \ Tumblr \ Pintrest \ RSS Feeds