1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Boot Config is corrupt | Error Code = 0 x 490

Discussion in 'Software' started by Mariusmssj, Oct 16, 2012.

  1. Mariusmssj

    Mariusmssj Private E-2

    Hello guys,

    Today i turned on my PC and it just restarted at Loading OS text

    Video here

    So i booted from a live CD and this is what I saw:

    I clicked on System Repair and got this:

    I tried usin the Bootrec but it didn't help at all.

    Here is the diskpart information:

    List volume-

    List partition-

    List partition 1 with details-

    List partition 2 with details-

    as you see it says no volume associated with it

    If i set the partition 2 as active i get the "BOOTMGR is missing" at power up.

    Can anyone help me????

    Last edited: Oct 16, 2012
  2. falconattack

    falconattack Command Sergeant Major

    Hi my friend , welcome to MG's :major

    Do you install any update ( about programmes ( acrobat reader or antivirus ) etc ) when your computer shut down ? :wave
  3. Mariusmssj

    Mariusmssj Private E-2

    Hi there, I was looking into spliting my other 1Tb drive into 2 partitions so installed Partition Magic 8.0 but it failed to open and i uninstalled it, which was yesterday my last time on the PC before shuting down. And today my PC just refuses to boot
  4. sach2

    sach2 Major Geek Extraordinaire

    Just a quick question, do you have two HD in there--a 60gb and a 1TB? If so, is the OS supposed to be on the 60gb?
  5. Mariusmssj

    Mariusmssj Private E-2

    Yes a 64Gb SSD (OS) and 1Tb HDD (media Drive)
    Last edited: Oct 16, 2012
  6. falconattack

    falconattack Command Sergeant Major

    You must go to

    Run msconfig
    Startup tab

    untick all boxes except for antivirus

    Windows is asking you about restart your machine , go for it , afterwards look what is the behaviour of your computer :wave
  7. Mariusmssj

    Mariusmssj Private E-2

    Hi, I have no access to windows 7 what you saw there was do using windows live disc
  8. sach2

    sach2 Major Geek Extraordinaire

    It looks like the 59gb partition on the SSD is not being assigned a drive/volume letter.

    I haven't figured out how to fix that in diskpart because you need a volume # to assign it a letter. If you have a blank CD you could burn this Partition Wizard bootable CD .iso file to see what it says about the HD. It would be the last download on the page so scroll down. You have to burn the ISO as an image file to make it bootable. Imgburn's "Write Image File to Disc" option will work.

    Then boot from the CD and see what it says about your 64gb HD. See if double clicking on the 59gb partition brings up a list of files including Windows and Users folders.

    Then go to the Partition Recovery Wizard and run the Full Disc and Quick Scan options. In screenshot #4, see if you have more than one entry for the 59gb partition and what the status is for them. Try double clicking on any listing for the 59gb partition and see if includes the Windows and Users folders. Don't Finish out but let me know what is in the list.
  9. Mariusmssj

    Mariusmssj Private E-2

    thanks for the tip, i don't have any CD's any way i can boot that program from USB memory stick???
  10. sach2

    sach2 Major Geek Extraordinaire

    You can use Lili to put it on USB. http://www.linuxliveusb.com/en/download

    In step 2 choose ISO and browse to the PW.iso you downloaded. It will say not on list but it will work.
    Step 3 is not applicable.
    Step 4 tick first 2 boxes. Untick third box. (This will erase everything on USB so make sure you have copies of anything important)
  11. Mariusmssj

    Mariusmssj Private E-2

    I don't understand this forum, if i quote someone my reply is instant, but i go reply to thread it takes time for my posts to come up, i already posted few things but here they are again:


    after full scan:


    Attached Files:

    Last edited by a moderator: Oct 16, 2012
  12. LauraR

    LauraR MajorGeeks Super-Duper Administrator Staff Member

    That has nothing to do with it. New members posts are sometimes flagged because of links, attachments, words. It is all to cut down on spam.

    Please stop reposting after they've gone into moderation. They must be approved and reposting will not make your post go right through.

    Also, please resize your images. They are way too large. (or better yet, attach them to your post as I have)

    Thank you.
  13. Mariusmssj

    Mariusmssj Private E-2

    Ok i understand, i know this will sound stupid but i can't find the edit button :S
  14. sach2

    sach2 Major Geek Extraordinaire

    Thanks Laura.

    You do not need to do any partition recovery in PW. The existing partitions are the ones you want. Close out of the recovery window by hitting Cancel.

    Go ahead and right click the 59gb partition in the main window and set it as Active. Hit Apply button along the top of the window.

    Boot from your Windows disc and see if it will try to fix the bootmgr is missing error or if it gives you the same error details. Check if it again shows the Win7 partition as 0mb as it did in your first screenshot of your first post.
  15. Mariusmssj

    Mariusmssj Private E-2

    Ok here is what i see now

    Attached Files:

  16. sach2

    sach2 Major Geek Extraordinaire

    That is some progress. It seems the disc you are using is for 32 or 64bit and your computer is running the opposite. Do you have access to another repair/installation disc of the other 32 or 64bit version?
  17. Mariusmssj

    Mariusmssj Private E-2

    This is the disk i used to install windows 7 64bit and the disk is for 32 and 64 installation.

    Could this be the solution?
  18. sach2

    sach2 Major Geek Extraordinaire

    I've only had that error when I have tried to run a 32bit repair disc on a 64bit Win7 installation. It has to do with the command prompt not being compatible. You were able to get to the command prompt previously because it didn't recognize your Windows installation.

    Definitely worth a try to disable the TB drive in BIOS or just unplug one of the cables from it.
  19. Mariusmssj

    Mariusmssj Private E-2

    disabling the 1Tb drive didn't do anything, i'll try to get my hands on Windows 7 64 ultimate installation disk.
  20. sach2

    sach2 Major Geek Extraordinaire

    Or if you have another computer running 64bit and scrounge up a CD you can type repair into the Start/Search box and choose "Create a Repair Disc" but ti will only burn directly to a blank CD/DVD.

    If you get your installation disc, you would want to get the list of 5 options by hitting the next button in your screenshot and then selecting start up repair. Let that run. Then reboot to the CD/USB and see if it will now run the automatic repair. then reboot without the USB.
  21. Mariusmssj

    Mariusmssj Private E-2


    i was able to get into the menu and yes i'm getting different error:

    Attached Files:

  22. sach2

    sach2 Major Geek Extraordinaire

    Go ahead and close that window and hit the Next button. Select Start up repair from the list of five options. Let it run then try to reboot. If it doesn't start, then boot from the DVD again and see if you get the same error.

    It is usually fairly straight forward getting the disc to write new boot up files to your actual Windows partition after setting it active as we have. I'll have to look into the 0x15 error because creating a bootmgr file from the disc onto your Win7 partition should have been automatically done. I have tested and found that choosing Start up repair from the list of five options and then rebooting and letting automatic repair run, writes all the necessary boot files found on the System Reserved partition to the main Windows partition. I'm not sure why it is giving you an error on writing the bootmgr file.
  23. Mariusmssj

    Mariusmssj Private E-2

    start up repair says it could not be done automatically and same error is displayed.

    can i try to use command prompt and bootrec?
    bootrec /fixboot
  24. sach2

    sach2 Major Geek Extraordinaire

    Yes you can try that.

    I think I would rule out corruption on those drives causing a problem with writing files to the drive. At command prompt:

    chkdsk c: /f
    chkdsk d: /f

    Then you can try the bootrec command but you need the bootmgr file. There is a copy on the 100mb partition (I believe it is d: ) but I still think I would do the chkdsk on c: and then try the automatic repair one more time. The automatic repair has a copy of bootmgr and should write it to the active partition as a first step. It is giving an error writing that file and I think it may be due to a corrupt filesystem. That would explain the original boot configuration file error too. Read through the chkdsk results just to see if it makes any changes to the filesystem on either of those two drives.
  25. Mariusmssj

    Mariusmssj Private E-2

    Well i slapped in my sisters win7 Sp1 install disk and repair worked and i'm back in my PC :DDDD

    BUT there is an issue the 100mb partition is now Named as E: which E used to be my My media drive so programs can't open any more as E is no longer my 1Tb drive. How to fix this???
  26. sach2

    sach2 Major Geek Extraordinaire

    Type disk management into the Start/Run box and hit enter. Go to the graph and right-click the System Reserved partition and select Change Drive letter and paths. In the window that opens click the Remove button to free up drive letter E:
    (You don't need a drive letter for System Reserved).

    Now right-click on your Media drive and select Change Drive letters. Click Change button and you should be able to select E: from the drop down box. That should do it.

    Edit: If you ever want to browse System Reserved. You can just go back and Assign it an unused letter.
    Last edited: Oct 16, 2012
  27. Mariusmssj

    Mariusmssj Private E-2

    I just can't catch a break :(

    Attached Files:

  28. sach2

    sach2 Major Geek Extraordinaire

    Hmm, your system gives all types of errors I've never seen. You could try installing the home version of Partition Wizard and see if it will remove the drive letter there.

    Otherwise I can take a look at the error but nothing useful came up in a quick search. I know I have removed the drive letter from System Reserved on several computers because I don't like it showing in Computer.
  29. Mariusmssj

    Mariusmssj Private E-2

    i got disk de-fragment service completely off would that cause any issues?
  30. sach2

    sach2 Major Geek Extraordinaire

    No Disk Defragment shouldn't be on for a SSD drive.

    Give me a quick screenshot of the disk management graph where it shows the SSD and its partitions stating which ones are boot, active, page etc.

    Attached Files:

  31. Mariusmssj

    Mariusmssj Private E-2

    here you go

    Attached Files:

  32. sach2

    sach2 Major Geek Extraordinaire

    The problem seems to be that System Reserved is listed as containing the page file which it can't possibly have because it is too small a partition. You C: drive is also listed as containing the page file which would be normal.

    I've never bothered to move my page file so I am not familiar with the process. But it is an apparent error to have two drives designated as page file partitions. I'd have to look into it or maybe someone reading can jump in. I'll take a look in an hour or two but I can't do it now.

    In reality your System Reserved partition is not even being used. The repair has kept your 59gb partition as active and has written a new set of boot files to that partition so it handles the whole boot process.

    A couple of things I am thinking but haven't come up with the best path:

    Run a chkdsk on Sys Reserved. Right-click it in Computer and select Properties. Under Tools tab select error checking. Leave just the first tab selected and hit the Start button. See if it finds any errors.

    I'm going to think about it and see if there is a better answer. You could just delete it using the PW USB you created earlier. The computer should still boot fine. If there was a problem you could run the Partition recovery wizard and in screen #4 just select the 100mb partition and the 59gb partition to recover. That would bring you back to where you are now.
  33. Mariusmssj

    Mariusmssj Private E-2

    Errors everywhere xD

    What do you think about this attempt?

    And btw thank you for all of your help and patience, I really appreciate it!

    Attached Files:

  34. sach2

    sach2 Major Geek Extraordinaire

    You can force a dismount on drive E: to run the error checking. That is no problem.

    The regedit is the detailed fix. Of course you would be changing the letter on drive E: not drive C:. I don't know if it will give you an error or not.

    I don't want to keep throwing out "quick fixes" without thinking about them. I was also thinking since the System Reserved partition isn't really being used it could be formatted. You could then go ahead and restart to verify that the system boots which it will.

    Then you could go ahead and set the System Reserved back to Active and use your Win7 SP1 disc to rewrite fresh boot files to the System Reserved partition which shoud set things back to the way they were originally.

    Like I said, I am still not sure how System Reserved is being marked as containing the Page File. Removing that designation would be ideal but I don't have time to search that before dinner. I will get back to this later. If you try something let me know I'd be interested. Oh, and Create a fresh restore point before doing anything in the registry. System Restore is available from the Recovery Environment on the DVD.
  35. Mariusmssj

    Mariusmssj Private E-2

    Force dismount did the job and i was allowed to use remove and i got my E back and everything as it used to be :D

    sach2 i would like to thank you for all of your help and the time you took to help me :) Your a star!!!
  36. sach2

    sach2 Major Geek Extraordinaire

    Good! Then I think we should just leave well enough alone.

    If you have any problems post back. :)

Share This Page

MajorGeeks.Com Menu

Downloads All In One Tweaks \ Android \ Anti-Malware \ Anti-Virus \ Appearance \ Backup \ Browsers \ CD\DVD\Blu-Ray \ Covert Ops \ Drive Utilities \ Drivers \ Graphics \ Internet Tools \ Multimedia \ Networking \ Office Tools \ PC Games \ System Tools \ Mac/Apple/Ipad Downloads

Other News: Top Downloads \ News (Tech) \ Off Base (Other Websites News) \ Way Off Base (Offbeat Stories and Pics)

Social: Facebook \ YouTube \ Twitter \ Tumblr \ Pintrest \ RSS Feeds