1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Can't Find Atheros AR8121/AR8113/AR8114 Ethernet Cotroller On Your System

Discussion in 'Software' started by D.Alejandro, Aug 19, 2012.

  1. D.Alejandro

    D.Alejandro Private E-2

    I had a virus and Malwarebytes Anti-malware found and removed it but ,when I restarted my PC I got a black screen then the no signal detected. So I figured that maybe a system files(s) were damaged during virus removal and decided to reinstall windows 7. After reinstall I clicked to check for updates and was unable to connect to the internet. I forgot to install the motherboard drivers with CD. After drivers were installed I looked to see if I had internet access and saw a red X, so I went to device manager and didn't see a Ethernet controller/driver. I then went to menu bar on device manager clicked view and selected show hidden devices and saw network adapters, clicked drop down arrow and saw 8 WAN Mini ports. So I thought maybe the windows CD is corrupt and tried installing windows vista with same results, then windows XP with same results. So I decided that somehow the motherboards Ethernet connector somehow became damaged, and flashed the bios to see if that would help but the problem remained. I then installed a Ethernet card compatible with windows XP and installed Windows Xp so that there wouldn't be a compatibility issue; and yet the problem still remains. I took the PC apart,cleaned it out and put it back together, reinstalled Windows XP in the hope that maybe somehow it would change something to get my internet working again, it didn't. I browsed the motherboard CD and manually installed the Lan drivers and got a message saying: Can't Find Atheros AR8121/AR8113/AR8114 Ethernet Controller On Your System.So I downloaded the Atheros AR8121/AR8113/Ar8114 Ethernet Controller from various sites including this one and tried installing with same result: Can't Find Atheros AR8121/AR8113/AR8114 Ethernet Controller On Your System. I don't know what else to do, please help.
  2. pwillener

    pwillener MajorGeek

    What is your actual network adapter?

    If I were in your situation I would install DriverMax, then check your system for unknown devices. Note that the free version can download up to two drivers per day.
  3. falconattack

    falconattack Command Sergeant Major

    Hi my friend , do you exist any yellow mark in Device Manager menu ?
    Start - Run mmc devmgmt.msc - Ok :wave
  4. D.Alejandro

    D.Alejandro Private E-2

    No,there are no yellow mark or any for that matter.The Ethernet controller/driver aren't installed. They don't show up.
  5. D.Alejandro

    D.Alejandro Private E-2

    There's something I forgot to mention; I had to change the ram because it somehow got damaged, probably from the virus,don't know.

    The network adapter doesn't show a name, just 8 WAN Mini ports.
  6. dlb

    dlb MajorGeek

    If nothing appears in the "Network Adapters" section of the Device Manager, then check the BIOS and make sure everything is enabled. If installing an ethernet card still doesn't work, then we have a problem. Possibly the motherboard is damaged. Check all the capacitors on the board and make sure they are all perfectly flat on top (more info about popped capacitors can be found in post #3 and #4 in this thread).

    Also, when you say that you "reinstalled Windows XP", do you mean a clean install where you erased the partition, created a new partition, formatted the hard drive, and then installed Windows? Or did you perform a repair install where you install Windows "on top" of the previous install, leaving all your programs and data intact?
  7. D.Alejandro

    D.Alejandro Private E-2

    It was a clean install. the capacitors are all good.the motherboard doesn't show anything wrong,nothing looks burned nor is there a burned smell,it looks fine, fairly new. Don't know if it matters but, it's an asus p5q pro turbo with a core 2 quad 2.66 ghz. processor, 2gb of ram Corsair, ATI Radeon HD 4670, Creative Soundblaster X-Fi Extreme Fidelity. I downloaded and ran SIW as gloozit suggested and noticed that there are no drivers related to internet, no controllers/drivers of any kind. As for network adapters only my computer name come's up. What does it mean. Could the motherboard be damaged to the point that it wont detect internet connectivity, drivers, or controllers? Could the processor be infected? don't know how but, I do see that my PC is running fine. Other than internet connection problem everything else runs fine. I'm beginning to think that there's nothing wrong with any of the installations or the ethernet card. I think the problem lays with the motherboard or CPU. I replaced the ram, hard drive, and ram, and did a clean install of windows 7 ultimate. The problem is still there. I need to know that it's the motherboard and not the processor. Is there any way that the processor be compromised, infected? I don't want to replace the mother board and it turns out it was the processor. How can I figure out if the processor is clean?
  8. D.Alejandro

    D.Alejandro Private E-2

    Opps, forgot. I checked the bios and everything is enabled accept.

Share This Page

MajorGeeks.Com Menu

Downloads All In One Tweaks \ Android \ Anti-Malware \ Anti-Virus \ Appearance \ Backup \ Browsers \ CD\DVD\Blu-Ray \ Covert Ops \ Drive Utilities \ Drivers \ Graphics \ Internet Tools \ Multimedia \ Networking \ Office Tools \ PC Games \ System Tools \ Mac/Apple/Ipad Downloads

Other News: Top Downloads \ News (Tech) \ Off Base (Other Websites News) \ Way Off Base (Offbeat Stories and Pics)

Social: Facebook \ YouTube \ Twitter \ Tumblr \ Pintrest \ RSS Feeds