1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Can't format flash drive after adding readyboost

Discussion in 'Hardware' started by whicky1978, Aug 3, 2011.

  1. whicky1978

    whicky1978 Staff Sergeant

    I bought an 8gib LaCie flash drive and formatted it exfat and put readyboost on it along with windows 7 backup. When I rebooted, my laptop would hang and boot very slowly or fast if I removed the drive.

    If I wait for my pc to boot with the drive in, it shows up but I can't open virtual disc service or format using right click with the mouse. I also tried using HP USB format tool with no sucess. I've also tried another Windows 7 PC with 32 bit W7 insteado of 64 bit. The next think I will try is taking it to work. My work laptop uses Windows XP. If I can format it and get it to work again, I won't put readyboost on there.

    I also tried using command prompt but I may not be using the right commands. Also, I have my HD to boot first now which helps with the bios but not windows.:confused
  2. tgell

    tgell Major Geek Extraordinaire

    Can you delete the partition and format using Disk Management? If not, download Gparted Live CD. Burn the iso image with Nero or Imgburn. Boot the CD with the USB flash connected and make sure the USB drive is selected in the drop down box in the upper right of the screen and not your hard drive. Select the partition(s) and then delete. Create a new partition and reformat. You should format it as FAT32.

Share This Page

MajorGeeks.Com Menu

Downloads All In One Tweaks \ Android \ Anti-Malware \ Anti-Virus \ Appearance \ Backup \ Browsers \ CD\DVD\Blu-Ray \ Covert Ops \ Drive Utilities \ Drivers \ Graphics \ Internet Tools \ Multimedia \ Networking \ Office Tools \ PC Games \ System Tools \ Mac/Apple/Ipad Downloads

Other News: Top Downloads \ News (Tech) \ Off Base (Other Websites News) \ Way Off Base (Offbeat Stories and Pics)

Social: Facebook \ YouTube \ Twitter \ Tumblr \ Pintrest \ RSS Feeds