1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Can't play Blu-Ray - AACS decoding library?

Discussion in 'Software' started by gman863, Feb 4, 2013.

  1. gman863

    gman863 MajorGeek

    I know Blu-Ray playback issues have been touched on in other threads; however I've tried most of the possible solutions in them and am at my wit's end.

    I upgraded a Toshiba notebook w/ Win 7 32-bit with a BD-ROM-CD/DVD+RW internal drive. The computer recognizes the drive and states it's working properly; however none of the following solutions has worked:

    * Shark007 Codecs.
    * Cleaning the registry using Advanced System Care
    * Pot Media Player
    * Disabling and re-enabling the drive (suggested in a Microsoft TechNet post)

    I tried VLC media player; however it gives me an error message stating "it needs a library for AACS decoding; your system does not have it."

    How do I find a library for AACS decoding? The only things I've found in the downloads section are programs that remove AACS decoding for copying.

    Any help would be appreciated. Thanks in advance.
  2. plodr

    plodr Major Geek Super Extraordinaire

  3. gman863

    gman863 MajorGeek


    Thanks for the advice. Unfortunately, following the steps in http://vlc-bluray.whoknowsmy.name/ did not work - I still get an error message.

    Also tried Pot Player, didn't work.
  4. plodr

    plodr Major Geek Super Extraordinaire

    Then you might have to buy a program to play Blu-ray.
  5. mcsmc

    mcsmc MajorGeek


    Not sure which version of VLC you tried, but the "nightly"/beta is the only one that is supposed to actually play BDs. If you choose to install it, I'd recommend uninstalling the version of VLC you currently have installed. I haven't tried it, so I honestly can't guarantee that it works, but here is a download link if you'd like to give it a shot:

  6. Harald12

    Harald12 Private E-2

    I have a question on this topic. I have put KEYDB.cfg file in roaming folder: username/appdata/roaming and the AASC file in program/videolan/vlc folder to play blu ray discs on an external blu ray drive with VLC media player but the player says when i try to load/start G: (the external blu ray drive) :blu ray error (something) missing keys? . I run windows 8 pro 32 bit and i have (i think) downloaded the right 32 bit AASC file, what can i do to make it work to play the blu ray disc? Thankful for answers.
  7. peterjack

    peterjack Private E-2

    You can use VLC to play Blu-Ray on Windows 8, but you will need to download and place the AACS and BD+ DRM libraries and keys in order to play Blu Ray on Windows 8.

    There a step-by-step guide from UFUSoft i find on google about how to Play Blu-Ray with VLC in Windows 8 64-bit/32-bit that may help you to play Blu-Ray for free.
  8. Just Playin

    Just Playin MajorGeek

    Some newer movies have BD+ DRM and VLC still can't play them.
  9. techster

    techster Private E-2

    I tried the latest version of VLC and also VLC night version 2.2

    I installed the KEYDB.cfg file as directed into the %appdata%/aacs folder.

    I installed the 64 bit version of libaacs.dll since I am running the nightly VLC (64-bit), but I tried with the 32-bit version just in case and still the same problem:

    Blu-ray error:
    This Blu-ray Disc needs a library for AACS decoding, and your system does not have it.
    Your input can't be opened:
    VLC is unable to open the MRL 'bluray:///D:/'. Check the log for details.

    I'm running Windows 7.

    Suggestions greatly appreciated, since this is getting frustrating.
  10. Just Playin

    Just Playin MajorGeek

    Some newer movies have BD+ DRM in addition to AACS DRM and VLC still can't play them.
  11. techster

    techster Private E-2

    Ok thanks.

    That is good to know, but as it turns out that was not the problem I was having.

    When trying to write the 64-bit libaacs.dll file into the VLC directory, I was actually not reading this pop up. It started with "This file already exists in this directory, do you want to wite...etc.". I have seen such messages in Windows many times before when it warns you that you are going to write over an existing file. However, after much painstaking troubleshooting, I finally read the popup msg to the end and saw that it ended with "...write it to <another directory>?"

    So it was never overwriting the 32-bit libaacs.dll file in the VLC directory because I needed administrator permission. However, when saving during a download, it never asks for that, it just gives the option to write it somewhere else.

    I went as administrator and hand pasted the file into that directory and now all is well :)
    Last edited: Nov 9, 2013

Share This Page

MajorGeeks.Com Menu

Downloads All In One Tweaks \ Android \ Anti-Malware \ Anti-Virus \ Appearance \ Backup \ Browsers \ CD\DVD\Blu-Ray \ Covert Ops \ Drive Utilities \ Drivers \ Graphics \ Internet Tools \ Multimedia \ Networking \ Office Tools \ PC Games \ System Tools \ Mac/Apple/Ipad Downloads

Other News: Top Downloads \ News (Tech) \ Off Base (Other Websites News) \ Way Off Base (Offbeat Stories and Pics)

Social: Facebook \ YouTube \ Twitter \ Tumblr \ Pintrest \ RSS Feeds