1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Can't stop "Preparing to Install" message

Discussion in 'Software' started by 4world, Jan 10, 2007.

  1. 4world

    4world Private E-2


    I am new to this forum and would appreciate any pointers or help for the following-

    I have Win XP Pro (2002), SP2. If I open a folder browser window (Explore or Folder list), and click on "Search" (F3), it brings up the Windows Installer dialog box that says "Preparing to install ..." I can't search and the PC seems crippled at that point.

    Only way out at that point is to use Ctrl-Alt-Del and kill the Installer or the browser window (which are in "Not Responding" state).

    Thank you in advance
  2. Adrynalyne

    Adrynalyne Guest

    Preparing to install.....what?

    Is there a title on the window, hinting as to what its trying to install?
  3. 4world

    4world Private E-2

    The title on the dialog box is "Windows Installer" and the message inside it is "Preparing to install..." There is nothing else that is mentioned except there is a "Cancel" button that does not work.

    Once this dialog box pops up, all open windows get almost frozen or extremely slow to respond.

  4. Adrynalyne

    Adrynalyne Guest

    Right click on My computer, choose manage.

    Go to event viewer, check application, and system logs.

    Look for a source of Windows installer.

    See if it gives a hint of what is trying to install.
  5. 4world

    4world Private E-2

    Hi Adrynalyne,

    Thank you for taking the time to help so quickly!

    To be sure, I cleared both the "Application" and "System" logs and then repeated the procedure that causes the problem.

    After the Installer starts, the System log shows nothing whereas the Application log shows the following two lines preceded by an exclamation point in a yellow triangle (I've just given the most relevant columns) --

    Type Source Category Event
    Warning MsiInstaller None 1001
    Warning MsiInstaller None 1004

    Thank you.
  6. Adrynalyne

    Adrynalyne Guest

    Sorry, should have mentioned. Double click on those to open them up and get the information from them.
  7. 4world

    4world Private E-2

    Oh, I am sorry ... I should have tried double clicking myself. So, here's what the "Description" of the two warnings say


    Detection of product '{DC76EAE7-72B6-442E-AAD0-6A67F915C23D}', feature 'Intel_Modules' failed during request for component '{2BBD855C-60FD-421E-9BF2-D67E06AE0679}'

    For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.


    Detection of product '{DC76EAE7-72B6-442E-AAD0-6A67F915C23D}', feature 'Intel_Modules', component '{27FB8069-002F-11D4-B4C2-0010B50A9735}' failed. The resource 'C:\WINDOWS\system32\Msinet.ocx' does not exist.

    For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

    The links above do not give much help either.

    I searched the net and found this ...


    ... which has 36 comments but no clear solution (click on "See all 36 comments" on the bottom). confused

  8. Adrynalyne

    Adrynalyne Guest

    ok, Intel_modules.

    Is it safe to assume you have an Intel video card?

    If so, try uninstalling the video card software from add/remove. If that doesn work (as in you cannot), let me know, there are other ways to do this.
  9. Marshaz

    Marshaz Private E-2

    Hi 4world, I have a similar problem the windows installer pops up when start VLC media player. In my case when I click on the cancel button it will carry on for a few seconds (so you think the cancel button hasn't worked) and then it stops but immediately tries to install again. I find that if I click the cancel button the second time it stops it. Odd times it may take 3 times but it is liveable with. Not an answer to your problem but you may like to try clicking the cancel button 2 or 3 times if you haven't already tried. Good luck.
  10. 4world

    4world Private E-2

    Actually, this is an IBM Thinkpad T42 with an ATI Mobility Radeon 9600 series video card.

    The only items that have "Intel" in their description in the Device Manager are:

    * IDE ATA/ATAPI Controllers
    * Network Adapters (2 - one wired and one wireless)
    * System devices - several. SMBus Controller, LPC Interface Controller, PCI bridge, Proc to AGP controller, Proc to I/O controller
    * USB controllers - several. Most are some "Host Controllers"

    If I "uninstall" any such item from the Device Manager, would I need some kind of driver disk to install it back after the system reboots? If so, I better look for the driver before uninstalling!

  11. Adrynalyne

    Adrynalyne Guest

  12. 4world

    4world Private E-2

    Shows the following two Intel programs--

    Intel PROSafe for Wired Connections [8.00.0005]
    Intel PROSet for Wired Connections [7.10.0000]

    (I did not click "Remove" to clean up the installer config for these two since I didn't know if you wanted me to. I have just listed what I saw after running the program.)

    Thank you again for your sustained effort!
  13. Adrynalyne

    Adrynalyne Guest


    Find an updated driver/software download for your network card.

    Then we will look at removing those entries, but check back with me first on finding those drivers.
  14. 4world

    4world Private E-2

    Ok, after quite a few different tries, I found the correct drivers for both network cards (they are from the correct Lenovo website after automatic detection of my laptop config).

    I would have installed both as given in the directions on the webpage but I'm checking with you as you've asked. Shall I install them?

  15. Adrynalyne

    Adrynalyne Guest

    Not yet.

    Use the clean up utility to remove those Intel entries., then reboot and install those drivers.

    This is at your own risk, if those drivers you downloaded don't work, you won't be able to get back online.
  16. 4world

    4world Private E-2

    Didn't work! The installer still pops up on search.

    I did exactly like you said:
    1. Removed the 2 entries with Windows Installer Clean up utility
    2. Rebooted
    3. Installed the two drivers and rebooted (as instructed by install)

    Pls. note that I did not 'uninstall' the two drivers from the Device Manager at any point. One driver was installed by right clicking the network adapter and selecting "Update Driver ..." whereas the other driver was installed by running a supplied ACPSETUP.EXE (which automatically removed the earlier driver first and then installed the new one).

    I observed 3 things-
    a) After step 2. but before 3. above, I was still able to connect to the net as usual (in contrast to what you had said).

    b) After step 3., I ran the clean up utility again but I couldn't see any entry for Intel, even though I had installed both the new drivers. Do you know why?

    c) Under Computer Management, Application Log reveals the exact same two entries even now.

    Thanks again. Sorry I am putting you through so much trouble. :(
  17. Adrynalyne

    Adrynalyne Guest

    Ok...let me do a little research.

    A little background to why this is happening.

    A feature or application was installed, and failed on install. It is attached to the WIndows Installer service via the registry.

    Every time the windows installer service is invoked (starting up any windows installer installed app), you get this message.

    The key is to find the app, nuke it, and reinstall if needed.
  18. Adrynalyne

    Adrynalyne Guest

    Can you try something?

    Go to start, run, regedit.

    Go to edit, find

    Paste in DC76EAE7-72B6-442E-AAD0-6A67F915C23D

    Click Find.

    Go through the keys it finds, (left hand side) and see if you can delve any name of the application in question. That would help immensely.

    DO NOT MODIFY ANYTHING! There is no 'undo' here. Just look.

    I'll do some research in the meantime.
  19. Adrynalyne

    Adrynalyne Guest

    I may have something. Do you have iTunes?

    Uninstall it from add/remove, if yes.
  20. 4world

    4world Private E-2

    1. No I don't have iTunes.

    2. The registry search revealed the following keys (copied from left column):


    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\App Management\ARPCache\{DC76EAE7-72B6-442E-AAD0-6A67F915C23D}




    I don't know how to dig any further from the above data to find the defaulting application. Pls. let me know how.

    You are quite a guy! Putting in so much effort for someone you've never dealt with before and for nothing in return. Thank you v much.
  21. Adrynalyne

    Adrynalyne Guest


    Go through this. Expand the key, click on the different parts. The data contained it is displayed on the right. We are looking for an application name :)

    Re: the help, thats what we are here for. I don't help as much as I used to, but I try to follow through to the end when i do :)
  22. 4world

    4world Private E-2

    Ok, the application name found in the right column in most of these keys is "SolidWorks 2004 SP0" and another one is ARPRODUCTION.EXE (this is the one that has the exact key that you had me search the first time).

    I would have searched for the above EXE file in the Program Files folder to see if it was in the SoildWorks folder or any others but 'search' is the function that we're trying to get working!

    Shall I uninstall SolidWorks and see?

    I expressed surprise only because unfortunately, people like you are not that common these days (I'm talking about the %age in the general population and not on forums like this; but even in forums, most don't usually show this level of persistence). Everyone's running after their own thing and people don't have time for others. People who selflessly work for others are the highest forms of life on the planet.
  23. Adrynalyne

    Adrynalyne Guest

    You bet. Lets uninstall it and see what happens.
  24. Adrynalyne

    Adrynalyne Guest

    You will find that a lot here (persistance), and I've been guilty of dropping threads more than once.

    I just don't know as much as I used to anymore. I haven't been actively working on this stuff in quite a while.
  25. Matacumbie

    Matacumbie Rocky Top

    If the Search feature is not working try re-registering Jscript.dll and Vbscript.dll, see if that solves anything.

    1. Click Start, and then click Run.
    2. In the Open box, type regsvr32 jscript.dll, and then click OK.
    3. Click OK.
    4. Click Start, and then click Run.
    5. In the Open box, type regsvr32 vbscript.dll, and then click OK.
    6. Click OK.

    Try to do a search.


    ps. Adrynalyne is one of the best. ;)
  26. Adrynalyne

    Adrynalyne Guest

    You give me far too much credit.
  27. 4world

    4world Private E-2

    You may be right since I am very new to forums so my comment was partly inaccurate.
  28. 4world

    4world Private E-2

    Strange! The first time I tried to uninstall, the dialog box showed:

    SolidWorks 2004 SP0

    Please wait while Windows configures SolidWorks 2004 SP0

    Gathering required information...

    < and a growing bar graph here which stopped growing at about 50% >

    Then the same Windows Installer started again and everything was pretty much frozen until I killed the two processes using Ctrl-Alt-Del

    The second time I tried to uninstall SolidWorks, it did the same thing except without the Windows Installer popping up. SolidWorks never uninstalled; the dialog box got stuck with bar graph at about 50% and virtually no disk or CPU activity after that.

    Hi Steve,

    Tried your steps which showed "... succeeded" message each time I ran regsvr32 but the search problem is still the same.

    Thank you
  29. Adrynalyne

    Adrynalyne Guest

    Use the window installer cleanup program to axe solidworks.
  30. 4world

    4world Private E-2


    You should see my beaming smile!!! That did it!


    Mucho mucho mucho gracias! (I ain't Spanish so don't talk back in it if you know it.)

    I don't know how I should thank you since a simple thank you is too easy.

    I have talked to tech support (even level 2) via phone of companies like HP, IBM, ... numerous times and most of the times the guys try random things to try fix your problem. In fact, some procedures look too dumb to even try once. This is really the first time someone has did some real systematic investigation to nail the real culprit; some impressive engineering-class research.

    I gotta find out what I ate that morning to have been lucky enough that you noticed my posting and helped!

    (Btw, can I now delete the SolidWorks directory from Program Files to completely eliminate it from my system or is there something else also required to finish the clean up?)

    My salutations to you. :wave
  31. Adrynalyne

    Adrynalyne Guest

    Yep! Its now Safe to delete, as its (important) registry entires have been axed.

    Sometimes its not knowing how to solve the problem, but rather understanding why the problem is happening, and where to go to find out why.

    Glad it worked out for ya :)
  32. Adrynalyne

    Adrynalyne Guest

    Funny you mentioned phone support. I did MS support for years, and by far, troubleshooting over a forum is the hardest way to fix things.

    Yet, MG members prevail again and again.

    Doesn't say much for the telephone tech support, does it :D
  33. Adrynalyne

    Adrynalyne Guest

    I will say this, 4world, thank you, for being able to follow my directions so easily :)

    That made this a very easy procedure for everyone.
  34. 4world

    4world Private E-2

    And, you are also too humble to give others credit for your good work! Geez.


    I wish the moderators of this forum make the forum's search facility a bit more powerful so others who face this problem can quickly find this thread. When I came to this forum, I tried using quote marks (like we use in Google) to force searching for a phrase ("Preparing to install") but that didn't work - it broke up the phrase and found a zillion threads. Of course, this thread was not there at that time but it wouldn't have helped even if it were.
  35. Matacumbie

    Matacumbie Rocky Top

    That was an amazing troubleshooting effort Adrynalyne. Well done my friend. :)

  36. Adrynalyne

    Adrynalyne Guest

    I think its more that we dont have a major database to draw from compared to somewhere like Google, where even close keywords generate a hit.

    For example, this poster ahs your same issue, with a different application. it also said preparing to install, but the poster never gave the exact error in his text, making it no good for a search query.


    And...thanks for the compliments guys :)
  37. eliteghost

    eliteghost Private E-2

    AHHH HA! i found that somone else had the same problem i have now!

    i dont quite understand how you went about fixing this, can someone sum it up?

    i dont think mine deals with sold works.

    my error derives from a list of crap that happend to my computer, maybe you can narrow it down to somthing to try.

    First. I downloaded and installed Visual stuio C++ to build web code for my website.
    2nd. Visual studio "Just-In-Time-Debugger" was pissing me off and closing my apps because they had errors that it wanted to debug before they ran.
    4th I uninstalled visual studio and probly went too far and got rid of some important windows installer things?
    5th I did a system restore way back to my brand new computer.
    6th MY video card drivers were all out of wack.
    7th i fixed my video card drivers, and everything is running smooth EXCEPT THIS "PREPARING TO INSTALL"

    i see it mostly when im opening internet explorer, and microsoft office programs.

    Any suggestions?
  38. man0fsteel

    man0fsteel Private E-2

    Hi Adrynalyne...I just read thru this entire post and hope it isn't too old to ask for help.

    I have the same problem as the OP, closer to 4-world's issue. I'm running WinXP SP3, Dell Precision T3400 and the "Preparing to Install" pop up window keeps flashing.

    I've tried the MS download (didn't work), when checking the Application event errors this is what shows up:

    The description for Event ID ( 1001 ) in Source ( MsiInstaller ) cannot be found. The local computer may not have the necessary registry information or message DLL files to display messages from a remote computer. You may be able to use the /AUXSOURCE= flag to retrieve this description; see Help and Support for details. The following information is part of the event: {30465B6C-B53F-49A1-9EBA-A3F187AD502E}, SoleFeature, {D2D7B4BF-6CCA-11D5-8B3F-00105A9846E9}, (NULL), (NULL), , .

    I hope you can help me diagnose this crazy problem. It originally started up after opening Outlook (2010) and then clicking on a different folder inside my inbox. I was able to click the cancel button for about 2 weeks and it would go away.

    Now the Preparing to Install window flashes so quickly, I can't even click it.


Share This Page

MajorGeeks.Com Menu

Downloads All In One Tweaks \ Android \ Anti-Malware \ Anti-Virus \ Appearance \ Backup \ Browsers \ CD\DVD\Blu-Ray \ Covert Ops \ Drive Utilities \ Drivers \ Graphics \ Internet Tools \ Multimedia \ Networking \ Office Tools \ PC Games \ System Tools \ Mac/Apple/Ipad Downloads

Other News: Top Downloads \ News (Tech) \ Off Base (Other Websites News) \ Way Off Base (Offbeat Stories and Pics)

Social: Facebook \ YouTube \ Twitter \ Tumblr \ Pintrest \ RSS Feeds