1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Dell Dimension 8400 won't start

Discussion in 'Hardware' started by jazzyhali, May 22, 2012.

  1. jazzyhali

    jazzyhali Private E-2

    My dell desktop won't start up, there is no light on on the power button, none of the letters in the back are lit. I have checked to see if the power supply was working and it is. I replaced the MB because there was some bulging parts on the original MB, but it is still not powering up, anyone have suggestions?
  2. brownizs

    brownizs MajorGeek

    Okay. Helps to know what the model number is. Have you checked to make sure that it is plugged in, if it is plugged into a surge strip, that the surge strip is turned on and plugged in.
  3. jazzyhali

    jazzyhali Private E-2

    Do you want more the dimension 8400? I have tried different outlets and check power supply
  4. brownizs

    brownizs MajorGeek

    If you have tried different outlets and checked the power supply, and all cables are plugged in correctly to the motherboard for the machine, fans are plugged in, I would say that the machine is FUBAR.

Share This Page

MajorGeeks.Com Menu

Downloads All In One Tweaks \ Android \ Anti-Malware \ Anti-Virus \ Appearance \ Backup \ Browsers \ CD\DVD\Blu-Ray \ Covert Ops \ Drive Utilities \ Drivers \ Graphics \ Internet Tools \ Multimedia \ Networking \ Office Tools \ PC Games \ System Tools \ Mac/Apple/Ipad Downloads

Other News: Top Downloads \ News (Tech) \ Off Base (Other Websites News) \ Way Off Base (Offbeat Stories and Pics)

Social: Facebook \ YouTube \ Twitter \ Tumblr \ Pintrest \ RSS Feeds