1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Digital Product ID error and pc shutdown

Discussion in 'Software' started by kguthrie, May 25, 2009.

  1. kguthrie

    kguthrie Private E-2

    Our system:
    Gateway GT5014GT
    Intel Pentium D CPU 820 2.8 GHz
    Intel Cortez NT94510J (name D945GCZ)
    DIMM1 &2 Samsung M3 78T6553CZ3-CD5 512 MB
    Windows XP Pro Service Pack 3

    We have done a system restore, a system recovery, replaced the power supply and the RAM. I have ran Windows Memory Diagnostics, Checkdisk and numerous other programs.
    We still have our computer randomly shut down and reboot, sometimes once, sometimes 3-5 times. We always get the same error about WER34d5.sys and .mndp. The folder is then created in our Local/Temp folder. The manifest for the error is:

    UI LCID=1033
    DigPidRegPath=HKLM\Software\Microsoft\Windows NT\CurrentVersion\DigitalProductId
    ErrorText=The program is not responding.
    HeaderText=You chose to end the nonresponsive program, Setup/Uninstall.
    EventLogSource=Application Hang

    When we try to report it we get this message:

    Windows cannot find "http://oca.microsoft/resedir.asp?sid=603&Bucket=MEMORY_CORRUPTION_STRIDE&State=1&ID=99fc16a-fcb7-4e3f-d9fbd52f3889&LCID=1033&OS=5.1.26002.00010100.30" Make sure that you typed the name correctly, and then try again. To search for this file, click the start button, and then press search.

    So we know that it has to do with the Digital Product ID and how it is programmed to hangup automatically. Anyone have any ideas about what to do?

  2. Drizzles

    Drizzles First Sergeant

    Well for starters def do READ & RUN ME FIRST, and Basic Computer Maintanence Everyone Should Do ...

    If you haven't already, boot from you original CD/DVD get to CMD and type;
    chkdsk /r

    Then, boot to Safe Mode and go to CMD and type sfc /SCANNOW.

    If none of that helps ... what memory diagnostic do you use?
    Last edited: May 25, 2009
  3. kguthrie

    kguthrie Private E-2

    as always, you rock. I didn't know anything about that. I'll give it a try and hopefully it will work. It really sucks that Gateway didn't include any Windows backup disks with the pc. It gives me no starting point.
    Thanks again!

    we used the actual Windows Diagnostic Tool that you download from their website when the screen pops up that they have no idea what's wrong with your system. I've also used Regscan and Regcleaner. I've done everything short of what DomLuc has pointed me to. In fact, we were about to do another system recovery and reformat the entire drive because of this. I can't boot from our original CD because we never received one from Gateway, so thank you anyway for that idea.
  4. kguthrie

    kguthrie Private E-2

    This is what I got, which doesn't look good... now how do I fix it?

    Microsoft (R) Windows Debugger Version 6.11.0001.404 X86
    Copyright (c) Microsoft Corporation. All rights reserved.

    Loading Dump File [C:\Documents and Settings\Owner\Local Settings\Temp\WERfea7.dir00\Mini052409-03.dmp]
    Mini Kernel Dump File: Only registers and stack trace are available

    Symbol search path is: SRV*c:\symbols*http://msdl.microsoft.com/download/symbols
    Executable search path is:
    Windows XP Kernel Version 2600 (Service Pack 3) UP Free x86 compatible
    Product: WinNt, suite: TerminalServer SingleUserTS
    Built by: 2600.xpsp_sp3_gdr.090206-1234
    Machine Name:
    Kernel base = 0x804d7000 PsLoadedModuleList = 0x8055d720
    Debug session time: Sun May 24 20:38:10.234 2009 (GMT-7)
    System Uptime: 0 days 0:00:18.781
    Loading Kernel Symbols
    Loading User Symbols
    Loading unloaded module list
    * *
    * Bugcheck Analysis *
    * *

    Use !analyze -v to get detailed debugging information.

    BugCheck 10000050, {ffffff7d, 0, 805c301e, 0}

    Could not read faulting driver name
    Probably caused by : memory_corruption

    Followup: memory_corruption

    kd> !anazize -v
    No export anazize found
    kd> !analyze -v
    * *
    * Bugcheck Analysis *
    * *

    Invalid system memory was referenced. This cannot be protected by try-except,
    it must be protected by a Probe. Typically the address is just plain bad or it
    is pointing at freed memory.
    Arg1: ffffff7d, memory referenced.
    Arg2: 00000000, value 0 = read operation, 1 = write operation.
    Arg3: 805c301e, If non-zero, the instruction address which referenced the bad memory
    Arg4: 00000000, (reserved)

    Debugging Details:

    Could not read faulting driver name

    READ_ADDRESS: ffffff7d

    805c301e 38587c cmp byte ptr [eax+7Ch],bl




    BUGCHECK_STR: 0x50

    PROCESS_NAME: winlogon.exe

    LAST_CONTROL_TRANSFER: from 80578ae4 to 805c301e

    f6db3ce4 80578ae4 f6db3cf0 00000000 001f0003 nt!ObInsertObject+0x7c
    f6db3d4c 8054162c 7c97e0f8 001f0003 00000000 nt!NtCreateIoCompletion+0x82
    f6db3d4c 7c90e514 7c97e0f8 001f0003 00000000 nt!KiFastCallEntry+0xfc
    WARNING: Frame IP not in any known module. Following frames may be wrong.
    0006f7cc 00000000 00000000 00000000 00000000 0x7c90e514


    CHKIMG_EXTENSION: !chkimg -lo 50 -db !nt
    3 errors : !nt (805783f6-80578ade)
    805783f0 df 89 7d d0 0f 8c *e6 02 00 00 8b 45 b4 8b 48 14 ..}........E..H.
    80578650 ff 75 94 ff 75 18 ff 30 8d 45 d8 50 ff 76 *0c ff .u..u..0.E.P.v..
    80578ad0 4e 3f f8 ff 8d 45 e4 50 53 53 ff 75 0c 53 *54 e8 N?...E.PSS.u.ST.

    MODULE_NAME: memory_corruption

    IMAGE_NAME: memory_corruption

    FOLLOWUP_NAME: memory_corruption





    Followup: memory_corruption
  5. Drizzles

    Drizzles First Sergeant

    Absolutely everything there points towards your RAM ... for starters, if you have handled Hardware before, I would remove your RAM sticks, get a CLEAN, NEVER USER tooth or paintbrush and remove your RAM sticks, brush them both over thoroughly and their sockets. THEN, get a CLEAN, NEVER USED rubber (eraser) and rub it up and back the gold contacts on the bottom of the sticks, both sides and the bottom, then brush them over again. After doing this insert ONE of the sticks and see if your system will boot, if it doesn't, remove it and try it in the other slot. If your system still doesn't boot, do the same process with the other stick. If your Motherboard has four RAM slots, two will be the same colour the other two will be a different colour, use the colour that the sticks weren't originally in. If you haven't handled Hardware before, get a friend that has to help you out. It also might pay to update your BIOS ... I would definetly get a Computer savvy person to do that as that can go really bad if its done wrong. (I say that about the BIOS because I had that same Blue Screen the other day on my new system and it was because my BIOS was 8 versions out of date.)
  6. kguthrie

    kguthrie Private E-2

    It's new and checked out RAM (I think I stated that before). They are in the same slots that the original ones were in. I ran MEMTEST86+ and Memory Diagnosis on them as well and both came out clean.
    I don't get the blue screen... I keep telling people this. The system just shuts down. I fixed the reboot thing. This is a programming error from everything that I can tell (and two other computer people in my family, they just don't know how to fix it. They've never seen it before). The original post error report states what the process is programmed to do and that's to shut off the computer when the DID is trying to register itself.
    Like I said before, I do not have the install or reboot disk for Windows XP.
    Maybe I'm completely wrong...
  7. kguthrie

    kguthrie Private E-2

    Also, I'd like to mention that this error only occurs between 12 pm- 7 pm. The rest of the time, the system runs fine.
  8. Drizzles

    Drizzles First Sergeant

    Are you for cerial?? lol wow ... ummm ... perhaps ... how old is this machine and have you tested the power supply?
  9. kguthrie

    kguthrie Private E-2

    Yes, I am serious. If you read my original post, we just installed a NEW power supply. The PC is 3 1/2 years old and has been well cared for. My husband is a web designer and knows that side of computers not the operational side.
    And you don't need to treat me like I'm an idiot. DomLuc has been helping me with this issue for well over a week now. He's been incredibly helpful and welcoming, your last post Drizzles, was a little condescending.
    If you find my thread so dumb, then just leave it alone. I'm sure that there are others out there who are willing and able to help me without attitude. Anything else is a waste of my time. I don't see you contributing anything that wasn't already stated in my original post that I have already done.

    I finally got a blue screen after I turned off the automatic reboot. The error was:
    Beginning dump physical memory...
    Dump physical memory complete.
    Disable or uninstall any anti-virus, disk defragmentation or back up. Check hard drive configuration and check for updated drivers. Run checkdisk for hard drive corruption.
    0x00000024(0x001902FE, 0xF5F8B378, 0xF5F8B074, 0x80573866)

    I have run chkdsk three times in the past two days (once before installing new RAM, once after and once this morning after this message). The error pointed back to the original software problem of Digital Product ID.
    HKLM\Software\Microsoft\WinNT\Current Version\Digital Product ID
    This was the ONLY error in chkdsk all three times.
    Last edited: May 25, 2009
  10. kguthrie

    kguthrie Private E-2

    CCleaner found no errors.
    As in my original post, we did a system recovery last Sunday, so all of our drivers are the latest that have been released by Intel, Gateway and Microsoft.
    I forgot to add that we are running Sophos as our anti-virus and firewall. We also have a Linksys Wireless-G Broadband Router installed.
  11. kguthrie

    kguthrie Private E-2

    that was the full text log that I got from the Debug...
    I just downloaded SysinternalsSuite, maybe that will give me some more information about what's going on.
    I still feel like the issue is the coding in the Digital Product ID and how it's configured to shut down after initiation. Why it's even running is curious to me... my product ID is there, so I don't know how to resolve that issue.
    I searched the Microsoft site last night for two hours looking for some kind of answer and I got nothing. This only started (I might mention) when I installed Service Pack 2. I had it on the original OS and this one as well (although I have upgraded to SP 3).
    It's a quandary... I'll post if I get anything after I run some more diagnostics with this new program.
    Thanks for staying on and helping me. I really appreciate it...
  12. kguthrie

    kguthrie Private E-2

    I was scanning that download "Sysinternals" that I got from this site, when PSKill (a hacking tool) was detected by Sophos. When I clicked on Sophos to remove it, the computer went to the blue screen. This is what it said:

    A problem has been detected and Windows has been shut down to prevent damage to your computer.
    If this is the first time you've seen this Stop error screen, restart your computer. If this screen appears again, follow these steps:
    Check to be sure you have adequate disk space. If a driver is identified in the stop message, disable the driver or check with the manufacturer for driver updates. Try changing video adapters.
    Check with your hardware vendor for any BIOS updates. Disable BIOS memory options such as caching or shadowing. If you need to use safe mode to remove or disable components, restart your computer, press F8 to select Advanced Startup Options, and then select Safe Mode.

    Tech Info:
    ***Stop: 0x0000007E (0x0000005, 0x80578775, 0xF796949c, 0xF7969198)

    I rebooted in Safe Mode with Networking and got onto the Microsoft website to see what the error code meant. It's basically what it says above. I checked disk space and we have 177 GB's. I'll try the video adapters right now. I had asked the question before about BIOS, I didn't really get an answer. Our BIOS is the original one that came with our system. My dad, who's a Police Computer Forensics Detective Specialist, told me that there was no need to update it. It came custom made specifically for our system and updating could cause instability to our system. If I do update, do I go directly to the latest version or what? I don't know how to disable BIOS memory options, I know that there is a thread on here somewhere about it. I just don't want to do it if it's not necessary.
    I got rid of Sysinternals (I'm reporting it too) and just did a virus and malware scan on my system.
    I want a sledgehammer at this point...
  13. kguthrie

    kguthrie Private E-2

    Now that that is taken care of...
    I went back into msconfig and took a look at my system. I'm missing the following .exe files, I don't know if they are vital:
    Running Tasks
    svchost.exe. (process ID's 1636,528,1140) There is a svchost.exe file in my system, it's just not assigned to these processes.
    System n/a
    System IDLE Process n/a

    I have no idea where to get these since I don't have that disk. I know that it's probably causing some issues on my pc. I checked out all of my hardware and everything is in working order with no errors. The rest of the Software Environment was fine as well.
    I'm really confused...
  14. Drizzles

    Drizzles First Sergeant

    I wasn't trying to be condescending ... I was just surprised and a little lost myself ... and yes agreeing with DomLuc I'm also beginning to think it may be Malware
  15. kguthrie

    kguthrie Private E-2

    I'm sorry, I'm just getting really frustrated.
    DomLuc, It is not a Malware issue. It's not a memory issue. It's not a motherboard issue.
    Today, all I've been getting since 4:00 is Update BIOS or disable BIOS memory options such as caching or shadowing there is an issue with hardware or software that has been recently installed. (IRQL_NOT_LESS_OR_EQUAL_) or (PAGE_FAULT_IN_NONPAGED_AREA).
    Error codes: 0x000007E (0xc0000ID, 0x8057889C9, 0xF79E9420, 0xF79E011C)
    0x0A0000 (0x500000, 0x1c0000, 0x000000, 0x804FA257).

    I've tried loading BIOS but there is nowhere to configure memory settings (I've looked five times). Maybe I'm missing something...
    I've also ran chckdsk \F \r, Windows Diagnosis and Memtest86+. I have physically examined the motherboard in direct light and a magnifying glass for cracks. I printed out my event viewer last night since the system recovery and found where and which software might have caused the issues (I stupidly hooked up my wireless external modem without installing it). I know where to do a system restore and have the point set in system restore, I just can't get to it. Remember, I don't have a boot CD or a floppy drive...

    My Windows Advanced Options Menu gives me:
    - Safe Mode (not working, it either freezes while booting the drivers (everytime it's \drivers\apgCPQ.sys) or it just reboots and gives me one of the two blue error screens.
    - Safe Mode with Networking (worked the first half an hour when the system started doing this. Now it does the same thing as regular Safe Mode).
    - Safe Mode with Command Prompt (don't know how to use it, but it's probably what I need to be using, just my hunch...)
    - Enable Boot Logging (no clue)
    - Enable VGA Mode (again, not a clue)
    - Last Known Configuration.... (same thing happens as above Safe Modes)
    - Directory Services (I really need to figure out the Advanced Options screen, huh? I'm trying to keep my sense of humor).
    - Debugging Mode (not even going to say it again, nothing about it)
    - Disable automatic restart on system failure (already configured that way)
    - Start Windows Normally (yeah, right)
    - Reboot (so I can go through this incredibly frustrating process?)
    - Return to OS Choices Menu (I can load either Windows Media Center or Windows XP (default). I know that they are the same thing.

    Can you please get me out of this hole? Thank God for my laptop and for all of you...
  16. kguthrie

    kguthrie Private E-2

    I'm sorry DomLuc, I should have stated that when you posted that Malware Removal Guide, I went directly to it and performed the tasks. I ran that guide about two weeks ago and there was nothing there either.
    Last night, my dad was convinced that this was a hardware issue and not a software issue. He had me plug my tower directly into the socket, disconnect my wireless keyboard and the ethernet cable. I followed his instructions and did what he said. It worked for the rest of the evening (about 2 hours) and then I shut it down.
    This morning, on the other hand, I immediately started getting blue screens with IRQL_NOT_LESS_OR_EQUAL and PAGE_NOT_FAULT_IN_NONPAGED_AREA.
    Luckily, I had my best friend who lives in Germany and happens to be a computer tech on the phone. We worked for three hours troubleshooting. One major problem seems to be our version of BIOS. On the main page, it doesn't state any copyright or manufacturer. There is no way of configuring BIOS in any way accessing the SATA/IDE mode. It's a really really really old version of BIOS (not even listed on the Gateway or Intel site. I have no idea who manufactured the chip). All of the page errors point in that direction as well.
    We did a system recovery to try and repair any program glitches in Windows XP and just set it back to a clean slate. We also formatted the disk after the recovery. I got an error message coming out of the recovery saying that a file had not been added to the system. I got it twice and I'm sorry but I was in a hurry to get to an appointment, I didn't write down the .dll.
    When I got back there was a blue screen again that stated BAD_POOL_CALLER. So I shut off the thing and tried to reboot in safe mode to set up for Memtest86+. The boot hung in the listed system files on apgCPQ.sys. I rebooted and tried to load normally and got the worst message ever: config.sys is corrupt or missing. This after we had just reinstalled Windows...
    So, all of our error codes and that system file could be fixed easily with a BIOS upgrade. Problem is, I need to find out who manufactured it and when.
    Here's the version number: PB94510J.15A.045.2005.0802.2004
    My dad still thinks it's a hardware issue... it might be, but everything is working properly in the processor, power and fans.
    Hope that gives you enough info... Again, I'm sorry that I didn't let you know that I had checked for the Malware...
    So I'm in the quandary of whether to actually upgrade the BIOS or give the tower over to my dad who will in turn just replace the motherboard because he won't even look at the software issues.
  17. plodr

    plodr Major Geek Super Extraordinaire

    Looking around Gateway's site, there are three models starting with GT5014. None end in GT. I think from the specs you've posted, that this is your computer
    None of the driver downloads are very recent

    Now, the place where the computer seems to hang is at the DigitalProductID for windows. Could it be damaged? I'd probably download magicalJellyBean and see what the registry has for your serial and see if it matches what is on the case.

    If it doesn't see if you can change it. If you have a problem, call either Gateway or Microsoft, tell them your XP serial and the issues you are having.
  18. kguthrie

    kguthrie Private E-2

    I was able to boot up the computer today for awhile and installed Everest via CD. It actually gave me the specs for my BIOS chip, which is Intel.
    As for the .sys hang, I've also gotten config.sys is corrupt or missing and today I got ntoskrnl.exe corrupt or missing error code.
    As for the registry error, the thing that seemed to start this whole mess (we are only guessing), we already know that the Digital Product ID does not match our Product ID. Found that out when I tried to download a program from Microsoft and they had to verify our certificate.
    So, now, I am completely frustrated. I'm trying to figure out which shortcut keys allow POST to appear. I know to pause it when it's done it's thing so I can write down what is going on.
    Tonight I'm downloading RescueRecoveryCD, the original OEM Windows XP suite that was initially installed on our pc when we got it and the updates for BIOS (I'm starting with the very first, jumping to 1788 (installs flash capabilities) and then the latest version). Hopefully, clearing and reformatting the hard drive and the reinstall will be the fix.
    Otherwise, I'm going to post and ask for a sledgehammer.
    Oh, I almost forgot... Intel and Gateway suck. Neither of them would even tell me what the manufacturer was of my BIOS chip. Intel said that it ships the motherboards to Gateway and then they remove the chip and install a different one. Gateway wouldn't even talk to me about anything because my computer is past warrantee. That's when I downloaded Everest on my laptop and burned it.
    I know that DomLuc was adamant about the Malware theory, but I've had two network techs look at the specs from it (they are gone now because we did a recovery, twice). Although we did have a virus about a month ago that was sending spam email out through our account about discount electronics. That's gone though, obviously.
  19. kguthrie

    kguthrie Private E-2

    From now on, listen to what DomLuc says about Malware and viruses as gospel. Not that I found any after this whole debacle, but we did have our system hijacked at some point in time. My husband was way too lax about the sites he visited and the files/programs that he would download. As a web designer, I assumed that he was scanning the stuff he was downloading and had the firewall appropriately configured. I knew nothing about this stuff before three weeks ago.
    In the beginning of this, I did run Diagnostics on the hard drive and RAM and two out of four tests came out positive about the RAM. I took out each stick of RAM and ran diagnostics on them. The two sticks of RAM that I got were actually extras that my dad had (he neglected to tell me that they had been used). So, I've been searching, posting and troubleshooting all of this time to try and figure out what the root cause was for our system failures. I was trying to reinstall WinXP today and kept having issues. I was on the phone with my comp tech friend in Germany and narrowed it down to two things. Either one or both sticks of RAM had gone bad or the SATA port or cable were. Long story short, it ended up being one of the sticks of RAM (sorry to have doubted you so much Drizzles). So in one way, I feel like a total newbie idiot and in another I'm really proud of myself for being so tenacious about doing this myself. I had a lot of help, everyone on here and my SATA post, were wonderful as usual.
    So, the new (purchased today in original packaging) RAM is installed, I plugged the SATA cable into port 3 just in case. The system is up and running again just like new. I've never felt such excitement booting up a computer in my life.
    So, thank you, all of you, you have all taught me a lot about something that I had no clue about. I now feel like if something happens again (knock on wood) to either the pc or laptop, I can at least determine within a shorter period of time what the issue is.
    The number one priority from now on is protection. Second is detection. I've now reinstalled our external wireless modem and I have a good (from what I've experienced and been told) firewall and anti-virus. I will be running a Malware and virus scan every day from now on.
    Thanks again everyone.

Share This Page

MajorGeeks.Com Menu

Downloads All In One Tweaks \ Android \ Anti-Malware \ Anti-Virus \ Appearance \ Backup \ Browsers \ CD\DVD\Blu-Ray \ Covert Ops \ Drive Utilities \ Drivers \ Graphics \ Internet Tools \ Multimedia \ Networking \ Office Tools \ PC Games \ System Tools \ Mac/Apple/Ipad Downloads

Other News: Top Downloads \ News (Tech) \ Off Base (Other Websites News) \ Way Off Base (Offbeat Stories and Pics)

Social: Facebook \ YouTube \ Twitter \ Tumblr \ Pintrest \ RSS Feeds