1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Display driver stopped responding and has successfully recovered

Discussion in 'Software' started by thejaguar, Jan 20, 2008.

Thread Status:
Not open for further replies.
  1. thejaguar

    thejaguar Private E-2

    Hello, am receiving this error on many games. Rome total war, Silent hunters 3, Company of heros. Screen will flicker black then recover with a lower resolution. Every 4th or 5th time the game will crash.

    Have found many sites quoting this problem but no answer I can understand.

    Vista 32
    Intel Core2 CPU
    2030 MB Ram
    Radeon X1950 Pro driver version 8.432.0.0
    ACPI x86 driver version 6.0.6000.16386
    BenQ FP222W Analog driver version

  2. dlb

    dlb MajorGeek

    I've been researching this, and it seems to be a Vista problem, not a driver problem. It also seems to be more of an nVidia problem, but you're running an ATI card.... when you get the error, is there a file name listed? Usually, it will look like this "Display driver %filename% stopped responding...." If you do get the file name, please post it and we'll go from there. In the mean time, please be patient and I'll do more research....
  3. thejaguar

    thejaguar Private E-2

    No there is no %filename% listed, I would have exspected one too.
  4. dlb

    dlb MajorGeek

    Microsoft has a Vista update KB938194 http://support.microsoft.com/?kbid=938194 that is supposed to help fix this issue. I have read that some people have installed this and now all is well, and other people have removed it to fix the problem. It is definitely a Vista issue. Many people have returned to XP due to this problem; apparently, it's related to the way drivers are installed in Vista. It's a different process than with XP.... the error may also be memory related: if you have a dual channel motherboard (ch A and ch B) each channel must have both slots full or both slots empty; ie- if you have 3 RAM sticks, you must remove the odd stick that sits alone, or add a 2nd equal stick. This particular "fix" sounds like BS to me, but it has worked for a few folks out there.... still looking into this... 95% of the people with this problem have NVidia cards, 4% have on board Intel video, and 1% have ATI so it really limits the research pool ;)
    I'm still looking tho'... I have some 'feelers' out there, hopefully something will come up soon....
  5. dlb

    dlb MajorGeek

    OK- it appears as if it's a Vista update from Microsoft that causes this problem. And since Vista is a bit 'sneaky' in it's updating, you may not have even known that an update to your driver or OS was even downloaded and installed. It seems that the default built-in Vista driver is not buggy; it's an update that is causing the error. So using this logic, removing the current video drivers, rebooting, and letting the OS install the built-in driver (and being sure that auto-update is totally disabled) should fix the problem. DO NOT allow Vista to search the web or update the video driver EVER until the new Vista service pack is released. Microsoft, NVidia, Intel, Dell, and ATI are all aware of this problem and have been aware for OVER A YEAR and have yet to do anything about it! Lots and lots of people have this same issue and are pretty PO'd, I would be too (I love WinXP ;) ). Dell claims to have fixed the issue in the new XPS computers but who knows.... again, I'm still looking for more info that will be more helpful. I'm glad you posted this issue. It has shown me that a large portion of the Vista gaming population is having a problem I hadn't even known existed. Now to find a concrete fix for this craziness....
  6. thejaguar

    thejaguar Private E-2

    My goodness! I've waited on hold with the bank longer than it has taken you to read, investigate and reply. Thankyou very much:)
  7. dlb

    dlb MajorGeek

    It seems a temporary fix is to lower your in-game video settings like resolution, anti-aliasing, antiscopic filtering, and what not. If everything is set at high, try going down a step to medium (some games have medium-high). If that doesn't help, go down another step.... this seems to help the NVidia users, maybe it will help with ATI also. There isn't much info about a fix for the ATI users, but I'm still looking....
  8. Colis12

    Colis12 Private E-2

    Hey are there any updates on this issue, because i'm currently suffering the same problem and its getting quite irritating :(
  9. dr.computer

    dr.computer Private E-2

  10. thejaguar

    thejaguar Private E-2

    Thankyou so much all who helped.
  11. thejaguar

    thejaguar Private E-2

    "Rats, I have seen this update before. It gives this message "This update does not apply to your system" Will wait and see if a fix does come.
  12. Edejon

    Edejon Private E-2

    5 of my friends (including myself) worked on this problem for about two weeks -- installing clean OS, xp 64, vista 32, and vista 64. Here is what we figured out -- A FIX!

    This works for all versions of Catalyst Control Center (several different video cards with the same problem were tested.)


    I am running Windows Vista Ultimate (64 bit), but we tried this in xp 64 bit, and vista 32 bit -- this works for all of them.

    Apparently CCC uses atikmdag.dll to reference memory. I don't know what the problem with it is, but all you need to do is install the most current driver and NOT catalyst control panel. If you only install the driver, atikmdag.dll never exists. You can use ati tool (there IS a signed driver version out there -- sorry, can't remember link) or rivatuner to regulate your fan speeds, overlclocking, and 3D environment. Crossfire should still work and you should be up and running in no time.

    If you are tired of having these problems, and have not found a work around, please try the above method. It eliminated ALL VPU crashes for all of us.

    Asus M2R32-MVP mobo (580x)
    Athalon 64 - 2.6ghz x2 (OC'd to 3 ghz)
    4x 1g Crucial Ballistix
    Sapphire Ati Radeon xt 2600 HD
  13. thejaguar

    thejaguar Private E-2

    Well I uninstalled CCC and downloaded the newest driver and installed it.

    I have dine a search for atikmdag.dll and it comes up negitive.

    But the problem remains. Is it possible to use some generic driver?
  14. thejaguar

    thejaguar Private E-2

Thread Status:
Not open for further replies.

Share This Page

MajorGeeks.Com Menu

Downloads All In One Tweaks \ Android \ Anti-Malware \ Anti-Virus \ Appearance \ Backup \ Browsers \ CD\DVD\Blu-Ray \ Covert Ops \ Drive Utilities \ Drivers \ Graphics \ Internet Tools \ Multimedia \ Networking \ Office Tools \ PC Games \ System Tools \ Mac/Apple/Ipad Downloads

Other News: Top Downloads \ News (Tech) \ Off Base (Other Websites News) \ Way Off Base (Offbeat Stories and Pics)

Social: Facebook \ YouTube \ Twitter \ Tumblr \ Pintrest \ RSS Feeds