1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Easeus Disk Copy - Can get it to work, copied disk won't boot

Discussion in 'Software' started by lostdata, May 26, 2011.

  1. lostdata

    lostdata Private E-2

    Hi, I tried duplicating my hard drive using "easeus disk copy" but the software doesn't seem to work even though on paper it should. Perhaps those knowledgeable with this software and disk formats in general can point out where I'm going wrong? I'm using Windows 7 Home Premium x64.

    I used this software as I believe it is supposed to copy every sector perfectly. As far as I know, partition size, location, names, attributes, the master boot record etc are all detailed in sectors, so that a sector by sector copy should produce a fully working drive, but I can't boot the copied drive or access the recovery partition through f8-repair computer. One partition is labelled as "recovery" rather than "oem", and "uniqueid disk" returned a different number identifier as well from the original.

    I used windows installation DVD recovery option to use diskpart to try and see whats going on with my limited knowledge. But I was told by the recovery software that my copy of windows has problems, clicking on details showed the following:

    "The following startup options will be repaired:
    Name: Windows Boot Manager
    Identifier: {xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx}

    The following startup options will be deleted:
    Name: Windows 7
    Identifier: {xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx}
    Windows Device: Partition = Not Found

    The following startup options will be added
    Name: Windows 7 Home Premium (recovered)
    Path: Windows
    Windows Device: Partition = C : (943866 MB)

    Name: Windows Recovery Partition Environment (recovered)
    Path: Recover\xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx\Winre.wim
    Windows Device: Partition=C : (943866 MB)

    Name Windows(TM) Code Name "Longhorn" Preinstallation Environment (recovered)]
    Path: Windows
    Windows Device: Partition = D : (100000MB)

    A copy of the current boot configuration data will be saved as c:\Boot\BCD,Backup.001"

    I replaced the number strings with Xs for convenience.

    I'm not sure why it couldn't find the windows 7 partition as diskpart can find 2 partitions, I declined the option to carry out the suggested repair.

    I used a drive that had been fully cleaned with diskpart clean all, and the copy occurred with no errors. Can you tell me where I'm going wrong? Thanks
  2. Earthling

    Earthling Interplanetary Geek

    I wonder if it's an anti-piracy thing in 7? Bit of a concern if it is, as many of us here use imaging (Easeus, Acronis etc) and would anticipate being able to restore an image to a new HDD and that it would be bootable.

    I assume you physically disconnected the original drive before attempting to boot the clone?

    Another way of doing this would be to take a full disk image with Easeus Todo and restore that to the new drive. An image is different from a clone in that it is not sector-by-sector (unless you opt for that), but the end result is the same - your system is transferred in its entirety to the new disk.
  3. sach2

    sach2 Major Geek Extraordinaire


    I used Todo to clone a Win7 HD to a new larger drive and had no problems it booted right up. I did it from the bootable CD which you can create from the ToDo program. So if this is just a test you might try with ToDo to see if it is program related rather than a security measure. (I believe I had read that on some computers that Windows ties the size of the C: partition into some information in BIOS to generate some code to make sure it is the same computer. I don't know specifics since I never ran into the problem.)

    As to the problems with the current disk, my experience with Windows RE rewriting the boot files, is that letting it do the automatic recovery you declined and then doing one manual Startup repair from the list of 5 recovery options (Startup Repair ending with Command Prompt) will always get the Windows installation going. I recommend anyone that is doing any type of Win7 partition/disk image restore have an installation disc or Win7RE disc available.

    If this is just a test I think I would try ToDo and see if it works without startup repair.
  4. lostdata

    lostdata Private E-2

    I did reboot with the drive still in, but I intercepted the boot with f8 and opted for a shutdown. But I solved the problem, all I simply had to do was enter uniqueid disk id=<number from original drive> and now it works fine. Perhaps rebooting, even if intercepted with f8, was the problem?
    Last edited: May 26, 2011
  5. sach2

    sach2 Major Geek Extraordinaire

    I've never seen that--where did you get the unique disk ID?
  6. lostdata

    lostdata Private E-2

    It's part of the diskpart command, you access that at the command line.

    If the problem was caused by rebooting, perhaps the developers can add a shutdown button in the next version?
  7. sach2

    sach2 Major Geek Extraordinaire

    Thanks! :)

    Sometime, I'll look into the Easeus program for disk cloning to see what I get regarding needing the disk ID and the rebooting. I like to test the different programs. I see easeus now allows you a bootable CD in the free version, which I like to have just in case.

Share This Page

MajorGeeks.Com Menu

Downloads All In One Tweaks \ Android \ Anti-Malware \ Anti-Virus \ Appearance \ Backup \ Browsers \ CD\DVD\Blu-Ray \ Covert Ops \ Drive Utilities \ Drivers \ Graphics \ Internet Tools \ Multimedia \ Networking \ Office Tools \ PC Games \ System Tools \ Mac/Apple/Ipad Downloads

Other News: Top Downloads \ News (Tech) \ Off Base (Other Websites News) \ Way Off Base (Offbeat Stories and Pics)

Social: Facebook \ YouTube \ Twitter \ Tumblr \ Pintrest \ RSS Feeds