1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Firefox refuses to open

Discussion in 'Software' started by kltrip, Jul 26, 2010.

  1. kltrip

    kltrip Private E-2

    For some reason Firefox won't open under on of the three users. The "Firefox is already running" error pops up. When I open task manager, it is not on the list so I can't shut it down there. FF opens with no problem on the other two user profiles. I have run every scan I can think of on this machine. What would you suggest as a next step? Thank you for your help.
  2. DavidGP

    DavidGP MajorGeeks Forum Administrator - Grand Pooh-Bah Staff Member


    What Windows version and Service Pack are you running? as in the likes of Vista and Windows 7 you "may" need to click the "show all processes from all users" button.

    Try the info in the Mozilla KB article HERE

    If that doesnt work, uninstall Firefox and run say CCLeaner and its Cleaner and Registry tool to clean up any temp and left over reg entries, then reboot and re-install the latest version of Firefox
  3. chapincito

    chapincito Specialist

    That makes me think about what happened with my wife's computer. After a Firefox update (2.6, I think) that started giving me errors, something like you; so, I uninstalled that version and reinstall the old one.;)
  4. sexyandy81

    sexyandy81 Sergeant Major

    Try downloading the new version of firefox to see if that works. But uninstall the old version first and run ccleaner to clean the remaining files and registry as per Halo's post.

    If you are using add-ons, install them one by one so that you know which add-on causes firefox not to open and then you can run in safe mode and delete the add-on.
  5. kltrip

    kltrip Private E-2

    The machine is running XP Home, SP3 Ver2002

    I have tried all of the advice in this thread including uninstalling ff, running the reg cleaner and reinstalling. I had previously uninstalled/reinstalled ff but had not run the cleaner. I thought it was worth a try to attempt it again
    I unchecked the box for read only on the profiles' folders. When I tried to delete the parent.lock file (I was on one of the working profiles) i was denied with the "file being used" error. When I closed ff, the file disappeared. Also, there are no add-ons being used. Thanks for all the suggestions so far!
    I'm not sure what to try next, any ideas?
  6. plodr

    plodr Major Geek Super Extraordinaire

  7. kltrip

    kltrip Private E-2

    I tried this already, I went through the steps, did I miss something?

Share This Page

MajorGeeks.Com Menu

Downloads All In One Tweaks \ Android \ Anti-Malware \ Anti-Virus \ Appearance \ Backup \ Browsers \ CD\DVD\Blu-Ray \ Covert Ops \ Drive Utilities \ Drivers \ Graphics \ Internet Tools \ Multimedia \ Networking \ Office Tools \ PC Games \ System Tools \ Mac/Apple/Ipad Downloads

Other News: Top Downloads \ News (Tech) \ Off Base (Other Websites News) \ Way Off Base (Offbeat Stories and Pics)

Social: Facebook \ YouTube \ Twitter \ Tumblr \ Pintrest \ RSS Feeds