1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Flash drive is write protected - can't work out how to unprotect

Discussion in 'Hardware' started by chookers, Dec 10, 2007.

  1. chookers

    chookers Staff Sergeant

    Hi all,

    I was copying 2 files from 1 computer (98SE) to a flash drive plugged into another (XP Pro), one of over 500mb and the other over 200mb. My son was playing a flash game on the XP. The flash drive had been shared about 15 minutes before this and the XP had not asked to be restarted. The flash drive is an Imation 1Gb Cool.

    Somewhere between the transfer of the 500Mb file and starting on the next one, the XP computer restarted without warning.

    When it restarted, I tried again to copy the 200mb file but was told the disk was write protected. We tried to check that all sharing and permissions were correct but discovered that sharing had disappeared from the context menu. Poking around didn't find anything wrong so I decided to run the Network Setup Wizard, and found that we needed to change the workgroup name back to what is was before and turn on file sharing again. This done, I found that the shares that had been set up still existed, including the flash drive.

    However, the flash drive is now write protected and I can't find any way of changing this.

    Help! I have no idea where to go next and have already spent a frustrating afternoon with the computer that the flash drive was getting files from either struggling to network or crashing. It's taken me about 2 hours or more to this point and I still haven't done, nor know how to get the write protection off, so I'm hopeful that someone will be able to figure out what I should do to fix it.

    We run security software on all our machines and have a modem with router so I don't think we're looking for malware. But I could be wrong, I know! :)

    I'm sure there will be things that I left out that people want to know such as Ad-aware, Spybot, Zone Alarm Free (oops, forgot: it was playing up badly and had to be removed and hasn't yet been replaced), AVG Free. Anyway, anything else I forgot, please ask. I feel a bit brain stupid and frustrated after my battles this afternoon and don't think I've included everything that should be.

    Thanks people.
    Last edited: Dec 10, 2007
  2. dlb

    dlb MajorGeek

    I did some research at Imation's web site and found out nothing. You should probably contact their tech support or customer service and explain to them what happened. I think the device may be damaged from the PC restarting in mid file transfer...
    Here's a link that may help: http://www.imation.com/support/products/flash_devices.html
    You could try formatting it using Imation's Disk Management Software, available at the link above...
  3. Plaphon

    Plaphon Specialist

    Some flash drives have special jumpers wich set the write protection. If there is such thing on your drive try to move it.
  4. chookers

    chookers Staff Sergeant

    Thanks both of you. We've struck out but got a resolution - the drive is bung and needs replacing. I much appreciated the suggestions; I was fairly frazzled by the time the drive ended up write protected and just couldn't find any further strategies to try. For the sake of others looking for a solution, I'll give you a run down of the steps in getting to the solution.

    I had already thought of what Plaphon had said and although I was absolutely certain that there were no buttons on it and sure that I had checked last night, I checked anyway. I have another drive which has a slide switch to write protect it but since when one is frazzled it's easy to overlook what you already know, that suggestion was much appreciated Plaphon. So it was back to Plan B. (Plan A was try everything that Windows allowed you to do and I'd tried all that before posting. :) )

    Plan B being download and try a drive manager, I followed the link that dlb gave me and found that last night in my weary state I had overlooked a link to a FAQ talking about drives becoming write protected (one reason I ran out of things to try). That link said the same things as you guys, check for the lever or try the software. So I went looking for the software and couldn't find software specific to our disk. I rang the place where I bought it to ask if there were any other names it might have and they said not, but told me to ring Imation Australia support. I had no idea we had an Imation office over here (missed that link in Google too!) and Imation pointed me to the drivers and Drive Manager for the Cool models which seem to only be on the South Asia site: http://www.imation-southasia.com/support/downloads_new.html

    Using the drop down box under the heading "Flash Drive" I downloaded the "flash drive formatting tools", unzipped and ran the program and the drive was supposedly formatted; the message said successfully completed.

    On putting the disk back, Windows said that the drive wasn't formatted and offered to format it. The instructions said "If this formatting tool fails, you may have a faulty drive." and the program finished by saying "Formatting has completed successfully. Please remove the USB flash drive and reinsert it." and hadn't said anything about whether I should expect Windows to have to format it after that. Didn't seem likely but I had nothing to lose so I tried it. That failed too, so I rang Imation back and they said it must be faulty and to get it replaced.

    While I was speaking to them, I asked about the possibility of the disk being damaged by the computer or vice versa and from the sequence of events that I had, he suspects that the disk was at fault, rather than the computer restarting having damaged the disk. It seems it caused the computer trouble and not that the computer trouble damaged the disk.

    So thus ends the story and my husband is going to take it back for me in a little while.

    Thanks again guys. Your help was much appreciated and put me back on track.
  5. yaseen

    yaseen Private E-2

    please help my
    my 1 gb flash is wirte protected and i can't perform format to it.
  6. Sojaner

    Sojaner Private E-2

  7. hrlow2

    hrlow2 MajorGeek

    Figure that after 1 1/2 years that they have solved it or given up.

    Welcome to Major Geeks.
  8. Sojaner

    Sojaner Private E-2

    This thread is one of first google results, so others may come here and look for some sort of solution and I think the link above is the solution to most of their problems. :)

    Thanks for your greetings. :)
  9. plodr

    plodr Major Geek Super Extraordinaire

    This should also be noted from the site
    I would recommend using them on an XP system only.
    People might be running newer versions of windows so the above should not be attempted.
  10. Sojaner

    Sojaner Private E-2

    That's a recommendation and is good to keep in mind, but I used it on a Windows 7 Sp1 Ultimate edition fully updated and had no problem at all, just use "Run as administrator..." option.
    It worked like a charm for me.:)

Share This Page

MajorGeeks.Com Menu

Downloads All In One Tweaks \ Android \ Anti-Malware \ Anti-Virus \ Appearance \ Backup \ Browsers \ CD\DVD\Blu-Ray \ Covert Ops \ Drive Utilities \ Drivers \ Graphics \ Internet Tools \ Multimedia \ Networking \ Office Tools \ PC Games \ System Tools \ Mac/Apple/Ipad Downloads

Other News: Top Downloads \ News (Tech) \ Off Base (Other Websites News) \ Way Off Base (Offbeat Stories and Pics)

Social: Facebook \ YouTube \ Twitter \ Tumblr \ Pintrest \ RSS Feeds