1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

hard disk locked, enter user password

Discussion in 'Hardware' started by bsa492, Feb 27, 2010.

  1. bsa492

    bsa492 Private E-2

    Have HP 2133 netbook with 4GB solid state SATA drive, 512 MB RAM, running SUSE Linux. Was running fine, but failed to boot to Linux a few days ago. The monitor shows the following at the time of failure...

    AMIBIOS(C) 2006 American Megatrends, Inc.
    BIOS Date: 04/02/08 09:56:47 Ver: 08.00.14
    CPU : VIA C7-M Processor 100MHz
    Speed : 1.00 GHz

    BIOS Ver: F.02 EC Ver: 07:11
    F10 = ROM Based Setup
    Press F12 if you want to boot from the network
    F9 = Boot Device Menu
    Press F9 to boot from the Restore Partition
    Initializing USB Controllers .. Done.
    448MB + 64MB

    Auto-Detecting 3rd Master..IDE Hard Disk
    3rd Master : SMI MODEL 20080308
    Ultra DMA Mode-4, S.M.A.R.T. Capable and Status OK
    Hard Disk locked, enter user password:

    There has not been a password on the hard drive and the BIOS password screen indicates none present. No power-on password set. No strangers or pranksters have had access to the netbook.

    We have tried all of the master passwords, as found on web sites across the web.

    We have removed the hard drive and reseated the connections.

    We have tried to boot the system from an external USB CD drive (no internal drives on this box), with UBCD4WIN. Windows appears to boot, but fails (BSOD) with a hard drive error (0x7D).

    Removed the hard drive and installed it in a USB case. Tried to add it to a Windows XP system, but Windows could not find the drive (remember it is a Linux boot disk). Tried to reboot the Windows system with this USB drive plugged in, but the Windows system would not POST.

    Are currently considering replacement of the solid state hard drive with new SATA 2.5" 40GB drive, but some information I have read indicates that when this condition has been reached, there is a risk that a new drive may become "locked", too, due to residual in the BIOS.

    Looking for ways to determine if the drive can be salvaged or, if the drive is junk, whether it is safe to try installing a new SATA drive and reloading an OS.


    Thanks, much.

  2. bullchit

    bullchit Private E-2

    for Linux


    Linux unlock

    For those of us using Linux, we have written an isd200 driver patch for unlocking the disk. This modified driver will automatically unlock the disk when you connect your Archos via USB, so you don't have to do anything special. Apply the patch to a 2.4.18 linux kernel tree.
    Still locked?

    If the above suggestions don't work, here's some background info about the disk lock feature:

    The disk lock is a built-in security feature in the disk. It is part of the ATA specification, and thus not specific to any brand or device.

    A disk always has two passwords: A User password and a Master password. Most disks support a Master Password Revision Code, which can tell you if the Master password has been changed, or it it still the factory default. The revision code is word 92 in the IDENTIFY response. A value of 0xFFFE means the Master password is unchanged.

    A disk can be locked in two modes: High security mode or Maximum security mode. Bit 8 in word 128 of the IDENTIFY response tell you which mode your disk is in: 0 = High, 1 = Maximum.

    In High security mode, you can unlock the disk with either the user or master password, using the "SECURITY UNLOCK DEVICE" ATA command. There is an attempt limit, normally set to 5, after which you must power cycle or hard-reset the disk before you can attempt again.

    In Maximum security mode, you cannot unlock the disk! The only way to get the disk back to a usable state is to issue the SECURITY ERASE PREPARE command, immediately followed by SECURITY ERASE UNIT. The SECURITY ERASE UNIT command requires the Master password and will completely erase all data on the disk. The operation is rather slow, expect half an hour or more for big disks. (Word 89 in the IDENTIFY response indicates how long the operation will take.)

    for windows

    HDD Unlock Wizard is a user-friendly application which allows you to easily remove HDD password. IDE and SATA hard disk drives are supported. Both User and Master password can be removed. Please note that while unlocking, HDD Unlock Wizard will erase and re-certify the drive, meaning to say all data in the disk is lost and not recoverable. HDD Unlock Wizard incorporates proprietary unlocking algorithms which allow removing an unknown HDD password and making hard drive usable again. Download HDD Unlock Wizard now! 2.8MB only!

    It may not be possible to recover the hard drive password or to unlock it; however, it is possible to remove the password together with the data, thus making your hard disk accessible and usable again.
  3. pclover

    pclover MajorGeek

    I would pull the CMOS battery out for 30 seconds and then put it back in to try and clear the password.
  4. bullchit

    bullchit Private E-2

    its a hard drive lock not a bios...completely different thing
  5. plodr

    plodr Major Geek Super Extraordinaire

    Doesn't this look strange to you?
    Your netbook only has one hard drive, a 4GB ssd, which is SATA.
  6. bsa492

    bsa492 Private E-2

    I actually intended to highlight that fact, but I was rushed to leave the house and forgot that point. Yes, there are 2 points that I don't understand in this: 1) as you say, the hard drive is SATA; I don't know that there are any IDE devices on-board (or even an IDE header on the system board); and 2) there is only one (1) hard drive, yet it says 3rd master.

    For this boot, there are no USB devices plugged in, either. Any ideas as to what it is trying to tell us?
  7. satrow

    satrow Major Geek Extraordinaire

    The "SATA" drive may be a misnomer if it's anything like the 8GB in my Acer netbook :), mine is a 1.8" IDE ZIF connected drive, some may then be connected via a SATA or USB adapter, others may have a mini PCie connector.

    This is the SATA connector for the HP, nearside connects to the 'board, farside to the NAND/SSD drive. More details may be available by perusing this HPminiguide or similar sites.
  8. bsa492

    bsa492 Private E-2

    Thanks for the suggestion, pclover. I had not tried that, yet, because I found several references that indicate the status of drive passwords are kept in a "security chip", separate from the bios settings and that disconnecting the battery would have no effect, but it's worth trying.

    I removed the CMOS battery for about 10 minutes, which I will tell you is not easy on this particular box. This is an interestingly cheap system, in that the battery is not your typical "button" battery, but is one connected with a pair of wires and a "plug" type connector. The manual points out that the battery is attached to the system board with double-sided tape. As it turns out, there are lots of things taped together inside, including tape across the entire bottom of the mobo.

    A perhaps more interesting point is that booting results in the same messages, but the security panel in the bios now shows:
    "Notebood Hard Drive Password :Enabled".

    Another reference on the web suggested that the password might be null; "just press enter". So, I tried that and the password is not null.

    Also, satrow suggested that the SATA reference was a red herring.

    Thanks for the suggestion, but it really is a SATA set of connectors on the SSD board. The HP 2133 does have a unique connector to bridge from the SSD to the system board. The connector is a mylar ribbon with both the SATA power and SATA data paths on one end and a proprietary tiny, retangular plug on the other end that fits into a socket on the mobo. I tested connecting typical SATA power and data cables from a desktop computer to the SSD board and they fit.

    Thanks for the link to the miniguide site. I wasn't aware of that one. I'll browse it tomorrow to see if there are any helpful suggestions for this issue.

    Does anyone have experience using a program called atapwd.exe? I found it while googling my issue. I do have a Windows desktop with a mobo that has SATA connectors, although I've never loaded the bios that supports SATA on that box. Would it be worth trying to use that system and atapwd.exe to reset the drive firmware and remove the password settings from the drive?

    Last edited: Feb 28, 2010
  9. collinsl

    collinsl MajorGeek

    Just FYI the #3 IDE may be a CD-ROM drive if you have one.

    If the netbook is under warranty, at this point I would advise sending it back.
  10. bsa492

    bsa492 Private E-2

    No CD or DVD drive on this unit. This is one of those REALLY small, light-weight computers. There is the tiny SSD hard drive (4 GB), 512 MB RAM, 2 USB ports, VGA port, headphone/microphone jacks, RJ45 ethernet, 802.11g wireless, a DC power jack, security slot, limited PCMCIA slot, and an SD slot. When it works, it starts up almost instantly.

    Unfortunately, the warranty was short and expired 9 months ago. Kathy (the owner) tried BestBuy to get it unlocked and they told her they could send it in, but it might cost more than a replacement at about US$225.

    If I had some confidence that we could just replace the SSD with a 40GB spinning disk and load an OS, I would do that. I'm just very nervous about the potential for a security chip that would lock a new HD.:confused

Share This Page

MajorGeeks.Com Menu

Downloads All In One Tweaks \ Android \ Anti-Malware \ Anti-Virus \ Appearance \ Backup \ Browsers \ CD\DVD\Blu-Ray \ Covert Ops \ Drive Utilities \ Drivers \ Graphics \ Internet Tools \ Multimedia \ Networking \ Office Tools \ PC Games \ System Tools \ Mac/Apple/Ipad Downloads

Other News: Top Downloads \ News (Tech) \ Off Base (Other Websites News) \ Way Off Base (Offbeat Stories and Pics)

Social: Facebook \ YouTube \ Twitter \ Tumblr \ Pintrest \ RSS Feeds