1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Hard drive disappeared from Windows

Discussion in 'Software' started by dlb, Apr 30, 2012.

  1. dlb

    dlb MajorGeek

    I'm working on a custom PC with 3 hard drives: it has a dual boot with Win7 X64 on drive C and WinXP on drive D, then a data storage drive as drive E. However, drive E now does not show up anywhere in Win7; not in Device Manager, not in Disk Management, not in My Computer. It does appear in the BIOS, and I'm running the Seagate factory diagnostic on the drive right now so obviously that program sees the drive. The owner of the PC messed up the dual boot configuration and tried to fix it via a repair install of WinXP, then they bailed out so the WinXP drive does not boot to a desktop so I can't check to see if drive E appears in WinXP. There was also a drive F but it has completely failed and has been removed from the PC. I have connected drive E to other PCs and it came up with all data intact. The strange thing is that drive E actually DID appear in My Computer in Win7 once today, just once, then it vanished on the next reboot and that was 15+ restarts back..... any suggestions?

  2. Goldenskull

    Goldenskull I can't follow the rules

    Are these Drives Sata Or ATA.
  3. dlb

    dlb MajorGeek

    Oh - duh :-o they are all SATA drives, there is no RAID, the "SATA Mode" setting in BIOS is set to IDE. All drives are different sizes but I know that has nothing to do with it.... C: is a 300gb WD Raptor, drive D is an older 160gb Seagate, and the storage drive E is a 500gb Seagate....
  4. dlb

    dlb MajorGeek

    The drive passed the diagnostic 100% as I assumed it would. Here's some weirdness: when I boot to a boot CD like the UBCD4Win which is built on the XP PE image, the drive appears and is browse-able, but if I boot to a boot CD built on the Win7 PE image, the drive does NOT appear! However, if I remove the drive from the PC and connect it via USB to either a Win7 PC or a WinXP system, it appears and is browse-able on both; when connected via USB to the PC in question it also appears and is fully functional!! I have tried the drive in other SATA ports on the motherboard w/o any luck. It's just crazy that it will not appear on this PC when connected via SATA.... I'm going to connect it via SATA to some other PCs and see what happens....
  5. dlb

    dlb MajorGeek

    OK- here's a new development.... with the drive connected via SATA, when I go to the Device Manager, click on Action, select "Scan for hardware changes", the drive is almost instantly recognized and added as a functional drive. However, it doesn't survive a restart; after each restart, I have to go back to the Device Manager and scan for changes in order for the drive to appear. I've checked the Windows services and other startup programs and I see nothing out of the ordinary. There are some Western Digital services installed and running, so I'm going to try disabling them just to see if that makes a difference.

    Any thoughts on why I have to run "Scan for hardware changes" in the Device Manager after each reboot to get the drive to be functional?
  6. Goldenskull

    Goldenskull I can't follow the rules

    If your installing Xp i would just do a Fresh Reinstall and get it over with sounds like too much of a headache to me.

    Well the size of the drives should not really matter as long as you have enough space for windows to install it on.

    Did you try to swtich the Drives to different ports on the main board
  7. dlb

    dlb MajorGeek

    I'm not messing w/ the XP install.... yeah, I tried all the ports except for SATA-0 and SATA-1 where the C and D drives are (don't want to mess w/ those since it's dual boot).

    BUT . . . SUCCESS!!!


    Here's what I did: went to the Device Manager, did the "Scan for hardware changes" to get drive E to recognize. Then I went thru the Device Manager and uninstalled both optical SATA drives (drives G and H), then I deleted drive E. All the Western Digital software is disabled (the startup entries and services). I powered down and unplugged the power cord. I unplugged all SATA devices except for drive C and D. I booted to Win7 with only my 2 main hard drives connected to the SATA ports; all other SATA devices are not connected. I waited a minute and powered down again. Then I connected drive E to one of the SATA ports that previously was connected to a DVD drive; then I connected one DVD drive to a port where it had not yet been connected; I powered up and let Windows install the "new" devices. I powered down and connected the 2nd DVD drive; I powered up again - and BAM!!! drive E is still listed and accessible. I have since restarted 3-4 times and so far all is well. I think removing all the entries from the Device Manager combined with moving all the devices to different SATA ports and then connecting one DVD drive at a time was the kicker. I have no idea if disabling the Western Digital software and services made a difference, but it's going to remain disabled since everything seems to be working now.

Share This Page

MajorGeeks.Com Menu

Downloads All In One Tweaks \ Android \ Anti-Malware \ Anti-Virus \ Appearance \ Backup \ Browsers \ CD\DVD\Blu-Ray \ Covert Ops \ Drive Utilities \ Drivers \ Graphics \ Internet Tools \ Multimedia \ Networking \ Office Tools \ PC Games \ System Tools \ Mac/Apple/Ipad Downloads

Other News: Top Downloads \ News (Tech) \ Off Base (Other Websites News) \ Way Off Base (Offbeat Stories and Pics)

Social: Facebook \ YouTube \ Twitter \ Tumblr \ Pintrest \ RSS Feeds