1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Help! My external hard drive says it needs to be formatted

Discussion in 'Hardware' started by ADNUP, Jul 27, 2012.

  1. ADNUP

    ADNUP Private E-2

    My Western Digital EHD wasn't showing up in My Computer. So I right clicked and change something in device manager(sorry don't remember what). Now when I plug it in it says it needs to be formatted first.
    There are a ton of the wife's movies on there, please help :banghead
  2. plodr

    plodr Major Geek Super Extraordinaire

    Without that key bit of information, it is impossible to guess what you have done.

    Get someone who knows linux to run a live CD and grab the files from the external hard drive. Make sure you have another drive with enough room to store them on.
  3. Speculant

    Speculant The Confused One

    I've ran into that before, usually when I unplug a storage device that is still being used. Trying a Linux live CD sounds like a good idea to get your files back.
  4. ADNUP

    ADNUP Private E-2

    OK, so its been six months and I havent tried anything. You can see here that its Drive E but there is no file system.
    Can I create another partition and move the files from one side to the other? It looks like I have about 500 GB worth of data on the drive. I used Partition Find and Mount, had it mount to drive letter F and I can see the folders. Is this possible? BTW I do not have another drive large enough to transfer the files

  5. ADNUP

    ADNUP Private E-2

    Sorry but another question. If I make a disk image and put it on another drive will the files be accessible?
  6. sach2

    sach2 Major Geek Extraordinaire

    Usually it is just Windows that has a problem seeing the partition. You can try Testdisk to rewrite the partition table.

    Start Testdisk
    Create is highlighted so hit <enter>
    Select the External drive <enter> to Proceed.
    Intel is highlighted so hit <enter>
    Analyse <enter>
    Quick Search <enter>
    Now there should only be one partition in the results. Hit P to list the files.
    If it shows your files then hit Q to exit the file list.
    Hit <enter> to continue.
    Use the arrow keys to get to Write and hit <enter>.
    Say yes.

    Remove external and plug it back in. See if Windows gives it a drive letter in My Computer.

    There is no harm done if it doesn't change anything, your files are all still there but we would need to try another program to rewrite the partition table.
  7. sach2

    sach2 Major Geek Extraordinaire

    Another program that might work is Partition Wizard. You would click on the external HD where it says its disk #. Then select partition recovery. Use the quick scan and Full disk option.
    Again, it should show only one partition in the list. Double-click the partition and see if it lists your files. If it does then tick the box and hit Finish. You may have to hit Apply in the main window. See if Windows now recognizes the external and assigns a drive letter so you can access the files. Guide: http://www.partitionwizard.com/help/partition-recovery.html
  8. davismccarn

    davismccarn Specialist

    Easus Partition Recovery is freeware and an excellent program; but, there are two possible reasons for your original problem. Either you forced a removal at a very bad time (while Windows was writing to the drive) or the hard disk is in the early stages of failing. You really need to get another copy of those files onto another drive!
  9. ADNUP

    ADNUP Private E-2

    Thanks sach2, I tired both and neither has worked.

    Do you think if I convert if from FAT32 to NTFS that would work?

    One other note when I open My Computer, with the ext hd plugged in, it runs rrrreeeeaaallllyyyyy slow

    I can see the files so I still have hope....:(
  10. sach2

    sach2 Major Geek Extraordinaire

    I have never had testdisk fail me. Does your Disk Management still look the same with no file system?

    I wouldn't convert it until we figure out the partitions.

    You could give Easeus a try. It looks the same as PW but Easeus is reliable software (I only use PW because it has a free bootable CD.

    I'll think about it but no other software jumps to mind. A Linux CD/USB would let you copy the files. Assuming it sees the partition which it probably will. It seems only Windows itself can't see it since both testdisk and PW and no problems.
  11. ADNUP

    ADNUP Private E-2

    EaseUS says its UNFORMATTED


    And Partition Wizzard says its FAT32

  12. davismccarn

    davismccarn Specialist

    Many of the external hard drives are partitioned as FAT32 so they will be universally compatible; but, your statement about "really slow" reinforces my thought that the drive is failing. Please get those files copied somewhere else, ASAP.
  13. ADNUP

    ADNUP Private E-2

    Ok, I bought another ext hd. Coping USB to USB is VERY slow, is there a better way to copy the files over?
  14. davismccarn

    davismccarn Specialist

    Most modern drives are in the 80-125MBps transfer range; but, USB2 limits it to about 12. USB3 is 10 times faster and eSATA runs at the drive's speed. You do not want to take apart that WD as it, apparently, may have encryption hardware in between the drive and the USB.
    Making sure neither drive is using an external USB hub and that each is on a different controller on the system side is as fast as you can make it go.

Share This Page

MajorGeeks.Com Menu

Downloads All In One Tweaks \ Android \ Anti-Malware \ Anti-Virus \ Appearance \ Backup \ Browsers \ CD\DVD\Blu-Ray \ Covert Ops \ Drive Utilities \ Drivers \ Graphics \ Internet Tools \ Multimedia \ Networking \ Office Tools \ PC Games \ System Tools \ Mac/Apple/Ipad Downloads

Other News: Top Downloads \ News (Tech) \ Off Base (Other Websites News) \ Way Off Base (Offbeat Stories and Pics)

Social: Facebook \ YouTube \ Twitter \ Tumblr \ Pintrest \ RSS Feeds