1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Help with drivers, please!

Discussion in 'Software' started by Abela, Apr 9, 2009.

  1. Abela

    Abela Private E-2


    A friend gave us an eMachine W3107 computer but no discs. My husband reformatted the computer with Windows XP. Everything seems to be working properly except for the ethernet. I went to this site: http://www.emachines.com/support/product_support.html?cat=Desktops&subcat=W Series&model=W3107 and downloaded the BIOS Flash Utility for K8MC51G Motherboard and also the NVIDIA nForce chipset and network drivers for FIC K8MC51G motherboard to a disc but neither of them worked.

    I am assuming that the network card is an on board type. When I plug the ethernet cord into the back of the computer, it lights up as it should.

    As I said, we cannot access the internet on this computer so I have been searching the net on my computer left and right for a solution. Any suggestions?
  2. DavidGP

    DavidGP MajorGeeks Forum Administrator - Grand Pooh-Bah Staff Member


    If you open Device Manager up, are their any yellow ! marks by any devices, if so what are they next too?

    Double check in the BIOS that the date and time are correct and the network/ethernet ports are nto disabled (just a check as likely they are not but with a BIOS flash as you have done, it may have reset some settinsg)

    Has any security software been installed, mainly has a 3rd party Firewall (ZoneAlarm, PCTools, Norton, McAfee etc)? if so disable it to test the internet connection, if it works then you need to allow the network adapter in the firewalls settings.
  3. Abela

    Abela Private E-2

    Thanks, Halo.

    Everything in the BIOS is as it should be.

    Yes, in the device manager there are several yellow question marks:
    Multimedia audio controller
    other PCI Bridge Device
    Video controller (VGA Compatible)

    No firewalls or anti virus programs yet.
    Last edited: Apr 9, 2009
  4. DavidGP

    DavidGP MajorGeeks Forum Administrator - Grand Pooh-Bah Staff Member

  5. Abela

    Abela Private E-2

    When I tried clicking on your link, I was prompted for a username and password. I tried going to the FIC site and downloading from there but I get this error message:
    550/1a12/1a12/mbdriver/chipset/nvidia/winxp: The system cannot find the path specified.
  6. Abela

    Abela Private E-2


    I just tried running the network setup (after I found it!) and it said there was no hardware found. Apparently the on board networking card isn't functional and I'll need to buy another one. Thank you for your help and sorry if I wasted your time!
  7. DavidGP

    DavidGP MajorGeeks Forum Administrator - Grand Pooh-Bah Staff Member


    Right click the Zip file on that FTP site and choose Save Target As, worked that way for me just now, if not then reading the specs on that motherboard its using the Nvidia 410/430 6100 chipset and its here
  8. DavidGP

    DavidGP MajorGeeks Forum Administrator - Grand Pooh-Bah Staff Member


    No problems, not wasted my time at all, pitty the onboard network is broken, hope the addon card does the trick.

Share This Page

MajorGeeks.Com Menu

Downloads All In One Tweaks \ Android \ Anti-Malware \ Anti-Virus \ Appearance \ Backup \ Browsers \ CD\DVD\Blu-Ray \ Covert Ops \ Drive Utilities \ Drivers \ Graphics \ Internet Tools \ Multimedia \ Networking \ Office Tools \ PC Games \ System Tools \ Mac/Apple/Ipad Downloads

Other News: Top Downloads \ News (Tech) \ Off Base (Other Websites News) \ Way Off Base (Offbeat Stories and Pics)

Social: Facebook \ YouTube \ Twitter \ Tumblr \ Pintrest \ RSS Feeds