1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

How do I rebuild/repair a RAID 0 Array

Discussion in 'Hardware' started by ITgirl, Jun 26, 2009.

  1. ITgirl

    ITgirl Private E-2


    The RAID 0 Array on a Dell System 9100 with hardware raid controller Intel Matrix Storage Manager option ROM v ICH7R. I can enter the RAID utility but there is no repair or rebuild option. The following info is shown at boot.

    Raid Volumes:
    ID Name Level Strip Size Status Bootable
    0 Array Raid 0 (Stripe) 128 KB Failed No

    Physical Disks:
    Port Drive Model Serial Size Type/Status
    0 WDC WD1600JS-75M 149.0GB Non Raid Disk
    2 WDC WD1600JS-75M 149.0GB Member Disk

    When I press <CTRL+I> I get the option to:
    create an array or delete an array....there is no option to repair or rebuild.

    I came across the following suggestion. Please let me know if any of you thinks this will work:

    "I FIGURED IT OUT.... I searched google for over 6 hours and read a ****load of articles but NONE of them said you can fix a RAID 0 array if it got an error.

    Well I just fixed my RAID 0 array - you can only do this if both the hard discs in the raid 0 array work properly - which uses FastTrak raid controllerby rebuilding it.

    1. First you gotta delete the array(it will ask u if u want to delete the bootsector, say NO because this will delete all the files from your harddiscs). Before deleting it make sure you write down the stripe number if you can't remember it in your head.

    2. Then you have to reboot, and choose 'Define Array' option. Rebuilt the array using the same stripe number as the array you had before had. When it asks you if you want to format the drives say NO.

    3. After rebuilding the array you have to reboot again and windows will start loading. Before you enter windows it will do a system error check to check for bad sectors etc. I did it and didn't get any bad sectors. When the system disc check is complete windows works just as it did before your array crashed!

    I hope this can help other people who have gotten/will get the same problem as I did. I've gotten this problem once already and lost over 100 gb of data because everyone said that I'm screwed, well they're wrong!
    My hardware was fine. It was the FastTrak controller that screws up when you touch/unplug a SATA cable."

    Your help as always is greatly appreciated.

  2. ITgirl

    ITgirl Private E-2

    Thanks to all of you for looking at my post. As it turns out I deleted the array but one of the two harddrives was completely dead so impossible to rebuild the array. I'll never know if the method suggested in my previous post works and hope I never have to find out.
  3. carey934

    carey934 Private E-2

    I was installing RealVNC on a new clients server. They have three servers all running Windows 2000 and I was assessing what work they were going to need and how i was going to back them up. I installed RealVNC on the other two servers with no problems, as expected, but when I went to install RealVNC on the third server, I got a message in the system tray that the drives became disconnected and then, a few seconds later, BSOD. I shut it down, but when I turned it back on, the machine would not POST. So I replaced the power supply and the machine POSTed but the RAID controller said the arrays were "offline". Now I was in panic mode. I took the server back to my office and called Promise and their technical support said it appears the machine has two RAID 0 arrays, using Western Digital Raptors and that the only way to recover the array was to send the drives in to a data recovery specialist. Well, that's several thousands of dollars and takes time we don't have. I removed each drive and put them, one by one, into my BlacX SATA-to-USB adapter and ran Western Digital diagnostics on all of them and they all passed. I thought if I could clone the drives to 'working' drives that might solve the problem, but Acronis doesn't recognize their format out of the RAID controller, so that was a bust. I thought the controller itself might be bad or need resetting, so I put two spare sata drives I had laying around my office into it and created an array and installed Windows XP with no problem. Put the old drives back in, and they still didn't work. Then I did some Google searching and found this post within 90 seconds. I tried what you suggested with the second array first (data only) and it worked! So I backed it up and then did it to the first array next, and it worked! It's booted back into Windows 2000 server as we speak! IT GIRL, if I ever meet you in person I'm going to give you the biggest hug ever!!! You are amazing! THANK YOU! THANK YOU! THANK YOU! You're a freakin' GENIUS!

    Now, why this clients previous technician configured the server that holds 60GB of their most important data with two RAID 0 arrays instead of a RAID 5, I'll never know. Especially since the extra performance won't make a difference since they only use the servers for file servers and nothing more. They don't even have a domain, host their own email or web page. It's just an over-priced NAS and the gigabit ethernet isn't going to transfer the data any faster with RAID 0 then it will with RAID 1, RAID 5, RAID 1+0 or even a single hard drive. The bottleneck is the ethernet adapter. Its like getting a Ferrari and ONLY driving it during rush hour! What was this guy thinking?! Anyway, I'm seriously indebted to you not only for saving this data and configuration, but for this education. Now I know. Thank you!!!
  4. carey934

    carey934 Private E-2

    I have a new client who I was evaluating their support and backup needs. They have three Windows 2000 servers. I installed RealVNC on the first two servers and when I went to install RealVNC on the 3rd server, I got a message in the system tray saying the hard drive controller was disconnected and then it went to a BSOD. I shut it down but when I turned it back on, it wouldn't post. Put a new power supply in and it posted, but said the array was 'offline'.

    The configuration was a Promise FastTrak TX4200 with 4 Western Digital Raptors configured as two striped arrays. It said both arrays were offline. I was pretty freaked out and called Promise technical support and they said because it was RAID 0, there was nothing I could do but send the drives in for professional data recovery services, which my client does not have the time or money to do. I removed each drive and placed them, one-by-one, in my BlacX SATA-to-USB adapter on my main PC in my office and ran Western Digital Drive Diagnostics on all of them. They all passed! I took two spare SATA hard drives I had laying around my office and plugged them into the server and configured them as a RAID 0 array, just to see if the controller was bad or not. It worked just fine and I installed Windows XP. Then I plugged a pair of the original drives back in, and they still registered as OFFLINE. I did a Google search and within 90 seconds, found your post and tried it and it worked to recover both arrays perfectly! Thank you IT GIRL!!! You are a genius!

    Now, why this clients previous tech would create two RAID 0 arrays and not one RAID 5, when this server holds the most important data for the whole company, I'll never now. But once I image the system (now that its working) I'm going to make it a RAID 5 like it should have been from the beginning. Without finding your post, I don't know what I would have done. I owe you!!!
    Last edited: Nov 2, 2010
  5. The13thSon

    The13thSon Private E-2

    Hi ITGirl

    I don't know if you're still on this site... since the last post was a year ago... believe it or not, nothing has changed. I've been searching everywhere for a problem like mine, this has been the first post I've seen in 2 days that speaks of RAID-0 with a drive missing from the array.... but here's my problem:

    I don't have a "FastTrak Raid Controller" ... I'm using Intel Rapid Storage Technology (v. and the problem is the same. I have 1 drive sitting outside the array and one sitting inside the array... but the Array doesn't want to recognize the other drive.

    I'm even more worried than you, in the sense that I have two 2TBs in RAID 0, and about 2.5TB is filled... This is a lot of data... I'm very scared about taking a step in any direction... but I'd have to build up the courage and do something soon...

    The software I have and the Option ROM (where I click CTRL+I) shows "Create" and "Delete" not Rebuild or repair.

    Anything will help... I may have to email you, considering nothing has been posted here for a year exactly :p.

    Oh yes, here's an image of my current setup:

    Something else I noticed:
    - the 0TB "missing" drive has a Serial No.: D-WMAY01444266:0
    whereas the drive sitting outside the array has Serial no: WD-WMAY01444266

    Definitely looks like something fishy.
    Anything you can help with will be much appreciated.

  6. harrystone

    harrystone Private E-2

    ITGirl - Not sure if you're still around but - Thank you! I thought that I was done for, I really did. Your solution definitely saved me hours of stress but given my propensity to impatience and panic measures I'm glad that I found your solution first as I'm sure I would have ended up making things worse and losing everything.

    One tip for anyone in the same situation - I have 2 disks that make up a stripe and the first time I tried this it didn't work because of the order that I selected the disks in. It said my stripe was healthy but didn't boot, I tried swapping the order of the disks in the stripe and it booted.

    ITGirl - Marriage? Children? Just say the word.

Share This Page

MajorGeeks.Com Menu

Downloads All In One Tweaks \ Android \ Anti-Malware \ Anti-Virus \ Appearance \ Backup \ Browsers \ CD\DVD\Blu-Ray \ Covert Ops \ Drive Utilities \ Drivers \ Graphics \ Internet Tools \ Multimedia \ Networking \ Office Tools \ PC Games \ System Tools \ Mac/Apple/Ipad Downloads

Other News: Top Downloads \ News (Tech) \ Off Base (Other Websites News) \ Way Off Base (Offbeat Stories and Pics)

Social: Facebook \ YouTube \ Twitter \ Tumblr \ Pintrest \ RSS Feeds