1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

how do I troubleshoot my wireless connection?

Discussion in 'Hardware' started by junkforaaron, Nov 11, 2007.

  1. junkforaaron

    junkforaaron Private E-2

    my integrated wireless adapter in my notebook has stopped working. how do I determine whether this is a software or hardware problem?

    gateway notebook
    win XP sp2
  2. lbmest

    lbmest MajorGeek

  3. junkforaaron

    junkforaaron Private E-2

    well, the device does not show up in the device manager. It used to show up as a Broadcom adapter. It has been out for months.

    My notebook:

    The wireless adapter:

    I downloaded the intel wireless drivers and it said a newer version was already installed and did not let me continue.

    i have downloaded the Broadcom software from the Gateway site, but nothing happened.

    I restarted, and a blue screen that flashed briefly after the login dialog and restarted the computer. I had to press F8 and go to "last known good configuration" to use the computer again.

    (obviously) the adapter doesn't turn on and off when i press Fn+F2.

    also: when it resumed from standby earlier today, it indicated a wireless connection in the system tray. I clicked on it and it showed my router as connected. It was not usable however. in the properties dialog it had sent/received 9 packets. The Broadcom adapter was listed as working properly in the device manager. I restarted the computer and it was all gone again. no connection, no adapter.

    so..... what now?
  4. lbmest

    lbmest MajorGeek

    So the Intel Pro does show up in Device Manager?
    If it does, right click on the Intel, choose uninstall and reboot. This should allow the computer to reload the drivers.
  5. junkforaaron

    junkforaaron Private E-2

  6. lbmest

    lbmest MajorGeek

    Yet, you did have a wireless icon at one point.
    Sounds like either the adapter is going out or you have loose connections.
    I've never been in a gateway laptop so someone else may be able to tell if you can possibly check the connections.
  7. junkforaaron

    junkforaaron Private E-2

    that is a possibility. how would I diagnose that?

    And even when the icon showed up, it didn't work.
  8. Monster

    Monster Guest

    I searched for a solution to that problem, and found a few weird ones...

    *AC power cables crossing over data cables can sometimes seriously mess-up data streams...

    *Sometimes the center-wire in the cable connector isn't making a good connection to the splitter or modem...

    *Old router configs can do this...

    *Maybe the cable connection at the pole is faulty...

    *Maybe the provider cut you off accidentally, or without warning...
    It can happen to a stale account around this time of year, when some providers do a major cleanup.. and should they delete an old account that hasn't been used in 12-months, sometimes that action can also shut all your active connections down with it... 'Happened to me... Took us three days to figure it out...

    *Spills on connectors can cause green corrosion, and failed contacts... so can washing the floor near cable connectors...

    *Surges in the 120AC can damage hardware... Phone hydro, and ask if there have been any large spikes, recorded, in the system that feeds your area, from a week before the troubles began...

    *I would run a barrage of tests.. The first being to try to get any kind of connection through those wires... Then slowly work it up to wireless, doing every step accurately.. Seriously troubleshooting where the trouble first hints or starts...

    What are your proxies configs set at..?

    Have you deleted all connections, and started from step one..?

    Is there a chance that power supply plugs were mixed up..?

    Are cards in their slots secure and properly screwed down..?

    Are the main signal wires all in perfect condition..?

    Did a provider's tech do some recent work in the outside boxes, and accidentally disconnect your service..? Is the wire intact all the way to the outside box..? and all the way to the mains box..?

    Have you reinstalled the wireless CD..?

    Are you running on an account that hasn't been assigned Internet access..?

    I bet a hundred other items could be added to this list...
  9. junkforaaron

    junkforaaron Private E-2

    The DSL gateway/Wireless router are working fine. My roommates have access and I was able to connect using a wireless USB adapter I borrowed from a friend. It is a problem with my laptop. What I don't know is if it is a hardware or a software problem.

    I was able to get some screen shots of the offending software/hardware.

    Here you see that windows has detected an adapter. For a long time, there was no wireless network icon.



    I noticed sharing was on so I turned it off.


    Says it's working properly


    no conflicts

    I don't know what to do about this....

    The Broadcom software recognized the router and I "connected" but it didn't really connect.

    no connection

    after i hit the connect button, my laptop kept stalling intermittently. A process called BCMWLTRY.exe was using all the CPU. (B)road(C)o(MW)i(R)e(L)ess(TR)a(Y)?

    = = = = = = = = = = = = = = = = = = = = = = = = = = = = =
    somebody suggested that I uninstall the wireless driver and try reinstalling. Does that sound right? all of them?
  10. cat5e

    cat5e MajorGeek

  11. junkforaaron

    junkforaaron Private E-2

    sorry that doesn't help. the adapter doesnt turn on when i press Fn+F2 but somehow the software still finds the router and tries to connect to it.
  12. Monster

    Monster Guest

    An off the top reach for a straw..

    I'm out of ideas on this one.. it's one I haven't met yet...
    Last edited by a moderator: Nov 21, 2007
  13. lbmest

    lbmest MajorGeek

    Hi junkforaaron,
    According to your specs, you should have a 1394 adapter (Firewire), a modem (probably Broadcom drivers), an ethernet adapter (the Broadcom NetLink Gigabit shown in post #5 screenshot) and the Intel PRO/Wireless card.
    Unless someone has changed the wireless card, it should still be connected.
    My suggestion is to uninstall the Broadcom 802.11g Network adapter drivers and then uninstall the same device.
    Here's a link to the intel site for drivers and an identification tool.


    Upon rebooting, use the intel drivers to see if the card will show up correctly in device manager and be in working order.
    From there, maybe the wireless connection problem can be worked out.
  14. junkforaaron

    junkforaaron Private E-2

    well... popped open the case and found out that the wireless card HAD been changed.

    I have a Broadcom BCM94318mpg card

    The trouble is that i can't seem to get it installed. once in a while the computer detects it and shows it as already installed. sometimes there's no trace of it. When i unplugged the mini pct card and plugged it back in, plug-and-play identified and installed it and then prompted me to restart. After restarting ... there was no trace of the device again.

    broadcom does not supply drivers for their cards, gateway does not support it. I found some drivers online and tried to use them but their installation applications don't work either. If i got to Add/Remove Hardware in the control panel and try adding it with "have disk" i find the .inf file but it doesn't seem to read it because the "next" button stays grayed-out and there is no device on the list to select.

    I really would like to know what to do now :cry
  15. lbmest

    lbmest MajorGeek

    Well, that explains a lot of things.
    I'm wondering if there is an underlying problem with the motherboard socket that the card plugs into. If the original card has been replaced and the 2nd card is acting up. That's an expensive can of worms you probably don't want to get into.
    Getting a minicard adapter or usb adapter and disabling the internal card would be the easiest solution. Hate to say that.:eek:
    Anybody else can chime in with any other ideas, solutions, etc.
    Sorry I couldn't be of any more help. Good Luck.
  16. Monster

    Monster Guest

    My comment isn't germane to the issue so I will be quiet.
    Last edited by a moderator: Nov 21, 2007

Share This Page

MajorGeeks.Com Menu

Downloads All In One Tweaks \ Android \ Anti-Malware \ Anti-Virus \ Appearance \ Backup \ Browsers \ CD\DVD\Blu-Ray \ Covert Ops \ Drive Utilities \ Drivers \ Graphics \ Internet Tools \ Multimedia \ Networking \ Office Tools \ PC Games \ System Tools \ Mac/Apple/Ipad Downloads

Other News: Top Downloads \ News (Tech) \ Off Base (Other Websites News) \ Way Off Base (Offbeat Stories and Pics)

Social: Facebook \ YouTube \ Twitter \ Tumblr \ Pintrest \ RSS Feeds